Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Применить поиск полных совпадений в формуле массива - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Применить поиск полных совпадений в формуле массива (Формулы/Formulas)
Применить поиск полных совпадений в формуле массива
Russt Дата: Понедельник, 09.04.2018, 18:38 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!

Имеется формула

Код
=ИНДЕКС(C$1:C$14;НАИБОЛЬШИЙ(ЕСЛИ((ЕЧИСЛО(ПОИСК(D$1;A$1:A$14)))*(ЕЧИСЛО(ПОИСК("ящик";$B$1:$B$14)));СТРОКА(A$1:A$14));СТРОКА(A1)))


подскажите плиз как сделать, чтобы поиск
Код
(ПОИСК(D$1;A$1:A$14)
был по полному совпадению содержимого ячейки.
 
Ответить
СообщениеЗдравствуйте!

Имеется формула

Код
=ИНДЕКС(C$1:C$14;НАИБОЛЬШИЙ(ЕСЛИ((ЕЧИСЛО(ПОИСК(D$1;A$1:A$14)))*(ЕЧИСЛО(ПОИСК("ящик";$B$1:$B$14)));СТРОКА(A$1:A$14));СТРОКА(A1)))


подскажите плиз как сделать, чтобы поиск
Код
(ПОИСК(D$1;A$1:A$14)
был по полному совпадению содержимого ячейки.

Автор - Russt
Дата добавления - 09.04.2018 в 18:38
Karataev Дата: Понедельник, 09.04.2018, 18:43 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1208
Репутация: 456 ±
Замечаний: 0% ±

Excel
Не используйте ПОИСК:
Код
=ИНДЕКС(C$1:C$14;НАИБОЛЬШИЙ(ЕСЛИ((A$1:A$14=D$1)*(ЕЧИСЛО(ПОИСК("ящик";$B$1:$B$14)));СТРОКА(A$1:A$14));СТРОКА(A1)))

Но в данном случае будет влиять регистр букв.


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеНе используйте ПОИСК:
Код
=ИНДЕКС(C$1:C$14;НАИБОЛЬШИЙ(ЕСЛИ((A$1:A$14=D$1)*(ЕЧИСЛО(ПОИСК("ящик";$B$1:$B$14)));СТРОКА(A$1:A$14));СТРОКА(A1)))

Но в данном случае будет влиять регистр букв.

Автор - Karataev
Дата добавления - 09.04.2018 в 18:43
Russt Дата: Понедельник, 09.04.2018, 18:48 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасиба! Регистр не так важен.
 
Ответить
СообщениеСпасиба! Регистр не так важен.

Автор - Russt
Дата добавления - 09.04.2018 в 18:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Применить поиск полных совпадений в формуле массива (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!