Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование ячеек по формату ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование ячеек по формату ячейки (Формулы/Formulas)
Суммирование ячеек по формату ячейки
Gold_Barsik Дата: Среда, 11.04.2018, 23:59 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 219
Репутация: 6 ±
Замечаний: 0% ±

2003
Как сложить значения по формату ячеек, если формат: Основной "м³"
К сообщению приложен файл: _Microsoft_Exce.xls(14.0 Kb)
 
Ответить
СообщениеКак сложить значения по формату ячеек, если формат: Основной "м³"

Автор - Gold_Barsik
Дата добавления - 11.04.2018 в 23:59
Che79 Дата: Четверг, 12.04.2018, 00:27 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1269
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Вариант хулиганский. Привязка не к формату, а к строкам с форматом. Ничего более умного с ходу не придумалось. B B1
Код
=СУММПРОИЗВ(A1:A18*(ОСТАТ(СТРОКА(A1:A18);4)))
К сообщению приложен файл: 5160060.xls(27.0 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеВариант хулиганский. Привязка не к формату, а к строкам с форматом. Ничего более умного с ходу не придумалось. B B1
Код
=СУММПРОИЗВ(A1:A18*(ОСТАТ(СТРОКА(A1:A18);4)))

Автор - Che79
Дата добавления - 12.04.2018 в 00:27
Gold_Barsik Дата: Четверг, 12.04.2018, 01:07 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 219
Репутация: 6 ±
Замечаний: 0% ±

2003
Спасибо! Отчасти помогло.
 
Ответить
СообщениеСпасибо! Отчасти помогло.

Автор - Gold_Barsik
Дата добавления - 12.04.2018 в 01:07
sboy Дата: Четверг, 12.04.2018, 09:29 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1944
Репутация: 564 ±
Замечаний: 0% ±

Excel 2010
Вариант хулиганский

Код
=СУММЕСЛИ(A4:A18;">1")
 
Ответить
Сообщение
Вариант хулиганский

Код
=СУММЕСЛИ(A4:A18;">1")

Автор - sboy
Дата добавления - 12.04.2018 в 09:29
Karataev Дата: Четверг, 12.04.2018, 09:37 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1238
Репутация: 472 ±
Замечаний: 0% ±

Excel
Вариант макросом в виде пользовательской функции. Формула вставлена в "A1".
Макрос находится внутри файла. После открытия файла разрешите макросы.
В формулу выбирайте целый столбец. Макрос берет формат из первой ячейки столбца.
К сообщению приложен файл: Excel_kar.xls(35.5 Kb)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеВариант макросом в виде пользовательской функции. Формула вставлена в "A1".
Макрос находится внутри файла. После открытия файла разрешите макросы.
В формулу выбирайте целый столбец. Макрос берет формат из первой ячейки столбца.

Автор - Karataev
Дата добавления - 12.04.2018 в 09:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование ячеек по формату ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!