Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Чем заменить формулу ПОИСКПОЗ,чтоб не смещался диапазон? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Чем заменить формулу ПОИСКПОЗ,чтоб не смещался диапазон? (Формулы/Formulas)
Чем заменить формулу ПОИСКПОЗ,чтоб не смещался диапазон?
blayd2007 Дата: Пятница, 13.04.2018, 14:40 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Подскажите, пожалуйста, чем заменить формулу
Код
=ИНДЕКС('Имена'!$C$1:$C$100;ПОИСКПОЗ(ИСТИНА;ИНДЕКС('Имена'!$A$1:$A$100=D1;0);0))


Чтобы при добавлении строки на листе "Имена" диапазон не смещался, а всегда начинался с первой ячейки, вниз соответственно можно.

Спасибо!
 
Ответить
СообщениеПодскажите, пожалуйста, чем заменить формулу
Код
=ИНДЕКС('Имена'!$C$1:$C$100;ПОИСКПОЗ(ИСТИНА;ИНДЕКС('Имена'!$A$1:$A$100=D1;0);0))


Чтобы при добавлении строки на листе "Имена" диапазон не смещался, а всегда начинался с первой ячейки, вниз соответственно можно.

Спасибо!

Автор - blayd2007
Дата добавления - 13.04.2018 в 14:40
bmv98rus Дата: Пятница, 13.04.2018, 14:44 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1299
Репутация: 220 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=INDEX('ANDмена'!$C:$C,MATCH(TRUE,INDEX(INDEX('ANDмена'!$A:$A,1):'ANDмена'!$A$100=D1,0),0))


Сообщение отредактировал bmv98rus - Пятница, 13.04.2018, 15:01
 
Ответить
Сообщение
Код
=INDEX('ANDмена'!$C:$C,MATCH(TRUE,INDEX(INDEX('ANDмена'!$A:$A,1):'ANDмена'!$A$100=D1,0),0))

Автор - bmv98rus
Дата добавления - 13.04.2018 в 14:44
китин Дата: Пятница, 13.04.2018, 14:45 | Сообщение № 3
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Ну я не знаю. а если ДВССЫЛ прикрутить?
[p.s.]
[offtop]
Миша ты уверен?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 13.04.2018, 14:48
 
Ответить
СообщениеНу я не знаю. а если ДВССЫЛ прикрутить?
[p.s.]
[offtop]
Миша ты уверен?

Автор - китин
Дата добавления - 13.04.2018 в 14:45
bmv98rus Дата: Пятница, 13.04.2018, 14:58 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1299
Репутация: 220 ±
Замечаний: 0% ±

Excel 2013/2016
Игорь, нет, но примера нет, а создавать лениво, пятницо :-)
По быстрому проверил, работает
Код
=INDEX(Sheet1!$C:$C;MATCH(TRUE;INDEX(INDEX(Sheet1!$A:$A;1):Sheet1!$A$100=Sheet1!D1;0);0))

а вот выше была ошибка, разделитель перепутал.


Сообщение отредактировал bmv98rus - Пятница, 13.04.2018, 15:03
 
Ответить
СообщениеИгорь, нет, но примера нет, а создавать лениво, пятницо :-)
По быстрому проверил, работает
Код
=INDEX(Sheet1!$C:$C;MATCH(TRUE;INDEX(INDEX(Sheet1!$A:$A;1):Sheet1!$A$100=Sheet1!D1;0);0))

а вот выше была ошибка, разделитель перепутал.

Автор - bmv98rus
Дата добавления - 13.04.2018 в 14:58
pabchek Дата: Пятница, 13.04.2018, 15:07 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 899
Репутация: 215 ±
Замечаний: 0% ±

Excel 2007
Может я пятнично туплю? Но, судя по образцу формулы, в колонке А ищем соответствие D1 и выводим результат из С. В таком случае
Код
=ИНДЕКС(C:C;ПОИСКПОЗ(D1;A:A;0))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеМожет я пятнично туплю? Но, судя по образцу формулы, в колонке А ищем соответствие D1 и выводим результат из С. В таком случае
Код
=ИНДЕКС(C:C;ПОИСКПОЗ(D1;A:A;0))

Автор - pabchek
Дата добавления - 13.04.2018 в 15:07
blayd2007 Дата: Пятница, 13.04.2018, 15:18 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
bmv98rus, Спасибо за наводку, немного подправил свою, вроде работает, подскажите, а в чем разница между
Код
=ИНДЕКС('Имена'!$C:$C;ПОИСКПОЗ(ИСТИНА;ИНДЕКС('Имена'!$A:$A=D1;0);0))


и вариантом, который вы добавили?
Код
=ИНДЕКС(Sheet1!$C:$C;ПОИСКПОЗ(ИСТИНА;ИНДЕКС(ИНДЕКС(Sheet1!$A:$A;1):Sheet1!$A$100=Sheet1!D1;0);0))


Подскажите пожалуйста?
 
Ответить
Сообщениеbmv98rus, Спасибо за наводку, немного подправил свою, вроде работает, подскажите, а в чем разница между
Код
=ИНДЕКС('Имена'!$C:$C;ПОИСКПОЗ(ИСТИНА;ИНДЕКС('Имена'!$A:$A=D1;0);0))


и вариантом, который вы добавили?
Код
=ИНДЕКС(Sheet1!$C:$C;ПОИСКПОЗ(ИСТИНА;ИНДЕКС(ИНДЕКС(Sheet1!$A:$A;1):Sheet1!$A$100=Sheet1!D1;0);0))


Подскажите пожалуйста?

Автор - blayd2007
Дата добавления - 13.04.2018 в 15:18
blayd2007 Дата: Пятница, 13.04.2018, 15:31 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
pabchek, Спасибо, конечно все верно! Просто все думал как уйти от диапазона, понимаю что можно, но как реализовать-провал.
Вот как только увидел пример от bmv98rus, сразу этот вопрос прояснился и вы это подтвердили. Писал, не видя еще ваш вариант.
Оставил вариант
Код
=ИНДЕКС('Марки НП'!$C:$C;ПОИСКПОЗ(D1;'Марки НП'!$A:$A;0))


Спасибо!
 
Ответить
Сообщениеpabchek, Спасибо, конечно все верно! Просто все думал как уйти от диапазона, понимаю что можно, но как реализовать-провал.
Вот как только увидел пример от bmv98rus, сразу этот вопрос прояснился и вы это подтвердили. Писал, не видя еще ваш вариант.
Оставил вариант
Код
=ИНДЕКС('Марки НП'!$C:$C;ПОИСКПОЗ(D1;'Марки НП'!$A:$A;0))


Спасибо!

Автор - blayd2007
Дата добавления - 13.04.2018 в 15:31
bmv98rus Дата: Пятница, 13.04.2018, 15:59 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1299
Репутация: 220 ±
Замечаний: 0% ±

Excel 2013/2016
и вариантом, который вы добавили?

Ну в данном случае не важно и как видно в первой части моей формулы, так и есть, но в некоторых случаях надо сдерживать себя и не кормить функциям, которые не умеют ограничивать область обработки реально используемой областью, целые столбцы, и сокрушатся потом, что считает медленно. Ну и, так как примера нет, то вдруг у вас со 101 строки идет другая таблица, которую учитывать не стоит.
 
Ответить
Сообщение
и вариантом, который вы добавили?

Ну в данном случае не важно и как видно в первой части моей формулы, так и есть, но в некоторых случаях надо сдерживать себя и не кормить функциям, которые не умеют ограничивать область обработки реально используемой областью, целые столбцы, и сокрушатся потом, что считает медленно. Ну и, так как примера нет, то вдруг у вас со 101 строки идет другая таблица, которую учитывать не стоит.

Автор - bmv98rus
Дата добавления - 13.04.2018 в 15:59
blayd2007 Дата: Пятница, 13.04.2018, 19:33 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Да нет, максимум 10 строк.

Теперь я понял разницу, можно чтоб не менялся, но с ограничением до 100 строки.

Спасибо большое всем!


Сообщение отредактировал blayd2007 - Пятница, 13.04.2018, 19:35
 
Ответить
СообщениеДа нет, максимум 10 строк.

Теперь я понял разницу, можно чтоб не менялся, но с ограничением до 100 строки.

Спасибо большое всем!

Автор - blayd2007
Дата добавления - 13.04.2018 в 19:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Чем заменить формулу ПОИСКПОЗ,чтоб не смещался диапазон? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!