Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт соц.услуг специалистов для семей по категориям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт соц.услуг специалистов для семей по категориям (Формулы/Formulas)
Подсчёт соц.услуг специалистов для семей по категориям
Wrascon Дата: Суббота, 14.04.2018, 16:29 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. Недавно помогал центру с переходом от бумажного в цифровой учёт табелей услуг. Производится пересчёт оказанных услуг 4 специалистов матерям и детям в нескольких категориях. Вёл услуги по специалистам для каждой семьи. Ближе к концу месяца по этим данным понадобилось сделать два листа с отчётами: один общий по услугам матерей и детей, другой отдельно для каждой семьи.
В общем отчёте суммируется диапазон (листы {:}) постоянных семей по дополнительным таблицам и формула всегда привязывается к одной ячейке. Из-за этого после добавления новой услуги таблица сместится и будет выдавать неверный результат.
Для срочной семьи подсчитывает только по её собственному листу. Листы всегда имеют фамилию и инициалы семьи, у меня не удаётся сделать привязку формулы к ячейки с названием листа.
Заблокировал на всех листах ячейки с формулами, серые ячейки доступны для редактирования.
Возник вопрос как с помощью ячейки, указывающей на лист семьи сделать вывод списка членов семьи и провести подсчёт услуг для них каждым специалистом?

Таблица на яндекс диске Ссылка удалена. Нарушение Правил форума

P.S. Также моя тема на других форумах
Форум программистов
Планета Excel
Киберфорум
К сообщению приложен файл: ____2018.xlsb(90.6 Kb)


Сообщение отредактировал Pelena - Воскресенье, 15.04.2018, 23:04
 
Ответить
СообщениеЗдравствуйте. Недавно помогал центру с переходом от бумажного в цифровой учёт табелей услуг. Производится пересчёт оказанных услуг 4 специалистов матерям и детям в нескольких категориях. Вёл услуги по специалистам для каждой семьи. Ближе к концу месяца по этим данным понадобилось сделать два листа с отчётами: один общий по услугам матерей и детей, другой отдельно для каждой семьи.
В общем отчёте суммируется диапазон (листы {:}) постоянных семей по дополнительным таблицам и формула всегда привязывается к одной ячейке. Из-за этого после добавления новой услуги таблица сместится и будет выдавать неверный результат.
Для срочной семьи подсчитывает только по её собственному листу. Листы всегда имеют фамилию и инициалы семьи, у меня не удаётся сделать привязку формулы к ячейки с названием листа.
Заблокировал на всех листах ячейки с формулами, серые ячейки доступны для редактирования.
Возник вопрос как с помощью ячейки, указывающей на лист семьи сделать вывод списка членов семьи и провести подсчёт услуг для них каждым специалистом?

Таблица на яндекс диске Ссылка удалена. Нарушение Правил форума

P.S. Также моя тема на других форумах
Форум программистов
Планета Excel
Киберфорум

Автор - Wrascon
Дата добавления - 14.04.2018 в 16:29
Wrascon Дата: Воскресенье, 15.04.2018, 16:40 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
По листу "Семейный отчёт"
Код
=СУММЕСЛИМН('Семья с 1'!C5:AG5;'Семья с 1'!C3:AG3;C$3)

Как будет правильнее разбить эту формулу для пересчёта через ячуйку, указывающую на отдельную семью?
Пробовал следующую, где $A$2 название листа нужной семьи, C5:AG5 месячный диапазон услуги, C3:AG3 месячная смена специалистов, C$3 специалист, по которому нужно провести подсчёты.
Код
=СУММЕСЛИМН(ДВССЫЛ($A$2&"!"&C5:AG5);ДВССЫЛ($A$2&"!"&C3:AG3);C$3)

Помимо этой функции мне нужно узнать как вывести список семьи по ячейкам "Мать:", "Ребёнок 1:", "Ребёнок 2: ", "Ребёнок 3: ", "Ребёнок 4: ", "Ребёнок 5: "

По листу "Общий отчёт"
Единственное меня не покидает опасение, что формула по всем листам указанного диапазона "{:}" не адаптируется под изменения в таблице. Любое изменение даже во всех листах оставит операцию на той же самой ячейке
Код
=СУММ('{:}'!AJ14)

У детей всё куда хуже. После добавления новой услуги все ячейки придётся указывать вручную для каждого ребёнка снова
Код
=СУММ('{:}'!AJ49;'{:}'!AJ88;'{:}'!AJ127;'{:}'!AJ166;'{:}'!AJ205)
 
Ответить
СообщениеПо листу "Семейный отчёт"
Код
=СУММЕСЛИМН('Семья с 1'!C5:AG5;'Семья с 1'!C3:AG3;C$3)

Как будет правильнее разбить эту формулу для пересчёта через ячуйку, указывающую на отдельную семью?
Пробовал следующую, где $A$2 название листа нужной семьи, C5:AG5 месячный диапазон услуги, C3:AG3 месячная смена специалистов, C$3 специалист, по которому нужно провести подсчёты.
Код
=СУММЕСЛИМН(ДВССЫЛ($A$2&"!"&C5:AG5);ДВССЫЛ($A$2&"!"&C3:AG3);C$3)

Помимо этой функции мне нужно узнать как вывести список семьи по ячейкам "Мать:", "Ребёнок 1:", "Ребёнок 2: ", "Ребёнок 3: ", "Ребёнок 4: ", "Ребёнок 5: "

По листу "Общий отчёт"
Единственное меня не покидает опасение, что формула по всем листам указанного диапазона "{:}" не адаптируется под изменения в таблице. Любое изменение даже во всех листах оставит операцию на той же самой ячейке
Код
=СУММ('{:}'!AJ14)

У детей всё куда хуже. После добавления новой услуги все ячейки придётся указывать вручную для каждого ребёнка снова
Код
=СУММ('{:}'!AJ49;'{:}'!AJ88;'{:}'!AJ127;'{:}'!AJ166;'{:}'!AJ205)

Автор - Wrascon
Дата добавления - 15.04.2018 в 16:40
Pelena Дата: Воскресенье, 15.04.2018, 19:28 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12620
Репутация: 2775 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Wrascon, файл надо прикладывать к сообщению. Таблицы можно сократить.
И надеюсь там нет конфиденциальных данных


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеWrascon, файл надо прикладывать к сообщению. Таблицы можно сократить.
И надеюсь там нет конфиденциальных данных

Автор - Pelena
Дата добавления - 15.04.2018 в 19:28
Wrascon Дата: Воскресенье, 15.04.2018, 21:22 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Извините, не заметил как удалилась ссылка с яндекс диска. На тот момент табица весила 169КБ и я не успел сжать её до 100. Думал смена формата поможет, но та только раздулась до 497КБ.
Если под сокращением таблицы вы имеете ввиду удаление лишних строк со сменой и датой, то это не подойдёт, т.к. на бумаге принято печатать отчёты вместе с ними.
Как говориться "Все события и герои вымышлены. Любые совпадения с реальными личностями случайны" Не думаю, что кого-то это побеспокоит.
Сейчас залью упрощённый файл пример
 
Ответить
СообщениеPelena, Извините, не заметил как удалилась ссылка с яндекс диска. На тот момент табица весила 169КБ и я не успел сжать её до 100. Думал смена формата поможет, но та только раздулась до 497КБ.
Если под сокращением таблицы вы имеете ввиду удаление лишних строк со сменой и датой, то это не подойдёт, т.к. на бумаге принято печатать отчёты вместе с ними.
Как говориться "Все события и герои вымышлены. Любые совпадения с реальными личностями случайны" Не думаю, что кого-то это побеспокоит.
Сейчас залью упрощённый файл пример

Автор - Wrascon
Дата добавления - 15.04.2018 в 21:22
Wrascon Дата: Воскресенье, 15.04.2018, 22:34 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Я оставил 1 семью из 3, с 2 детьми из 5, вес .xlsx сократился со 169 до 83, а при конвертации в .xls что было 497, то стало 294. Залить 83МБ .xlsx версии конечно же сюда нельзя, а в старой .xls все функции перестали работать. Если речь идёт об обрубленном примере с двумя ячейками из используемых формул, где не соблюдается порядок с изложенной мыслью и оказание услуги детей отличается от взрослых отсутствием целых категорий, проще написать их тут, чем подогнать пример с такими ограничениями. Поправьте меня, если я чего-то не понимаю и есть способ легче поделиться таблицей.
 
Ответить
СообщениеЯ оставил 1 семью из 3, с 2 детьми из 5, вес .xlsx сократился со 169 до 83, а при конвертации в .xls что было 497, то стало 294. Залить 83МБ .xlsx версии конечно же сюда нельзя, а в старой .xls все функции перестали работать. Если речь идёт об обрубленном примере с двумя ячейками из используемых формул, где не соблюдается порядок с изложенной мыслью и оказание услуги детей отличается от взрослых отсутствием целых категорий, проще написать их тут, чем подогнать пример с такими ограничениями. Поправьте меня, если я чего-то не понимаю и есть способ легче поделиться таблицей.

Автор - Wrascon
Дата добавления - 15.04.2018 в 22:34
Pelena Дата: Воскресенье, 15.04.2018, 23:04 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12620
Репутация: 2775 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Я убрала одну семью и сохранила в .xlsb, получилось 91 Кб, вполне пролезет на форум.
Приложила к первому сообщению


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЯ убрала одну семью и сохранила в .xlsb, получилось 91 Кб, вполне пролезет на форум.
Приложила к первому сообщению

Автор - Pelena
Дата добавления - 15.04.2018 в 23:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт соц.услуг специалистов для семей по категориям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!