Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма с тремя условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма с тремя условиями (Формулы/Formulas)
Сумма с тремя условиями
lapin9126 Дата: Вторник, 17.04.2018, 11:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте уважаемые форумчане, помогите с формулой: суть которой в следующем
Если в любой из ячеек С и D значение больше 0, то суммируем ту ячейку в которой это значение со значением ячейки E (+10), если в ячейках С и D 0, то сумма равна 0, если в обеих ячейках значение больше 0, то суммируем значение обеих ячеек со значением ячейки F (+15). Заминка с последним условием.
Код
=ЕСЛИ(C2>0;C2+E2;ЕСЛИ(C2+D2=0;0;ЕСЛИ(C2=0;D2+E2;ЕСЛИ(D2=0;0;ЕСЛИ(D2>0;D2+E2)))))
К сообщению приложен файл: Na_forum_1.xlsx(9.0 Kb)


Сообщение отредактировал lapin9126 - Вторник, 17.04.2018, 11:55
 
Ответить
СообщениеЗдравствуйте уважаемые форумчане, помогите с формулой: суть которой в следующем
Если в любой из ячеек С и D значение больше 0, то суммируем ту ячейку в которой это значение со значением ячейки E (+10), если в ячейках С и D 0, то сумма равна 0, если в обеих ячейках значение больше 0, то суммируем значение обеих ячеек со значением ячейки F (+15). Заминка с последним условием.
Код
=ЕСЛИ(C2>0;C2+E2;ЕСЛИ(C2+D2=0;0;ЕСЛИ(C2=0;D2+E2;ЕСЛИ(D2=0;0;ЕСЛИ(D2>0;D2+E2)))))

Автор - lapin9126
Дата добавления - 17.04.2018 в 11:53
sboy Дата: Вторник, 17.04.2018, 12:03 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2230
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вот такой вариант
Код
=(C2+D2)+ВЫБОР((C2>0)+(D2>0)+1;;E2;F2)
К сообщению приложен файл: 4138194.xlsx(8.7 Kb)
 
Ответить
СообщениеДобрый день.
Вот такой вариант
Код
=(C2+D2)+ВЫБОР((C2>0)+(D2>0)+1;;E2;F2)

Автор - sboy
Дата добавления - 17.04.2018 в 12:03
lapin9126 Дата: Вторник, 17.04.2018, 12:06 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
sboy, Огромное спасибо, то что нужно.
 
Ответить
Сообщениеsboy, Огромное спасибо, то что нужно.

Автор - lapin9126
Дата добавления - 17.04.2018 в 12:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма с тремя условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!