Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Не выполняется условие в ячейках с другими формулами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не выполняется условие в ячейках с другими формулами (Формулы/Formulas)
Не выполняется условие в ячейках с другими формулами
Risovod Дата: Воскресенье, 29.04.2018, 15:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.

Помогите пожалуйста создать/исправить формулу (желательно для MS Excel 2003). Дело в том, что ниже приведенная формула работает со строками где имеются только значения, но не хочет работать там, где имеются другие формулы.
Код
{=ЕСЛИ(ЕОШИБКА(СУММ(ЕСЛИ(B$4:M$4="га";ЕСЛИ(B25:M25;B25:M25);"")));"";СУММ(ЕСЛИ(B$4:M$4="га";ЕСЛИ(B25:M25;B25:M25);"")))}

В прикрепленном примере выделил ячейки зеленым цветом где одна и та же формула работает и жёлтым цветом - где не работает.
К сообщению приложен файл: 3770319.xls(30.5 Kb)


Сообщение отредактировал Risovod - Воскресенье, 29.04.2018, 15:21
 
Ответить
СообщениеЗдравствуйте.

Помогите пожалуйста создать/исправить формулу (желательно для MS Excel 2003). Дело в том, что ниже приведенная формула работает со строками где имеются только значения, но не хочет работать там, где имеются другие формулы.
Код
{=ЕСЛИ(ЕОШИБКА(СУММ(ЕСЛИ(B$4:M$4="га";ЕСЛИ(B25:M25;B25:M25);"")));"";СУММ(ЕСЛИ(B$4:M$4="га";ЕСЛИ(B25:M25;B25:M25);"")))}

В прикрепленном примере выделил ячейки зеленым цветом где одна и та же формула работает и жёлтым цветом - где не работает.

Автор - Risovod
Дата добавления - 29.04.2018 в 15:20
Pelena Дата: Воскресенье, 29.04.2018, 15:39 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12686
Репутация: 2790 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Посмотрите такие варианты
К сообщению приложен файл: 7893667.xls(44.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Посмотрите такие варианты

Автор - Pelena
Дата добавления - 29.04.2018 в 15:39
Risovod Дата: Воскресенье, 29.04.2018, 16:03 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Спасибо.
Сумму понравилось как считает.
Подскажите можно ли модернизировать Вашу формулу для расчета среднего значения с применением Вашей же формулы для расчета суммы, т.е. как-то так:
Код
=СУММЕСЛИ($B$4:$M$4;"ц/га";B5:M5)/СЧЁТЕСЛИ($B$4:$M$4;"ц/га";B5:M5)

Как правильно это сделать?
 
Ответить
СообщениеPelena, Спасибо.
Сумму понравилось как считает.
Подскажите можно ли модернизировать Вашу формулу для расчета среднего значения с применением Вашей же формулы для расчета суммы, т.е. как-то так:
Код
=СУММЕСЛИ($B$4:$M$4;"ц/га";B5:M5)/СЧЁТЕСЛИ($B$4:$M$4;"ц/га";B5:M5)

Как правильно это сделать?

Автор - Risovod
Дата добавления - 29.04.2018 в 16:03
Pelena Дата: Понедельник, 30.04.2018, 13:38 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12686
Репутация: 2790 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Дело в том, что в Вашем случае при подсчёте количества нужно учитывать ещё одно условие, что ячейка непустая. В Excel 2003 нет функции СЧЁТЕСЛИМН, а также нет функции СРЗНАЧЕСЛИ, поэтому я и использовала СУММПРОИЗВ


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДело в том, что в Вашем случае при подсчёте количества нужно учитывать ещё одно условие, что ячейка непустая. В Excel 2003 нет функции СЧЁТЕСЛИМН, а также нет функции СРЗНАЧЕСЛИ, поэтому я и использовала СУММПРОИЗВ

Автор - Pelena
Дата добавления - 30.04.2018 в 13:38
Risovod Дата: Понедельник, 30.04.2018, 15:27 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Pelena,
Ясно. Вопрос решен.
 
Ответить
СообщениеPelena,
Ясно. Вопрос решен.

Автор - Risovod
Дата добавления - 30.04.2018 в 15:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не выполняется условие в ячейках с другими формулами (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!