Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбор сведений из базы данных. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор сведений из базы данных. (Формулы/Formulas)
Сбор сведений из базы данных.
Boris1983 Дата: Понедельник, 30.04.2018, 12:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, вечер, ..... :D
По работе необходимо ежедневно отслеживать состояние заказов по определенным критериям используя базу данных.
Можно воспользоваться фильтром hands и отслеживать каждый показатель, выписывая на бумагу, забивать в таблицу и т.д. %)
Хочется облегчить себе работу чтобы оставалось время на beer yahoo
Помогите с решением.
Суть вопроса.
На листе `Статистика` в зависимости от периода запроса данные автоматически из базы данных листа `Результаты запроса`отображались на против Офиса заказа по определенный критериям. Т.Е. в зависимости от периода заказов с 24 по 27.0.42018 сформировать таблицу ОФИС - железнодорожный - заказов 3 - Оплачено 1 - Не оплачено 2 - Просрочено 0.
Чувствую, что нужна формула массива со множественными формулами если и соответствующего подсчета. Но как все это воплотить в жизнь ?????
За ранее Спасибо.
К сообщению приложен файл: 4794262.xlsx(70.8 Kb)
 
Ответить
СообщениеДобрый день, вечер, ..... :D
По работе необходимо ежедневно отслеживать состояние заказов по определенным критериям используя базу данных.
Можно воспользоваться фильтром hands и отслеживать каждый показатель, выписывая на бумагу, забивать в таблицу и т.д. %)
Хочется облегчить себе работу чтобы оставалось время на beer yahoo
Помогите с решением.
Суть вопроса.
На листе `Статистика` в зависимости от периода запроса данные автоматически из базы данных листа `Результаты запроса`отображались на против Офиса заказа по определенный критериям. Т.Е. в зависимости от периода заказов с 24 по 27.0.42018 сформировать таблицу ОФИС - железнодорожный - заказов 3 - Оплачено 1 - Не оплачено 2 - Просрочено 0.
Чувствую, что нужна формула массива со множественными формулами если и соответствующего подсчета. Но как все это воплотить в жизнь ?????
За ранее Спасибо.

Автор - Boris1983
Дата добавления - 30.04.2018 в 12:48
китин Дата: Понедельник, 30.04.2018, 13:24 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброго времени!!!
нужна формула массива

зачем?
Код
=СУММПРОИЗВ(('Результаты запроса'!$K$2:$K$613=Статистика!$G5)*($G$3<='Результаты запроса'!$A$2:$A$613)*($H$3>='Результаты запроса'!$A$2:$A$613))

только в вашем файле приведите все одинаковые названия к единообразию, а то у вас "Железнодорожному" тремя разными способами написано :D ( пробелы мать их)
и я ва там переделал в Результаты запроса статусы заказов, как в Статистике, что бы формула полегче была
К сообщению приложен файл: Boris1983.xlsx(72.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДоброго времени!!!
нужна формула массива

зачем?
Код
=СУММПРОИЗВ(('Результаты запроса'!$K$2:$K$613=Статистика!$G5)*($G$3<='Результаты запроса'!$A$2:$A$613)*($H$3>='Результаты запроса'!$A$2:$A$613))

только в вашем файле приведите все одинаковые названия к единообразию, а то у вас "Железнодорожному" тремя разными способами написано :D ( пробелы мать их)
и я ва там переделал в Результаты запроса статусы заказов, как в Статистике, что бы формула полегче была

Автор - китин
Дата добавления - 30.04.2018 в 13:24
abtextime Дата: Понедельник, 30.04.2018, 13:27 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 828
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Или через СУММЕСЛИМН()

Код
=СЧЁТЕСЛИМН('Результаты запроса'!$A$2:$A$613;">="&$G$3;'Результаты запроса'!$A$2:$A$613;"<="&$H$3;'Результаты запроса'!$K$2:$K$613;G5)


Код
=СЧЁТЕСЛИМН('Результаты запроса'!$A$2:$A$613;">="&$G$3;'Результаты запроса'!$A$2:$A$613;"<="&$H$3;'Результаты запроса'!$K$2:$K$613;$G5;'Результаты запроса'!$G$2:$G$613;I$4)


чуток поправил названия в 4 строке
К сообщению приложен файл: 2675839.xlsx(72.4 Kb)
 
Ответить
СообщениеИли через СУММЕСЛИМН()

Код
=СЧЁТЕСЛИМН('Результаты запроса'!$A$2:$A$613;">="&$G$3;'Результаты запроса'!$A$2:$A$613;"<="&$H$3;'Результаты запроса'!$K$2:$K$613;G5)


Код
=СЧЁТЕСЛИМН('Результаты запроса'!$A$2:$A$613;">="&$G$3;'Результаты запроса'!$A$2:$A$613;"<="&$H$3;'Результаты запроса'!$K$2:$K$613;$G5;'Результаты запроса'!$G$2:$G$613;I$4)


чуток поправил названия в 4 строке

Автор - abtextime
Дата добавления - 30.04.2018 в 13:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор сведений из базы данных. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!