Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Массив данных с соседнего листа по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Массив данных с соседнего листа по условию (Формулы/Formulas)
Массив данных с соседнего листа по условию
stoniq Дата: Четверг, 03.05.2018, 17:26 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 67
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Всем добрый день!
Вытягиваю с соседнего листа массив данных по определенным условиям, в моём случае это город "Москва". Подскажите, как правильно добавить еще несколько условий? Допустим должность "Водитель", и стаж более 3-х лет "ДА".
К сообщению приложен файл: 5849680.xlsx(9.9 Kb)
 
Ответить
СообщениеВсем добрый день!
Вытягиваю с соседнего листа массив данных по определенным условиям, в моём случае это город "Москва". Подскажите, как правильно добавить еще несколько условий? Допустим должность "Водитель", и стаж более 3-х лет "ДА".

Автор - stoniq
Дата добавления - 03.05.2018 в 17:26
Manyasha Дата: Четверг, 03.05.2018, 17:34 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 2193
Репутация: 892 ±
Замечаний: 0% ±

Excel 2010, 2016
stoniq, здравствуйте, например так:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Общая!$A:$A;НАИМЕНЬШИЙ(ЕСЛИ((Общая!$B:$B="Москва")*(Общая!$C:$C="Водитель")*(Общая!$D:$D="ДА");СТРОКА(Общая!$B:$B));СТРОКА(A1)));"")


UPD
Диапазоны лучше ограничить:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Общая!$A$1:$A$1000;НАИМЕНЬШИЙ(ЕСЛИ((Общая!$B$1:$B$1000="Москва")*(Общая!$C$1:$C$1000="Водитель")*(Общая!$D$1:$D$1000="ДА");СТРОКА(Общая!$B$1:$B$1000));СТРОКА(A1)));"")
К сообщению приложен файл: 5849680-1.xlsx(10.1 Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804


Сообщение отредактировал Manyasha - Четверг, 03.05.2018, 17:35
 
Ответить
Сообщениеstoniq, здравствуйте, например так:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Общая!$A:$A;НАИМЕНЬШИЙ(ЕСЛИ((Общая!$B:$B="Москва")*(Общая!$C:$C="Водитель")*(Общая!$D:$D="ДА");СТРОКА(Общая!$B:$B));СТРОКА(A1)));"")


UPD
Диапазоны лучше ограничить:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Общая!$A$1:$A$1000;НАИМЕНЬШИЙ(ЕСЛИ((Общая!$B$1:$B$1000="Москва")*(Общая!$C$1:$C$1000="Водитель")*(Общая!$D$1:$D$1000="ДА");СТРОКА(Общая!$B$1:$B$1000));СТРОКА(A1)));"")

Автор - Manyasha
Дата добавления - 03.05.2018 в 17:34
stoniq Дата: Четверг, 03.05.2018, 17:44 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 67
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Manyasha, всё отлично работает, большое Вам спасибо!
 
Ответить
СообщениеManyasha, всё отлично работает, большое Вам спасибо!

Автор - stoniq
Дата добавления - 03.05.2018 в 17:44
_Boroda_ Дата: Четверг, 03.05.2018, 17:49 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13245
Репутация: 5454 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Попробуйте еще сводной таблицей. Ее, правда нужно обновлять (вручную или макросом), но зато работает гораздо быстрее формул
К сообщению приложен файл: 5849680_1.xlsx(14.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПопробуйте еще сводной таблицей. Ее, правда нужно обновлять (вручную или макросом), но зато работает гораздо быстрее формул

Автор - _Boroda_
Дата добавления - 03.05.2018 в 17:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Массив данных с соседнего листа по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!