Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если делится пополам, то оставлять - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если делится пополам, то оставлять (Формулы/Formulas)
Если делится пополам, то оставлять
Aimod Дата: Пятница, 11.05.2018, 12:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день всем!
Горю, помогите, собственно, в файле должно быть все понятно - три столбца, искомый в середине, условия:
Столбец В - если "С" делится на "А" пополам, то оставлять это число.
Столбец В - если "С" делится на "А" на четыре, то оставлять половину.
К сообщению приложен файл: 1381960.xlsx(30.8 Kb)
 
Ответить
СообщениеДобрый день всем!
Горю, помогите, собственно, в файле должно быть все понятно - три столбца, искомый в середине, условия:
Столбец В - если "С" делится на "А" пополам, то оставлять это число.
Столбец В - если "С" делится на "А" на четыре, то оставлять половину.

Автор - Aimod
Дата добавления - 11.05.2018 в 12:47
abtextime Дата: Пятница, 11.05.2018, 12:55 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 743
Репутация: 102 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(C2/2=A2;C2;ЕСЛИ(C2/4=A2;C2/2;"неформат"))
К сообщению приложен файл: 1290297.xlsx(32.4 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(C2/2=A2;C2;ЕСЛИ(C2/4=A2;C2/2;"неформат"))

Автор - abtextime
Дата добавления - 11.05.2018 в 12:55
китин Дата: Пятница, 11.05.2018, 12:55 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4813
Репутация: 769 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
в В2
Код
=ЕСЛИ(A2*2=C2;A2;ЕСЛИ(A2*4=C2;C2/2;""))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениев В2
Код
=ЕСЛИ(A2*2=C2;A2;ЕСЛИ(A2*4=C2;C2/2;""))

Автор - китин
Дата добавления - 11.05.2018 в 12:55
Aimod Дата: Пятница, 11.05.2018, 12:59 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
СПасибо, друзья! смотрю
PS: Супер, спасибо!


Сообщение отредактировал Aimod - Пятница, 11.05.2018, 13:08
 
Ответить
СообщениеСПасибо, друзья! смотрю
PS: Супер, спасибо!

Автор - Aimod
Дата добавления - 11.05.2018 в 12:59
Nic70y Дата: Пятница, 11.05.2018, 13:35 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4618
Репутация: 996 ±
Замечаний: 0% ±

Excel 2013
для разнообразия
Код
C2/(C2/A2/2)
Код
=ЕСЛИ(C2/A2=ЦЕЛОЕ(C2/A2);C2/(C2/A2/2);"")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениедля разнообразия
Код
C2/(C2/A2/2)
Код
=ЕСЛИ(C2/A2=ЦЕЛОЕ(C2/A2);C2/(C2/A2/2);"")

Автор - Nic70y
Дата добавления - 11.05.2018 в 13:35
Pelena Дата: Пятница, 11.05.2018, 13:59 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12686
Репутация: 2790 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
C2/(C2/A2/2)

Код
=A2*2

:)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
C2/(C2/A2/2)

Код
=A2*2

:)

Автор - Pelena
Дата добавления - 11.05.2018 в 13:59
sboy Дата: Пятница, 11.05.2018, 14:37 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1738
Репутация: 492 ±
Замечаний: 0% ±

Excel 2010
для разнообразия

массивная
Код
=СУММ((A2*{2;4}=C2)*(A2*{1;2}))
 
Ответить
Сообщение
для разнообразия

массивная
Код
=СУММ((A2*{2;4}=C2)*(A2*{1;2}))

Автор - sboy
Дата добавления - 11.05.2018 в 14:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если делится пополам, то оставлять (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!