Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как подсчитать количество цифр (0-9) в массиве - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как подсчитать количество цифр (0-9) в массиве (И отоброжение их по типу "каких - сколько")
Как подсчитать количество цифр (0-9) в массиве
ded2000ded Дата: Суббота, 12.05.2018, 00:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: -1 ±
Замечаний: 0% ±

Excel 2003
Доброе время суток! Есть такой вопрос: массив А1:А100 в котором есть разное количество цифр от 0 до 9. Каким образом подсчитать количество "0", "1", "2" и т.д., и отобразить результат для "1" к примеру в ячейку В2, для "2" к примеру в ячейку В3, для "3" к примеру в ячейку В3 и т.д. Заранее благодарен...
 
Ответить
СообщениеДоброе время суток! Есть такой вопрос: массив А1:А100 в котором есть разное количество цифр от 0 до 9. Каким образом подсчитать количество "0", "1", "2" и т.д., и отобразить результат для "1" к примеру в ячейку В2, для "2" к примеру в ячейку В3, для "3" к примеру в ячейку В3 и т.д. Заранее благодарен...

Автор - ded2000ded
Дата добавления - 12.05.2018 в 00:48
Che79 Дата: Суббота, 12.05.2018, 01:21 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1271
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте. Так нужно? В В2
Код
=ЕСЛИ(СТРОКА()>11;"";СЧЁТЕСЛИ($A$1:$A$100;(СТРОКА()-1)*(СТРОКА()<11)))
Если не угадал, то выкладывайте файл-пример
К сообщению приложен файл: 847589.xlsx(10.3 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте. Так нужно? В В2
Код
=ЕСЛИ(СТРОКА()>11;"";СЧЁТЕСЛИ($A$1:$A$100;(СТРОКА()-1)*(СТРОКА()<11)))
Если не угадал, то выкладывайте файл-пример

Автор - Che79
Дата добавления - 12.05.2018 в 01:21
Светлый Дата: Суббота, 12.05.2018, 08:39 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 560
Репутация: 132 ±
Замечаний: 0% ±

Excel 2007
Доброе утро!
Такая формула:
Код
=СУММПРОИЗВ(ДЛСТР(A$1:A$100)-ДЛСТР(ПОДСТАВИТЬ(A$1:A$100;СТРОКА()-2;)))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДоброе утро!
Такая формула:
Код
=СУММПРОИЗВ(ДЛСТР(A$1:A$100)-ДЛСТР(ПОДСТАВИТЬ(A$1:A$100;СТРОКА()-2;)))

Автор - Светлый
Дата добавления - 12.05.2018 в 08:39
ded2000ded Дата: Суббота, 12.05.2018, 17:04 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: -1 ±
Замечаний: 0% ±

Excel 2003
Проблему решил сам: =СЧЁТЕСЛИ(D1:D115;0) , где массив с цифрами 0-9, далее критерий 0..., где массив с цифрами 0-9, далее критерий 1..., где массив с цифрами 0-9, далее критерий 2... и так далее. Всем спасибо. Всем свободны. Тему думаю закрыть
 
Ответить
СообщениеПроблему решил сам: =СЧЁТЕСЛИ(D1:D115;0) , где массив с цифрами 0-9, далее критерий 0..., где массив с цифрами 0-9, далее критерий 1..., где массив с цифрами 0-9, далее критерий 2... и так далее. Всем спасибо. Всем свободны. Тему думаю закрыть

Автор - ded2000ded
Дата добавления - 12.05.2018 в 17:04
_Boroda_ Дата: Суббота, 12.05.2018, 19:12 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12749
Репутация: 5227 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Проблему решил сам
Поздавляю
Всем свободны
Спасибо. Так мы пойдем, да? Вы точно нас отпустили?
А теперь серьезно:
Прочитайте Правила форума
Засуньте формулу из предыдущего сообщения в спецтеги - кнопка fx
В следующий раз обязательно прикладывайте файл-пример


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Проблему решил сам
Поздавляю
Всем свободны
Спасибо. Так мы пойдем, да? Вы точно нас отпустили?
А теперь серьезно:
Прочитайте Правила форума
Засуньте формулу из предыдущего сообщения в спецтеги - кнопка fx
В следующий раз обязательно прикладывайте файл-пример

Автор - _Boroda_
Дата добавления - 12.05.2018 в 19:12
Pelena Дата: Суббота, 12.05.2018, 21:15 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12905
Репутация: 2843 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
[offtop]
и так далее
хорошо, что цифр всего десять :D
[/offtop]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение[offtop]
и так далее
хорошо, что цифр всего десять :D
[/offtop]

Автор - Pelena
Дата добавления - 12.05.2018 в 21:15
bmv98rus Дата: Суббота, 12.05.2018, 22:28 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1261
Репутация: 214 ±
Замечаний: 0% ±

Excel 2013/2016
хорошо, что цифр всего

ну енто в десятичной системе :-)
 
Ответить
Сообщение
хорошо, что цифр всего

ну енто в десятичной системе :-)

Автор - bmv98rus
Дата добавления - 12.05.2018 в 22:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как подсчитать количество цифр (0-9) в массиве (И отоброжение их по типу "каких - сколько")
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!