Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/постановка значения в ячейку при нескольких условиях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » постановка значения в ячейку при нескольких условиях (Формулы/Formulas)
постановка значения в ячейку при нескольких условиях
nespica Дата: Среда, 30.05.2018, 12:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, уважаемые форумчане!
помогите пжлст
имею файл табличного наряда, установил некоторые формулы и застопорился, далее нужна помощь.
имеются справочники (после мучений создал общий), в пятой строке Лист2 (из созданого списка ='сводный справочник'!$1:$1) идет выбор изделия из справочника, по этому списку в следующей строке идет список выбора операций (=ДВССЫЛ($F$5)).и так для каждого столбца.
далее необходимо в следующих строках "9", "10", "11" (ячейки указал желтым цветом) подставлялись значения из нужных ячеек соответствующие ранее выбранной операции из справочника. (на примере для наглядности вручную ввел значения)
и такое нужно сделать для каждого столбца, где указаны ячейки желтым цветом. может и первоначальный мой вариант не верный, слепил из того что нашел))) прошу строго не судить.
ПЫСЫ: после повторного открытия файла, формулы не сохраняются
К сообщению приложен файл: _2.xls(85.5 Kb)
 
Ответить
СообщениеДобрый день, уважаемые форумчане!
помогите пжлст
имею файл табличного наряда, установил некоторые формулы и застопорился, далее нужна помощь.
имеются справочники (после мучений создал общий), в пятой строке Лист2 (из созданого списка ='сводный справочник'!$1:$1) идет выбор изделия из справочника, по этому списку в следующей строке идет список выбора операций (=ДВССЫЛ($F$5)).и так для каждого столбца.
далее необходимо в следующих строках "9", "10", "11" (ячейки указал желтым цветом) подставлялись значения из нужных ячеек соответствующие ранее выбранной операции из справочника. (на примере для наглядности вручную ввел значения)
и такое нужно сделать для каждого столбца, где указаны ячейки желтым цветом. может и первоначальный мой вариант не верный, слепил из того что нашел))) прошу строго не судить.
ПЫСЫ: после повторного открытия файла, формулы не сохраняются

Автор - nespica
Дата добавления - 30.05.2018 в 12:52
_Boroda_ Дата: Среда, 30.05.2018, 13:18 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12353
Репутация: 5079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС('сводный справочник'!$A$1:$W$999;;ПОИСКПОЗ(F$5;'сводный справочник'!$A$1:$W$1;)+1);ПОИСКПОЗ(E$7;ИНДЕКС('сводный справочник'!$A$1:$W$999;;ПОИСКПОЗ(F$5;'сводный справочник'!$A$1:$W$1;));));"")

Или
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ИНДЕКС('сводный справочник'!$A$1:$W$999;;ПОИСКПОЗ(L$5;'сводный справочник'!$A$1:$W$1;))=K7);ИНДЕКС('сводный справочник'!$A$1:$W$999;;ПОИСКПОЗ(L$5;'сводный справочник'!$A$1:$W$1;)+1));"")
К сообщению приложен файл: _2-8-1.xls(96.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС('сводный справочник'!$A$1:$W$999;;ПОИСКПОЗ(F$5;'сводный справочник'!$A$1:$W$1;)+1);ПОИСКПОЗ(E$7;ИНДЕКС('сводный справочник'!$A$1:$W$999;;ПОИСКПОЗ(F$5;'сводный справочник'!$A$1:$W$1;));));"")

Или
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ИНДЕКС('сводный справочник'!$A$1:$W$999;;ПОИСКПОЗ(L$5;'сводный справочник'!$A$1:$W$1;))=K7);ИНДЕКС('сводный справочник'!$A$1:$W$999;;ПОИСКПОЗ(L$5;'сводный справочник'!$A$1:$W$1;)+1));"")

Автор - _Boroda_
Дата добавления - 30.05.2018 в 13:18
nespica Дата: Среда, 30.05.2018, 13:29 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, огромное человеческое спасибо! в приложенном файле все функционирует....приступаю к изучению и вводу, если не разберусь, можно еще пристану?)))
 
Ответить
Сообщение_Boroda_, огромное человеческое спасибо! в приложенном файле все функционирует....приступаю к изучению и вводу, если не разберусь, можно еще пристану?)))

Автор - nespica
Дата добавления - 30.05.2018 в 13:29
_Boroda_ Дата: Среда, 30.05.2018, 13:38 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12353
Репутация: 5079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для того форум и есть.
Для изучения прежде всего посмотрите ИНДЕКС с нулевым вторым или третьим аргументом
https://support.office.com/ru-ru....61328bd


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля того форум и есть.
Для изучения прежде всего посмотрите ИНДЕКС с нулевым вторым или третьим аргументом
https://support.office.com/ru-ru....61328bd

Автор - _Boroda_
Дата добавления - 30.05.2018 в 13:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » постановка значения в ячейку при нескольких условиях (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!