Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подтянуть значения только по ячейке из выпадающего списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтянуть значения только по ячейке из выпадающего списка (Формулы/Formulas)
Подтянуть значения только по ячейке из выпадающего списка
clorax Дата: Пятница, 01.06.2018, 15:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Помогите, пожалуйста, я решением задачи. У меня есть список Регионов с кодами населенных пунктов. Я сделала выпадающий список с регионами, мне нужно сделать так, что только по тому региону, который я выбрала в списке подтягивались данные по всем кодам нас.пунктов в данном регионе. Я пока что записла на том этапе, что через ЕСЛИ коды тянутся, но тянутся в том же порядке, в котором они расположены в исходном списке, пример во вложении
К сообщению приложен файл: 0982558.xlsx(10.4 Kb)
 
Ответить
СообщениеПомогите, пожалуйста, я решением задачи. У меня есть список Регионов с кодами населенных пунктов. Я сделала выпадающий список с регионами, мне нужно сделать так, что только по тому региону, который я выбрала в списке подтягивались данные по всем кодам нас.пунктов в данном регионе. Я пока что записла на том этапе, что через ЕСЛИ коды тянутся, но тянутся в том же порядке, в котором они расположены в исходном списке, пример во вложении

Автор - clorax
Дата добавления - 01.06.2018 в 15:52
_Boroda_ Дата: Пятница, 01.06.2018, 16:06 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13245
Репутация: 5454 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Регионы в первой таблице всегда по порядку?
Если нет, то
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(B$1:B$99=F$2;СТРОКА(B$1:B$99));СТРОКА(F1)));"")
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Если да, то
Код
=ЕСЛИ(СТРОКА(G1)>СЧЁТЕСЛИ(B$3:B$99;F$2);"";ИНДЕКС(C:C;ПОИСКПОЗ(F$2;B$1:B$99;)+СТРОКА()-5))
или
Код
=ЕСЛИ(СТРОКА(G1)>СЧЁТЕСЛИ(B$3:B$99;F$2);"";ИНДЕКС(C3:C99;ПОИСКПОЗ(F$2;B$3:B$99;)))


Если порядок неважен, то
Код
=ЕСЛИ(СТРОКА(I1)>СЧЁТЕСЛИ(B$3:B$99;F$2);"";ПРОСМОТР(2;1/(B3:B99=F$2);C$3:C$99))


В файле еще автораскраску сделал Условным форматированием
К сообщению приложен файл: 0982558_1.xlsx(13.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеРегионы в первой таблице всегда по порядку?
Если нет, то
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(B$1:B$99=F$2;СТРОКА(B$1:B$99));СТРОКА(F1)));"")
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Если да, то
Код
=ЕСЛИ(СТРОКА(G1)>СЧЁТЕСЛИ(B$3:B$99;F$2);"";ИНДЕКС(C:C;ПОИСКПОЗ(F$2;B$1:B$99;)+СТРОКА()-5))
или
Код
=ЕСЛИ(СТРОКА(G1)>СЧЁТЕСЛИ(B$3:B$99;F$2);"";ИНДЕКС(C3:C99;ПОИСКПОЗ(F$2;B$3:B$99;)))


Если порядок неважен, то
Код
=ЕСЛИ(СТРОКА(I1)>СЧЁТЕСЛИ(B$3:B$99;F$2);"";ПРОСМОТР(2;1/(B3:B99=F$2);C$3:C$99))


В файле еще автораскраску сделал Условным форматированием

Автор - _Boroda_
Дата добавления - 01.06.2018 в 16:06
sboy Дата: Пятница, 01.06.2018, 16:12 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2124
Репутация: 609 ±
Замечаний: 0% ±

Excel 2010
Вариант первой формулы от _Boroda_, только без массивного ввода
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;АГРЕГАТ(15;6;СТРОКА($B$1:$B$22)/($F$2=$B$1:$B$22);СТРОКА(A1)));"")
К сообщению приложен файл: 9955785.xlsx(10.5 Kb)
 
Ответить
СообщениеВариант первой формулы от _Boroda_, только без массивного ввода
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;АГРЕГАТ(15;6;СТРОКА($B$1:$B$22)/($F$2=$B$1:$B$22);СТРОКА(A1)));"")

Автор - sboy
Дата добавления - 01.06.2018 в 16:12
clorax Дата: Пятница, 01.06.2018, 17:56 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ура, ура, ура! Спасибо! и так и так получилось. Дай Бог Вам здоровья, счастья, денег побольше)))) sboy, _Boroda_,
 
Ответить
СообщениеУра, ура, ура! Спасибо! и так и так получилось. Дай Бог Вам здоровья, счастья, денег побольше)))) sboy, _Boroda_,

Автор - clorax
Дата добавления - 01.06.2018 в 17:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтянуть значения только по ячейке из выпадающего списка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!