Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет сумм чисел, соответствующих уникальному значению - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет сумм чисел, соответствующих уникальному значению (Формулы/Formulas)
Подсчет сумм чисел, соответствующих уникальному значению
Mitya Дата: Среда, 06.06.2018, 11:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте. Подскажите, пожалуйста, как решить следующую задачу формулами.
В колонке A содержатся буквенные значения, отсортированные по уникальности (от а до я).
Каждому буквенному значению соответствует число (в колонке B).
Как подсчитать суммы всех чисел для одинаковых буквенных значений и поместить их в колонке C в первую ячейку напротив каждого уникального буквенного значения?

Более понятно то, что хочется получить, видно на примере.
К сообщению приложен файл: 11.xlsx(88.4 Kb)
 
Ответить
СообщениеЗдравствуйте. Подскажите, пожалуйста, как решить следующую задачу формулами.
В колонке A содержатся буквенные значения, отсортированные по уникальности (от а до я).
Каждому буквенному значению соответствует число (в колонке B).
Как подсчитать суммы всех чисел для одинаковых буквенных значений и поместить их в колонке C в первую ячейку напротив каждого уникального буквенного значения?

Более понятно то, что хочется получить, видно на примере.

Автор - Mitya
Дата добавления - 06.06.2018 в 11:24
_Boroda_ Дата: Среда, 06.06.2018, 11:27 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13187
Репутация: 5422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(A2=A1;"";СУММЕСЛИ(A:A;A2;C:C))


*Может, не В, а С столбец нужен?
К сообщению приложен файл: 11-5-1.xlsx(86.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(A2=A1;"";СУММЕСЛИ(A:A;A2;C:C))


*Может, не В, а С столбец нужен?

Автор - _Boroda_
Дата добавления - 06.06.2018 в 11:27
китин Дата: Среда, 06.06.2018, 11:31 | Сообщение № 3
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Здравствуйте. может так?
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$2:A2;A2)=1;СУММЕСЛИ($A$2:$A$3850;$A2;$C$2:$C$3850);"")
К сообщению приложен файл: Mitya.xlsb(86.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеЗдравствуйте. может так?
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$2:A2;A2)=1;СУММЕСЛИ($A$2:$A$3850;$A2;$C$2:$C$3850);"")

Автор - китин
Дата добавления - 06.06.2018 в 11:31
Mitya Дата: Среда, 06.06.2018, 11:39 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо огромное!!! Оба варианта подходят.
 
Ответить
СообщениеСпасибо огромное!!! Оба варианта подходят.

Автор - Mitya
Дата добавления - 06.06.2018 в 11:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет сумм чисел, соответствующих уникальному значению (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!