Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка значений по ряду парметров и копирование их в столбе - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений по ряду парметров и копирование их в столбе (Формулы/Formulas)
Выборка значений по ряду парметров и копирование их в столбе
kameron5 Дата: Четверг, 07.06.2018, 17:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемые форумчане, добрый день, просьба к вам помочь с таким вот вопросом:
имеется таблица продаж по клиентам, в которой также представлены номера счетов фактур.
Необходимо с помощью формул отфильтровать данную таблицу допустим по получатель: Кузьмин, позиция: лейка, и полученные номера счетов фактур копировать в столбец выделенный желтым цветом (т.е формула должна находиться в данном столбце).
При этом необходимо, чтобы номера СФ следовали друг за другом не по возрастанию, а в том порядке в котором находятся в таблице.
Заранее спасибо за помощь/совет.
К сообщению приложен файл: 6099994.xlsx(9.5 Kb)
 
Ответить
СообщениеУважаемые форумчане, добрый день, просьба к вам помочь с таким вот вопросом:
имеется таблица продаж по клиентам, в которой также представлены номера счетов фактур.
Необходимо с помощью формул отфильтровать данную таблицу допустим по получатель: Кузьмин, позиция: лейка, и полученные номера счетов фактур копировать в столбец выделенный желтым цветом (т.е формула должна находиться в данном столбце).
При этом необходимо, чтобы номера СФ следовали друг за другом не по возрастанию, а в том порядке в котором находятся в таблице.
Заранее спасибо за помощь/совет.

Автор - kameron5
Дата добавления - 07.06.2018 в 17:19
sboy Дата: Четверг, 07.06.2018, 17:31 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1861
Репутация: 535 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$1:$D$30;АГРЕГАТ(15;6;СТРОКА($D$1:$D$30)/(($B$1:$B$30=$G$1)/($C$1:$C$30=$H$1));СТРОКА(D1)));"")
К сообщению приложен файл: 5624608.xlsx(10.2 Kb)
 
Ответить
СообщениеДобрый день.
Если правильно понял
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$1:$D$30;АГРЕГАТ(15;6;СТРОКА($D$1:$D$30)/(($B$1:$B$30=$G$1)/($C$1:$C$30=$H$1));СТРОКА(D1)));"")

Автор - sboy
Дата добавления - 07.06.2018 в 17:31
_Boroda_ Дата: Четверг, 07.06.2018, 17:32 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12399
Репутация: 5092 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(D:D;НАИМЕНЬШИЙ(ЕСЛИ((B$2:B$999=J$2)*(C$2:C$999=K$2);СТРОКА(C$2:C$999));СТРОКА()));"")
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 6099994_1.xlsx(10.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(D:D;НАИМЕНЬШИЙ(ЕСЛИ((B$2:B$999=J$2)*(C$2:C$999=K$2);СТРОКА(C$2:C$999));СТРОКА()));"")
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 07.06.2018 в 17:32
abtextime Дата: Четверг, 07.06.2018, 17:36 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 796
Репутация: 113 ±
Замечаний: 0% ±

Excel 2010
В столбце H

Код
=SF($B$2:$B$30;$E$2;$F$2;СТРОКА()-1)


UDF
[vba]
Код

Public Function SF(RR As Range, Recipient, Good As String, N As Long) As String
    For Each R In RR
        If R.Cells(1, 1).Value = Recipient And R.Cells(1, 2).Value = Good Then
            Counter = Counter + 1
            If Counter = N Then
                SF = R.Cells(1, 3).Value
                Exit Function
            End If
        End If
    Next R
End Function
[/vba]
К сообщению приложен файл: 6099994.xlsm(15.5 Kb)
 
Ответить
СообщениеВ столбце H

Код
=SF($B$2:$B$30;$E$2;$F$2;СТРОКА()-1)


UDF
[vba]
Код

Public Function SF(RR As Range, Recipient, Good As String, N As Long) As String
    For Each R In RR
        If R.Cells(1, 1).Value = Recipient And R.Cells(1, 2).Value = Good Then
            Counter = Counter + 1
            If Counter = N Then
                SF = R.Cells(1, 3).Value
                Exit Function
            End If
        End If
    Next R
End Function
[/vba]

Автор - abtextime
Дата добавления - 07.06.2018 в 17:36
kameron5 Дата: Четверг, 07.06.2018, 17:43 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Друзья спасибо большое!
Очень помогли!!!
 
Ответить
СообщениеДрузья спасибо большое!
Очень помогли!!!

Автор - kameron5
Дата добавления - 07.06.2018 в 17:43
kameron5 Дата: Четверг, 07.06.2018, 18:02 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Еще один вопрос, можно модифицировать формулу, чтобы считались не просто лопаты и лейки, со строгим совпадением, а если ячейка содержит много символов среди которых имеет значение лейка.
Во вложении новый список, где присутствуют лейка-1; лейка-2 Ле1ка-3, желательно чтобы они все считались когда мы ищем просто слово: лейка.

Это возможно сделать?
К сообщению приложен файл: 8260676.xlsx(9.6 Kb)


Сообщение отредактировал kameron5 - Четверг, 07.06.2018, 18:03
 
Ответить
СообщениеЕще один вопрос, можно модифицировать формулу, чтобы считались не просто лопаты и лейки, со строгим совпадением, а если ячейка содержит много символов среди которых имеет значение лейка.
Во вложении новый список, где присутствуют лейка-1; лейка-2 Ле1ка-3, желательно чтобы они все считались когда мы ищем просто слово: лейка.

Это возможно сделать?

Автор - kameron5
Дата добавления - 07.06.2018 в 18:02
abtextime Дата: Четверг, 07.06.2018, 18:29 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 796
Репутация: 113 ±
Замечаний: 0% ±

Excel 2010
kameron5,

для UDF очень просто

[vba]
Код
Public Function SF(RR As Range, Recipient, Good As String, N As Long) As String
    For Each R In RR
        If R.Cells(1, 1).Value = Recipient And (InStr(LCase(R.Cells(1, 2).Value), LCase(Good)) > 0) Then
            Counter = Counter + 1
            If Counter = N Then
                SF = R.Cells(1, 3).Value
                Exit Function
            End If
        End If
    Next R
End Function
[/vba]
К сообщению приложен файл: 6099994-1-.xlsm(15.7 Kb)
 
Ответить
Сообщениеkameron5,

для UDF очень просто

[vba]
Код
Public Function SF(RR As Range, Recipient, Good As String, N As Long) As String
    For Each R In RR
        If R.Cells(1, 1).Value = Recipient And (InStr(LCase(R.Cells(1, 2).Value), LCase(Good)) > 0) Then
            Counter = Counter + 1
            If Counter = N Then
                SF = R.Cells(1, 3).Value
                Exit Function
            End If
        End If
    Next R
End Function
[/vba]

Автор - abtextime
Дата добавления - 07.06.2018 в 18:29
_Boroda_ Дата: Четверг, 07.06.2018, 19:13 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12399
Репутация: 5092 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(D:D;НАИМЕНЬШИЙ(ЕСЛИ((B$2:B$999=J$2)*ЕЧИСЛО(ПОИСК(K$2;C$2:C$999));СТРОКА(C$2:C$999));СТРОКА()));"")
К сообщению приложен файл: 6099994_2.xlsx(10.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(D:D;НАИМЕНЬШИЙ(ЕСЛИ((B$2:B$999=J$2)*ЕЧИСЛО(ПОИСК(K$2;C$2:C$999));СТРОКА(C$2:C$999));СТРОКА()));"")

Автор - _Boroda_
Дата добавления - 07.06.2018 в 19:13
kameron5 Дата: Воскресенье, 10.06.2018, 16:43 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
ДА, спасибо.

Все работает
 
Ответить
СообщениеДА, спасибо.

Все работает

Автор - kameron5
Дата добавления - 10.06.2018 в 16:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений по ряду парметров и копирование их в столбе (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!