Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложение значений ячеек взависимости от значений др. ячеек. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение значений ячеек взависимости от значений др. ячеек. (Формулы/Formulas)
Сложение значений ячеек взависимости от значений др. ячеек.
Aleksanqr Дата: Пятница, 08.06.2018, 09:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте! Подскажите, пожалуйста, следующее - имеется 2 столбца, например, А и B. В столбце А значение ячейки может иметь текстовое содержание трех видов:
1)Маша; 2)Саша; 3)Катя.
Ячейки столбца В состоят из чисел. Необходимо, чтобы проводилось сложение чисел для каждого из имени и сумма выводилась отдельно.
Столбец А может быть сколько угодно большим.
Для наглядности прикреплю скриншот.



Сообщение отредактировал Aleksanqr - Пятница, 08.06.2018, 09:58
 
Ответить
СообщениеЗдравствуйте! Подскажите, пожалуйста, следующее - имеется 2 столбца, например, А и B. В столбце А значение ячейки может иметь текстовое содержание трех видов:
1)Маша; 2)Саша; 3)Катя.
Ячейки столбца В состоят из чисел. Необходимо, чтобы проводилось сложение чисел для каждого из имени и сумма выводилась отдельно.
Столбец А может быть сколько угодно большим.
Для наглядности прикреплю скриншот.


Автор - Aleksanqr
Дата добавления - 08.06.2018 в 09:26
Светлый Дата: Пятница, 08.06.2018, 09:40 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 477
Репутация: 110 ±
Замечаний: 0% ±

Excel 2007
Название неподходящее. Причём здесь комментарии?
Неплохо бы приложить файл.
Таких тем с уникальными значениями довольно много. СтОит поискать.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеНазвание неподходящее. Причём здесь комментарии?
Неплохо бы приложить файл.
Таких тем с уникальными значениями довольно много. СтОит поискать.

Автор - Светлый
Дата добавления - 08.06.2018 в 09:40
sboy Дата: Пятница, 08.06.2018, 10:02 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1861
Репутация: 535 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
без файла, советую использовать СУММЕСЛИ()
 
Ответить
СообщениеДобрый день.
без файла, советую использовать СУММЕСЛИ()

Автор - sboy
Дата добавления - 08.06.2018 в 10:02
Aleksanqr Дата: Пятница, 08.06.2018, 10:19 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
sboy, благодарю за наводку! Вопрос решен.
 
Ответить
Сообщениеsboy, благодарю за наводку! Вопрос решен.

Автор - Aleksanqr
Дата добавления - 08.06.2018 в 10:19
_Boroda_ Дата: Пятница, 08.06.2018, 22:58 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12400
Репутация: 5092 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Иногда СУММЕСЛИ не прокатывает (не для этого файла, это так, на всякий случай), тогда можно СУММПРОИЗВ.
Код
=СУММПРОИЗВ(($A1:$A99=E1)*$B1:$B99)

Но СУММЕСЛИ быстрее


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИногда СУММЕСЛИ не прокатывает (не для этого файла, это так, на всякий случай), тогда можно СУММПРОИЗВ.
Код
=СУММПРОИЗВ(($A1:$A99=E1)*$B1:$B99)

Но СУММЕСЛИ быстрее

Автор - _Boroda_
Дата добавления - 08.06.2018 в 22:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение значений ячеек взависимости от значений др. ячеек. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!