Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Использование ГПР - место сайта в поиске - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Использование ГПР - место сайта в поиске (получение места сайта (цифры))
Использование ГПР - место сайта в поиске
Alex_UndeRR Дата: Пятница, 08.06.2018, 10:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
привет! пытаюсь с помощью ГПР получить цифру (место определенного сайта в списке). Пытаюсь получить место сайта X, но вместо 1 вылетает НД. Что не так?

К сообщению приложен файл: 9650361.xlsx(10.2 Kb)
 
Ответить
Сообщениепривет! пытаюсь с помощью ГПР получить цифру (место определенного сайта в списке). Пытаюсь получить место сайта X, но вместо 1 вылетает НД. Что не так?


Автор - Alex_UndeRR
Дата добавления - 08.06.2018 в 10:27
SLAVICK Дата: Пятница, 08.06.2018, 10:37 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 2275
Репутация: 750 ±
Замечаний: 0% ±

2019
Код
=ИНДЕКС($A$2:$J$2;ПОИСКПОЗ(L2;$A$3:$J$3;0))

ГПР смотрит по верхней строке.
Т.е. найти Х по 1-е можно а наоборот нет.
К сообщению приложен файл: 9876938.xlsx(11.4 Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение
Код
=ИНДЕКС($A$2:$J$2;ПОИСКПОЗ(L2;$A$3:$J$3;0))

ГПР смотрит по верхней строке.
Т.е. найти Х по 1-е можно а наоборот нет.

Автор - SLAVICK
Дата добавления - 08.06.2018 в 10:37
китин Дата: Пятница, 08.06.2018, 10:39 | Сообщение № 3
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
привет. может так?
Код
=ИНДЕКС($A$2:$J$2;ПОИСКПОЗ($K$2;$A$3:$J$3;0))
К сообщению приложен файл: _9650361.xlsx(11.2 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениепривет. может так?
Код
=ИНДЕКС($A$2:$J$2;ПОИСКПОЗ($K$2;$A$3:$J$3;0))

Автор - китин
Дата добавления - 08.06.2018 в 10:39
Alex_UndeRR Дата: Пятница, 08.06.2018, 10:50 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо за оперативную помощь!
 
Ответить
СообщениеСпасибо за оперативную помощь!

Автор - Alex_UndeRR
Дата добавления - 08.06.2018 в 10:50
Alex_UndeRR Дата: Пятница, 08.06.2018, 10:51 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
привет. может так?

Уже вариант от Славика помог) Но все равно респект)
 
Ответить
Сообщение
привет. может так?

Уже вариант от Славика помог) Но все равно респект)

Автор - Alex_UndeRR
Дата добавления - 08.06.2018 в 10:51
китин Дата: Пятница, 08.06.2018, 10:54 | Сообщение № 6
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вариант от Славика

а ведь и мой и Славин вариант идентичны :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
вариант от Славика

а ведь и мой и Славин вариант идентичны :D

Автор - китин
Дата добавления - 08.06.2018 в 10:54
_Boroda_ Дата: Пятница, 08.06.2018, 23:06 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13194
Репутация: 5425 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
При Вашем раскладе в таблице (вторая строка по возрастанию) достаточно просто ПОИСКПОЗа
Код
=ПОИСКПОЗ(K2;A3:J3;)
К сообщению приложен файл: 9650361_1.xlsx(11.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПри Вашем раскладе в таблице (вторая строка по возрастанию) достаточно просто ПОИСКПОЗа
Код
=ПОИСКПОЗ(K2;A3:J3;)

Автор - _Boroda_
Дата добавления - 08.06.2018 в 23:06
Che79 Дата: Суббота, 09.06.2018, 00:11 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
с помощью ГПР
Код
=ГПР(K2;ЕСЛИ({1:0};A3:J3;A2:J2);2;)
К сообщению приложен файл: 9650361_2.xlsx(11.4 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
с помощью ГПР
Код
=ГПР(K2;ЕСЛИ({1:0};A3:J3;A2:J2);2;)

Автор - Che79
Дата добавления - 09.06.2018 в 00:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Использование ГПР - место сайта в поиске (получение места сайта (цифры))
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!