Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сопоставление двух массивов на листе EXCEL - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставление двух массивов на листе EXCEL (Формулы/Formulas)
Сопоставление двух массивов на листе EXCEL
Allisonn Дата: Пятница, 08.06.2018, 11:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте уважаемые знатоки. Вопрос в следующем:
Имеется файл Excel в столбце которого указаны товарные индексы, при помощи макроса я пытаюсь подставить к ячейкам в столбце, строки, которые совпадают с товарными позициями.
Но если товарные позиции одинаковые - то макрос подставляет строки которые подпадают под требования только к одной ячейке, а остальные игнорирует.
Прилагаю файл образец
В VBA не сильна.
Бывший сотрудник перед увольнением специально все испортил и уже 2 дня никак не могу понять что же он изменил в макросе
Файл образец содержит макрос
Заранее благодарю знатока который подскажет
К сообщению приложен файл: 0637388.xlsm(16.3 Kb)


Лето, ты где?
 
Ответить
СообщениеЗдравствуйте уважаемые знатоки. Вопрос в следующем:
Имеется файл Excel в столбце которого указаны товарные индексы, при помощи макроса я пытаюсь подставить к ячейкам в столбце, строки, которые совпадают с товарными позициями.
Но если товарные позиции одинаковые - то макрос подставляет строки которые подпадают под требования только к одной ячейке, а остальные игнорирует.
Прилагаю файл образец
В VBA не сильна.
Бывший сотрудник перед увольнением специально все испортил и уже 2 дня никак не могу понять что же он изменил в макросе
Файл образец содержит макрос
Заранее благодарю знатока который подскажет

Автор - Allisonn
Дата добавления - 08.06.2018 в 11:57
sboy Дата: Пятница, 08.06.2018, 12:29 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2020
Репутация: 578 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
А зачем использовать макрос? да и еще с такими циклами.
Тут обычный ВПР поможет
Код
=ВПР($B2;$D$20:$G$24;СТОЛБЕЦ(A1);)
К сообщению приложен файл: 1826617.xlsm(17.2 Kb)
 
Ответить
СообщениеДобрый день.
А зачем использовать макрос? да и еще с такими циклами.
Тут обычный ВПР поможет
Код
=ВПР($B2;$D$20:$G$24;СТОЛБЕЦ(A1);)

Автор - sboy
Дата добавления - 08.06.2018 в 12:29
Allisonn Дата: Пятница, 08.06.2018, 13:00 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
sboy, Мне тоже говорили про функцию, но я ничего не поняла, куда подставлять то ее надо :(


Лето, ты где?
 
Ответить
Сообщениеsboy, Мне тоже говорили про функцию, но я ничего не поняла, куда подставлять то ее надо :(

Автор - Allisonn
Дата добавления - 08.06.2018 в 13:00
sboy Дата: Пятница, 08.06.2018, 13:05 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 2020
Репутация: 578 ±
Замечаний: 0% ±

Excel 2010
Посмотрите в файлике, который я приложил.
Если не разберетесь, то задавайте вопросы
На сайте видео можно посмотреть


Сообщение отредактировал sboy - Пятница, 08.06.2018, 13:06
 
Ответить
СообщениеПосмотрите в файлике, который я приложил.
Если не разберетесь, то задавайте вопросы
На сайте видео можно посмотреть

Автор - sboy
Дата добавления - 08.06.2018 в 13:05
Allisonn Дата: Пятница, 08.06.2018, 13:16 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
sboy, Огромное спасибо, видео очень помогло :)))))
Отличного Вам дня! girl_smile


Лето, ты где?
 
Ответить
Сообщениеsboy, Огромное спасибо, видео очень помогло :)))))
Отличного Вам дня! girl_smile

Автор - Allisonn
Дата добавления - 08.06.2018 в 13:16
Allisonn Дата: Пятница, 08.06.2018, 13:57 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
sboy, Сделала на 100 000 строк, первые нормально, а потом он произвольно стал вставлять значение


Лето, ты где?
 
Ответить
Сообщениеsboy, Сделала на 100 000 строк, первые нормально, а потом он произвольно стал вставлять значение

Автор - Allisonn
Дата добавления - 08.06.2018 в 13:57
sboy Дата: Пятница, 08.06.2018, 15:13 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 2020
Репутация: 578 ±
Замечаний: 0% ±

Excel 2010
значит что-то не так сделали
проверьте диапазоны таблицы, закрепление
 
Ответить
Сообщениезначит что-то не так сделали
проверьте диапазоны таблицы, закрепление

Автор - sboy
Дата добавления - 08.06.2018 в 15:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставление двух массивов на листе EXCEL (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!