Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать нужные строки из столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать нужные строки из столбца (Формулы/Formulas)
Выбрать нужные строки из столбца
Chelovekov Дата: Суббота, 09.06.2018, 06:19 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте помогите пожалуйста, совсем замучился. Нужно выбрать нужные строки из столбца. Я вроде делаю правильно, но выскакивают не нужные строки.В примере все увидите, если что спрашивайте. Спасибо.
К сообщению приложен файл: _4.xlsx(20.0 Kb)
 
Ответить
СообщениеЗдравствуйте помогите пожалуйста, совсем замучился. Нужно выбрать нужные строки из столбца. Я вроде делаю правильно, но выскакивают не нужные строки.В примере все увидите, если что спрашивайте. Спасибо.

Автор - Chelovekov
Дата добавления - 09.06.2018 в 06:19
Chelovekov Дата: Суббота, 09.06.2018, 06:38 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Извините, что я повторился, вот решение, добрый человек написал.
К сообщению приложен файл: 6739447.xlsx(10.0 Kb)
 
Ответить
СообщениеИзвините, что я повторился, вот решение, добрый человек написал.

Автор - Chelovekov
Дата добавления - 09.06.2018 в 06:38
Chelovekov Дата: Суббота, 09.06.2018, 06:47 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Хотя если есть еще варианты, буду благодарен, ведь на практике бывает, что что то идет не так.
 
Ответить
СообщениеХотя если есть еще варианты, буду благодарен, ведь на практике бывает, что что то идет не так.

Автор - Chelovekov
Дата добавления - 09.06.2018 в 06:47
Pelena Дата: Суббота, 09.06.2018, 09:06 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12756
Репутация: 2809 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
У Вас данные в двух файлах совершенно разные. Объясните словами, что нужно сделать и в каком из файлов?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеУ Вас данные в двух файлах совершенно разные. Объясните словами, что нужно сделать и в каком из файлов?

Автор - Pelena
Дата добавления - 09.06.2018 в 09:06
Chelovekov Дата: Суббота, 09.06.2018, 14:55 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Они почти одинаковые, а первом столбце данные о бейсбольном матче. Нужно вытащить данные типа 1 RUNS, 0 HITS, 0 ERRORS, они находятся под каждым иннингом, например Blue Jays - Top 1st 1 RUNS, 0 HITS, 0 ERRORS, то есть и Торонто в первом иннинге были такие данные, Tigers - Bottom 1st 0 RUNS, 2 HITS, 0 ERRORS, у Детройто были такие данные, Всего иннингов 9, Ну вот и нужно вытащить данные по иннингам.
%)
 
Ответить
СообщениеОни почти одинаковые, а первом столбце данные о бейсбольном матче. Нужно вытащить данные типа 1 RUNS, 0 HITS, 0 ERRORS, они находятся под каждым иннингом, например Blue Jays - Top 1st 1 RUNS, 0 HITS, 0 ERRORS, то есть и Торонто в первом иннинге были такие данные, Tigers - Bottom 1st 0 RUNS, 2 HITS, 0 ERRORS, у Детройто были такие данные, Всего иннингов 9, Ну вот и нужно вытащить данные по иннингам.
%)

Автор - Chelovekov
Дата добавления - 09.06.2018 в 14:55
Chelovekov Дата: Суббота, 09.06.2018, 15:02 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
http://www.espn.com/mlb/playbyplay?gameId=380608109
вот с этого сайта буру информацию
 
Ответить
Сообщениеhttp://www.espn.com/mlb/playbyplay?gameId=380608109
вот с этого сайта буру информацию

Автор - Chelovekov
Дата добавления - 09.06.2018 в 15:02
Pelena Дата: Суббота, 09.06.2018, 17:14 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12756
Репутация: 2809 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Ничего не понимаю в бейсболе :(
Для файла из первого поста формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$5000;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(НАЙТИ("RUN";$A$1:$A$5000));СТРОКА($A$1:$A$5000));СТРОКА(A1)));"")
К сообщению приложен файл: 9548860.xlsx(20.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНичего не понимаю в бейсболе :(
Для файла из первого поста формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$5000;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(НАЙТИ("RUN";$A$1:$A$5000));СТРОКА($A$1:$A$5000));СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 09.06.2018 в 17:14
_Boroda_ Дата: Суббота, 09.06.2018, 18:43 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12399
Репутация: 5092 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для второго файла. Немассивная
[vba]
Код
=ИНДЕКС(A:A;ПОИСКПОЗ("* RUN*";ИНДЕКС(A:A;ПОИСКПОЗ("*"&D9;A$1:A$999;)):A999;)+ПОИСКПОЗ("*"&D9;A$1:A$999;)-1)
[/vba]
К сообщению приложен файл: 6739447_1.xlsx(10.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля второго файла. Немассивная
[vba]
Код
=ИНДЕКС(A:A;ПОИСКПОЗ("* RUN*";ИНДЕКС(A:A;ПОИСКПОЗ("*"&D9;A$1:A$999;)):A999;)+ПОИСКПОЗ("*"&D9;A$1:A$999;)-1)
[/vba]

Автор - _Boroda_
Дата добавления - 09.06.2018 в 18:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать нужные строки из столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!