Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбор данных с книг одной структуры в одну таблицу другой. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных с книг одной структуры в одну таблицу другой. (Формулы/Formulas)
Сбор данных с книг одной структуры в одну таблицу другой.
KrosTj Дата: Суббота, 09.06.2018, 15:13 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Подскажите пожалуйста. Есть Одна большая таблица которая должна собрать все данные с других КНИГ. Например, в конечной книге в таблице есть столбец "Имя", а в исходных книгах это строка, состоящая из 2 клеток, в одной их которой находится “Имя", а напротив её значение. Нужно заполнить таблицу в 1 вкладке. Демо файл прикрепил. Относитесь к вкладкам, кроме Книга-клиент как к другим, отдельным книгам.
К сообщению приложен файл: Example.xlsx(19.1 Kb)
 
Ответить
СообщениеДобрый день. Подскажите пожалуйста. Есть Одна большая таблица которая должна собрать все данные с других КНИГ. Например, в конечной книге в таблице есть столбец "Имя", а в исходных книгах это строка, состоящая из 2 клеток, в одной их которой находится “Имя", а напротив её значение. Нужно заполнить таблицу в 1 вкладке. Демо файл прикрепил. Относитесь к вкладкам, кроме Книга-клиент как к другим, отдельным книгам.

Автор - KrosTj
Дата добавления - 09.06.2018 в 15:13
bigor Дата: Суббота, 09.06.2018, 16:25 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Можно так
Код
=ВПР(B$1;ВЫБОР($A2;'D:\2\[2.xlsx]Лист1'!A1:B6;'D:\2\[24.xlsx]Лист1'!A1:B6); 2; 0)
 
Ответить
СообщениеМожно так
Код
=ВПР(B$1;ВЫБОР($A2;'D:\2\[2.xlsx]Лист1'!A1:B6;'D:\2\[24.xlsx]Лист1'!A1:B6); 2; 0)

Автор - bigor
Дата добавления - 09.06.2018 в 16:25
Pelena Дата: Суббота, 09.06.2018, 17:57 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12753
Репутация: 2809 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Вариант макросом
К сообщению приложен файл: KrosTj.rar(57.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант макросом

Автор - Pelena
Дата добавления - 09.06.2018 в 17:57
KrosTj Дата: Понедельник, 11.06.2018, 15:47 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bigor, Можешь пояснить что происходит во втором аргументе функции ВЫБОР? Туда нужно что-то подставить или как?
 
Ответить
Сообщениеbigor, Можешь пояснить что происходит во втором аргументе функции ВЫБОР? Туда нужно что-то подставить или как?

Автор - KrosTj
Дата добавления - 11.06.2018 в 15:47
StoTisteg Дата: Вторник, 12.06.2018, 15:38 | Сообщение № 5
Группа: Авторы
Ранг: Ветеран
Сообщений: 877
Репутация: 72 ±
Замечаний: 0% ±

Excel 2010
KrosTj, да, там полный путь к нужному листу в Вашем закрытом файле в Вашем компе. Естественно, bigor не в курсе, что у Вас там будет.


Проверь всё. ThisWorkbook.Save. On Error Resume Next.

Сообщение отредактировал StoTisteg - Вторник, 12.06.2018, 15:40
 
Ответить
СообщениеKrosTj, да, там полный путь к нужному листу в Вашем закрытом файле в Вашем компе. Естественно, bigor не в курсе, что у Вас там будет.

Автор - StoTisteg
Дата добавления - 12.06.2018 в 15:38
bigor Дата: Среда, 13.06.2018, 08:10 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
KrosTj - там нужно перечислить все файлы книг из которых будете имена подтягивать, я для примера только 2 прописал, ну и пути соответственно Ваши должны быть.
 
Ответить
СообщениеKrosTj - там нужно перечислить все файлы книг из которых будете имена подтягивать, я для примера только 2 прописал, ну и пути соответственно Ваши должны быть.

Автор - bigor
Дата добавления - 13.06.2018 в 08:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных с книг одной структуры в одну таблицу другой. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!