Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение степени выполнения в зависимости от километража - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение степени выполнения в зависимости от километража (Формулы/Formulas)
Определение степени выполнения в зависимости от километража
parovoznik Дата: Понедельник, 11.06.2018, 15:14 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 13 ±
Замечаний: 0% ±

Excel 2007
Добрый день. Имеется таблица учета транспортных средств. В зависимости от Дат меняются степени выполнения работ(прибыл,в дороге и т.д.)
Это все работает. Сейчас добавил доп. столбец :Остаток ,км движения.
Если Остаток км,движения < 200
, то cтепень выполнения "на подходе" иначе "в дороге".
Как прописать это в общую формулу.
К сообщению приложен файл: 0391317.xlsm(31.1 Kb)
 
Ответить
СообщениеДобрый день. Имеется таблица учета транспортных средств. В зависимости от Дат меняются степени выполнения работ(прибыл,в дороге и т.д.)
Это все работает. Сейчас добавил доп. столбец :Остаток ,км движения.
Если Остаток км,движения < 200
, то cтепень выполнения "на подходе" иначе "в дороге".
Как прописать это в общую формулу.

Автор - parovoznik
Дата добавления - 11.06.2018 в 15:14
abtextime Дата: Понедельник, 11.06.2018, 15:34 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 797
Репутация: 113 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(B6="";"запланировано";ЕСЛИ(C6="";ЕСЛИ(E6>=200;"в дороге";"на подходе");ЕСЛИ(И(C6<>"";D6<>"")=ЛОЖЬ;"на таможне";ЕСЛИ(И(C6<>"";D6<>"")=ИСТИНА;"приб.";""))))
К сообщению приложен файл: 0247074.xlsm(29.4 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(B6="";"запланировано";ЕСЛИ(C6="";ЕСЛИ(E6>=200;"в дороге";"на подходе");ЕСЛИ(И(C6<>"";D6<>"")=ЛОЖЬ;"на таможне";ЕСЛИ(И(C6<>"";D6<>"")=ИСТИНА;"приб.";""))))

Автор - abtextime
Дата добавления - 11.06.2018 в 15:34
boa Дата: Понедельник, 11.06.2018, 15:39 | Сообщение № 3
Группа: Проверенные
Ранг: Участник
Сообщений: 55
Репутация: 7 ±
Замечаний: 0% ±

2013, 2016
parovoznik,
из вашего объяснения получается так:
Код
=IF(RC2=0;"запланировано";IF(RC5<200;"на подходе";IF(RC3=0;"в дороге";IF(RC4=0;"на таможне";"приб."))))

Код
=IF($B13=0;"запланировано";IF($E13<200;"на подходе";IF($C13=0;"в дороге";IF($D13=0;"на таможне";"приб."))))


но я бы сделал так:
Код
=IF(RC2=0;"запланировано";IF(RC3=0;"в дороге";IF(RC4=0;"на таможне";"приб.")))&IF(RC5<=200;", на подходе";"")

Код
=IF($B13=0;"запланировано";IF($C13=0;"в дороге";IF($D13=0;"на таможне";"приб.")))&IF($E13<=200;", на подходе";"")




Сообщение отредактировал boa - Понедельник, 11.06.2018, 15:46
 
Ответить
Сообщениеparovoznik,
из вашего объяснения получается так:
Код
=IF(RC2=0;"запланировано";IF(RC5<200;"на подходе";IF(RC3=0;"в дороге";IF(RC4=0;"на таможне";"приб."))))

Код
=IF($B13=0;"запланировано";IF($E13<200;"на подходе";IF($C13=0;"в дороге";IF($D13=0;"на таможне";"приб."))))


но я бы сделал так:
Код
=IF(RC2=0;"запланировано";IF(RC3=0;"в дороге";IF(RC4=0;"на таможне";"приб.")))&IF(RC5<=200;", на подходе";"")

Код
=IF($B13=0;"запланировано";IF($C13=0;"в дороге";IF($D13=0;"на таможне";"приб.")))&IF($E13<=200;", на подходе";"")

Автор - boa
Дата добавления - 11.06.2018 в 15:39
parovoznik Дата: Понедельник, 11.06.2018, 16:04 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 13 ±
Замечаний: 0% ±

Excel 2007
abtextime,спасибо за быстрый ответ. А можно подкорректировать формулу,что бы при вводе даты прибытия на таможню- Остаток км,движения обнулился =0
boa,Ваш вариант тестирую.
К сообщению приложен файл: 8314097.xlsm(13.2 Kb)
 
Ответить
Сообщениеabtextime,спасибо за быстрый ответ. А можно подкорректировать формулу,что бы при вводе даты прибытия на таможню- Остаток км,движения обнулился =0
boa,Ваш вариант тестирую.

Автор - parovoznik
Дата добавления - 11.06.2018 в 16:04
abtextime Дата: Понедельник, 11.06.2018, 16:51 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 797
Репутация: 113 ±
Замечаний: 0% ±

Excel 2010
parovoznik, формула , если это не UDF (User Defined Function, использующая средства VBA), не может вносить изменения в другую ячейку.

Можно сделать UDF с таким побочным эффектом (не рекомендуется) или подвесить макрос на изменение столбца G или C, но это для такой простой таблицы - гвозди микроскопом забивать

Просто назовите столбец E "ПОСЛЕДНИЕ данные по Остатку движения (км)"
 
Ответить
Сообщениеparovoznik, формула , если это не UDF (User Defined Function, использующая средства VBA), не может вносить изменения в другую ячейку.

Можно сделать UDF с таким побочным эффектом (не рекомендуется) или подвесить макрос на изменение столбца G или C, но это для такой простой таблицы - гвозди микроскопом забивать

Просто назовите столбец E "ПОСЛЕДНИЕ данные по Остатку движения (км)"

Автор - abtextime
Дата добавления - 11.06.2018 в 16:51
parovoznik Дата: Понедельник, 11.06.2018, 17:16 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 13 ±
Замечаний: 0% ±

Excel 2007
Ок,понял. hands
 
Ответить
СообщениеОк,понял. hands

Автор - parovoznik
Дата добавления - 11.06.2018 в 17:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение степени выполнения в зависимости от километража (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!