Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подставить число к дате - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подставить число к дате (Формулы/Formulas)
подставить число к дате
gorodgrehov Дата: Среда, 13.06.2018, 08:16 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Друзья добрый день! прошу помочь.
мне нужно сделать так чтобы, чтобы плотность сама указывалась в колонке (указано зелёным цветом, Важно чтоб не плюсовала а подставляла с колонки Е по дате)
в столбце вода есть формула (которую так же создали мне в этом форуме, спасибо создателям) а правильная и считает мне расход воды.

Важно то что к примеру: 1 мая он должен считать с 01.05.2018 08:00:00 по 02.05.2018 07:59:59 (по формуле расхода воды поймете.

так же во вложении пример
Спасибо.
К сообщению приложен файл: ___.xlsx(42.8 Kb)
 
Ответить
СообщениеДрузья добрый день! прошу помочь.
мне нужно сделать так чтобы, чтобы плотность сама указывалась в колонке (указано зелёным цветом, Важно чтоб не плюсовала а подставляла с колонки Е по дате)
в столбце вода есть формула (которую так же создали мне в этом форуме, спасибо создателям) а правильная и считает мне расход воды.

Важно то что к примеру: 1 мая он должен считать с 01.05.2018 08:00:00 по 02.05.2018 07:59:59 (по формуле расхода воды поймете.

так же во вложении пример
Спасибо.

Автор - gorodgrehov
Дата добавления - 13.06.2018 в 08:16
китин Дата: Среда, 13.06.2018, 08:46 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Важно чтоб не плюсовала а подставляла с колонки Е по дате

02.01.2018 у вас две разные плотности в одну дату. как быть?
без учета этого обстоятельства: формула массива
Код
=ИНДЕКС($E$4:$E$400;ПОИСКПОЗ(ПРОПНАЧ(СТРОКА(A1)&$H$4);ТЕКСТ($A$4:$A$400;"ДММММ");0))

но найдет только ПЕРВОЕ вхождение нужной даты в таблице
К сообщению приложен файл: gorodgrehov.xlsx(43.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 13.06.2018, 08:53
 
Ответить
Сообщение
Важно чтоб не плюсовала а подставляла с колонки Е по дате

02.01.2018 у вас две разные плотности в одну дату. как быть?
без учета этого обстоятельства: формула массива
Код
=ИНДЕКС($E$4:$E$400;ПОИСКПОЗ(ПРОПНАЧ(СТРОКА(A1)&$H$4);ТЕКСТ($A$4:$A$400;"ДММММ");0))

но найдет только ПЕРВОЕ вхождение нужной даты в таблице

Автор - китин
Дата добавления - 13.06.2018 в 08:46
gorodgrehov Дата: Среда, 13.06.2018, 08:56 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
пример:
01.05.2018 с 00:00:00 до 02.05.2018 07:59:59 (утра) считается 1 число мая
02.05.2018 с 08:00:00 до 03.05.2018 07:59:59 (утра) считается 2 число мая
03.05.2018 с 08:00:00 до 04.05.2018 07:59:59 (утра) считается 3 число мая
 
Ответить
Сообщениепример:
01.05.2018 с 00:00:00 до 02.05.2018 07:59:59 (утра) считается 1 число мая
02.05.2018 с 08:00:00 до 03.05.2018 07:59:59 (утра) считается 2 число мая
03.05.2018 с 08:00:00 до 04.05.2018 07:59:59 (утра) считается 3 число мая

Автор - gorodgrehov
Дата добавления - 13.06.2018 в 08:56
AlexM Дата: Среда, 13.06.2018, 09:21 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3762
Репутация: 949 ±
Замечаний: 0% ±

Excel 2003
Формула массива
Код
=ИНДЕКС(E$4:E$400;ПОИСКПОЗ(1=1;(H5&H$4)+"8:"<=A$4:A$400;))
К сообщению приложен файл: gorodgrehov_01.xlsx(42.3 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 13.06.2018, 09:38
 
Ответить
СообщениеФормула массива
Код
=ИНДЕКС(E$4:E$400;ПОИСКПОЗ(1=1;(H5&H$4)+"8:"<=A$4:A$400;))

Автор - AlexM
Дата добавления - 13.06.2018 в 09:21
_Boroda_ Дата: Среда, 13.06.2018, 09:29 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13187
Репутация: 5422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(I5;ПРОСМОТР("31:59:59:"+(H5&H$4);A$4:A$999;E$4:E$999);)

И чуть подправил Вам желтую формулу, там не нужно ЛЕВБ (если Вы будете писать месяц полностью или тремя первыми буквами - без разницы)

Немассивная и обрабатывает отсутствующие числа (например, 30 мая)
К сообщению приложен файл: -21-1.xlsx(45.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(I5;ПРОСМОТР("31:59:59:"+(H5&H$4);A$4:A$999;E$4:E$999);)

И чуть подправил Вам желтую формулу, там не нужно ЛЕВБ (если Вы будете писать месяц полностью или тремя первыми буквами - без разницы)

Немассивная и обрабатывает отсутствующие числа (например, 30 мая)

Автор - _Boroda_
Дата добавления - 13.06.2018 в 09:29
gorodgrehov Дата: Среда, 13.06.2018, 12:45 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо, друзья облегчили мне работу...
 
Ответить
Сообщениеспасибо, друзья облегчили мне работу...

Автор - gorodgrehov
Дата добавления - 13.06.2018 в 12:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подставить число к дате (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!