Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества рабочих дней (не ЧИСТРАБДНИ) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества рабочих дней (не ЧИСТРАБДНИ) (Формулы/Formulas)
Подсчет количества рабочих дней (не ЧИСТРАБДНИ)
mkotik Дата: Четверг, 21.06.2018, 18:00 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Есть производственный календарь (Лист - Календарь начальный) в виде сводной таблицы (за большой период): Дата/Рабочий день.
По Дате (в ячейке F1) необходимо подсчитать общее кол-во дней с начала месяца Даты и кол-во дней рабочих (значения 0,1,2) с начала месяца Даты.

PS Сводную таблицу менять невозможно.
ЧИСТРАБДНИ не подходит, так как в определенные дни ставится "двойная" ставка (и это не связано с праздниками).
На листе Календарь измененный пробовал делать подсчёт, но без изменения сводной таблицы не получается.
Подскажите, как решить эту задачу?
К сообщению приложен файл: 2878103.xlsx(36.1 Kb)


Сообщение отредактировал mkotik - Четверг, 21.06.2018, 18:01
 
Ответить
СообщениеДобрый день!
Есть производственный календарь (Лист - Календарь начальный) в виде сводной таблицы (за большой период): Дата/Рабочий день.
По Дате (в ячейке F1) необходимо подсчитать общее кол-во дней с начала месяца Даты и кол-во дней рабочих (значения 0,1,2) с начала месяца Даты.

PS Сводную таблицу менять невозможно.
ЧИСТРАБДНИ не подходит, так как в определенные дни ставится "двойная" ставка (и это не связано с праздниками).
На листе Календарь измененный пробовал делать подсчёт, но без изменения сводной таблицы не получается.
Подскажите, как решить эту задачу?

Автор - mkotik
Дата добавления - 21.06.2018 в 18:00
_Boroda_ Дата: Четверг, 21.06.2018, 18:57 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13421
Репутация: 5507 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СЧЁТЕСЛИМН(A:A;"<="&E1;A:A;">"&КОНМЕСЯЦА(E1;-1))

Код
=СУММЕСЛИМН(B:B;A:A;"<="&E1;A:A;">"&КОНМЕСЯЦА(E1;-1))

Если даты по порядку без пропусков, то
Код
=ДЕНЬ(E1)

Код
=СУММЕСЛИМН(B:B;A:A;"<="&E1;A:A;">"&E1-ДЕНЬ(E1))

Можно еще СУММПРОИЗВ,
Еще вот
Код
=СУММ(ИНДЕКС(B:B;E1-ДЕНЬ(E1)-A2+3):ИНДЕКС(B:B;E1-A2+2))
К сообщению приложен файл: 2878103_1.xlsx(36.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СЧЁТЕСЛИМН(A:A;"<="&E1;A:A;">"&КОНМЕСЯЦА(E1;-1))

Код
=СУММЕСЛИМН(B:B;A:A;"<="&E1;A:A;">"&КОНМЕСЯЦА(E1;-1))

Если даты по порядку без пропусков, то
Код
=ДЕНЬ(E1)

Код
=СУММЕСЛИМН(B:B;A:A;"<="&E1;A:A;">"&E1-ДЕНЬ(E1))

Можно еще СУММПРОИЗВ,
Еще вот
Код
=СУММ(ИНДЕКС(B:B;E1-ДЕНЬ(E1)-A2+3):ИНДЕКС(B:B;E1-A2+2))

Автор - _Boroda_
Дата добавления - 21.06.2018 в 18:57
mkotik Дата: Пятница, 22.06.2018, 08:32 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, спасибо огромное!
Не успел вчера проверить из-за Аргентина-Хорватия :)

ЗЫ Очень понравилось с ИНДЕКС victory


Сообщение отредактировал mkotik - Пятница, 22.06.2018, 08:37
 
Ответить
Сообщение_Boroda_, спасибо огромное!
Не успел вчера проверить из-за Аргентина-Хорватия :)

ЗЫ Очень понравилось с ИНДЕКС victory

Автор - mkotik
Дата добавления - 22.06.2018 в 08:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества рабочих дней (не ЧИСТРАБДНИ) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!