Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Умножать числа при выполнении условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Умножать числа при выполнении условия (Формулы/Formulas)
Умножать числа при выполнении условия
Ekonomist Дата: Четверг, 28.06.2018, 10:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет! Ребята, помогите, пожалуйста!!! Есть длинные столбцы с ценами и долями. Нужно перемножить цену и долю в общем объеме, исходя из артикля. Проблема в том, что объемы указаны еще и по многим др. артиклям, которые мне не нужны. И простое перемножение с помощью "растягивания" столбца приведет к ошибкам. Я понимаю, что нужно сделать такое условие: перемножать в том случае, если артикль по цене = артикль по доле, если такого нет вообще во всем столбце, то 0. Но какую формулу использовать не знаю! Формула "ЕСЛИ с множеством условий - тоже не вариант. Файл прикрепить не могу - весит много.


Петрович
 
Ответить
СообщениеВсем привет! Ребята, помогите, пожалуйста!!! Есть длинные столбцы с ценами и долями. Нужно перемножить цену и долю в общем объеме, исходя из артикля. Проблема в том, что объемы указаны еще и по многим др. артиклям, которые мне не нужны. И простое перемножение с помощью "растягивания" столбца приведет к ошибкам. Я понимаю, что нужно сделать такое условие: перемножать в том случае, если артикль по цене = артикль по доле, если такого нет вообще во всем столбце, то 0. Но какую формулу использовать не знаю! Формула "ЕСЛИ с множеством условий - тоже не вариант. Файл прикрепить не могу - весит много.

Автор - Ekonomist
Дата добавления - 28.06.2018 в 10:11
Manyasha Дата: Четверг, 28.06.2018, 11:00 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 2180
Репутация: 886 ±
Замечаний: 0% ±

Excel 2010, 2016
Ekonomist, весь файл не нужен, оставьте 10-20 строк для примера и выложите сюда.


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеEkonomist, весь файл не нужен, оставьте 10-20 строк для примера и выложите сюда.

Автор - Manyasha
Дата добавления - 28.06.2018 в 11:00
_Boroda_ Дата: Четверг, 28.06.2018, 12:09 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12686
Репутация: 5200 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Кросс с файлом https://forum.msexcel.ru/index.php?topic=11892.msg59017#msg59017
Решение
Код
=ЕСЛИОШИБКА(D2*ВПР(C2;E$2:G$3127;3;);)

Файл урезан
Можно еще с СУММПРОИЗВ, СУММЕСЛИ, но
1. ВПР быстрее в данном случае
2. Если есть задвоенные значения в столбце Е, то СУММПРОИЗВ, СУММЕСЛИ дадут ошибку

Ekonomist, - Прочитайте Правила форума
К сообщению приложен файл: __2.xlsb(9.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеКросс с файлом https://forum.msexcel.ru/index.php?topic=11892.msg59017#msg59017
Решение
Код
=ЕСЛИОШИБКА(D2*ВПР(C2;E$2:G$3127;3;);)

Файл урезан
Можно еще с СУММПРОИЗВ, СУММЕСЛИ, но
1. ВПР быстрее в данном случае
2. Если есть задвоенные значения в столбце Е, то СУММПРОИЗВ, СУММЕСЛИ дадут ошибку

Ekonomist, - Прочитайте Правила форума

Автор - _Boroda_
Дата добавления - 28.06.2018 в 12:09
Ekonomist Дата: Четверг, 28.06.2018, 15:25 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо огромное! Все верно!


Петрович
 
Ответить
СообщениеСпасибо огромное! Все верно!

Автор - Ekonomist
Дата добавления - 28.06.2018 в 15:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Умножать числа при выполнении условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!