Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автодобавление строк при заполнении таблицы на другом листе - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автодобавление строк при заполнении таблицы на другом листе (Формулы/Formulas)
Автодобавление строк при заполнении таблицы на другом листе
DrMini Дата: Воскресенье, 01.07.2018, 09:00 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 319
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010, 2013
Доброе утро всем, всем, всем.
Пару лет назад мне на этом форуме помогли сделать автоматическое заполнение таблицы с разбросом по листам в зависимости от буквы на которую начинается фамилия. Помогите пожалуйста убрать привязку к букве. Надо что бы при заполнении листа Посетители автоматом добавлялись в таблицу на листе Итого. А то после протаскивания формул таблица на листе Итого выглядит ужасно. Оставил пример с листами на букву Б и В
К сообщению приложен файл: 20180701.xlsm(62.7 Kb)
 
Ответить
СообщениеДоброе утро всем, всем, всем.
Пару лет назад мне на этом форуме помогли сделать автоматическое заполнение таблицы с разбросом по листам в зависимости от буквы на которую начинается фамилия. Помогите пожалуйста убрать привязку к букве. Надо что бы при заполнении листа Посетители автоматом добавлялись в таблицу на листе Итого. А то после протаскивания формул таблица на листе Итого выглядит ужасно. Оставил пример с листами на букву Б и В

Автор - DrMini
Дата добавления - 01.07.2018 в 09:00
abtextime Дата: Воскресенье, 01.07.2018, 10:52 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 828
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Так устроит?

На листе Б:

A2
Код
=LetCounter(Т1[Фамилия И.О.];СТРОКА()-1;ПРАВСИМВ(ЯЧЕЙКА("имяфайла";$A$1);ДЛСТР(ЯЧЕЙКА("имяфайла";$A$1))-ПОИСК("]";ЯЧЕЙКА("имяфайла";$A$1))))

B2
Код
=ЕСЛИ(A2="";"";ИНДЕКС(Т1[Фамилия И.О.];A2))

C2
Код
=ЕСЛИ(A2="";"";ИНДЕКС(Т1[Дата рождения];A2))


UDF LetCounter()

[vba]
Код
Public Function LetCounter(RR As Range, N As Long, Letter As String) As Variant
    For Each R In RR
        LetCounter = LetCounter + 1
        If Left(R.Value, 1) = Letter Then
            Counter = Counter + 1
            If Counter = N Then Exit Function
        End If
    Next R
    LetCounter = ""
End Function
[/vba]
К сообщению приложен файл: 2574893.xlsm(69.6 Kb)


Сообщение отредактировал abtextime - Воскресенье, 01.07.2018, 11:05
 
Ответить
СообщениеТак устроит?

На листе Б:

A2
Код
=LetCounter(Т1[Фамилия И.О.];СТРОКА()-1;ПРАВСИМВ(ЯЧЕЙКА("имяфайла";$A$1);ДЛСТР(ЯЧЕЙКА("имяфайла";$A$1))-ПОИСК("]";ЯЧЕЙКА("имяфайла";$A$1))))

B2
Код
=ЕСЛИ(A2="";"";ИНДЕКС(Т1[Фамилия И.О.];A2))

C2
Код
=ЕСЛИ(A2="";"";ИНДЕКС(Т1[Дата рождения];A2))


UDF LetCounter()

[vba]
Код
Public Function LetCounter(RR As Range, N As Long, Letter As String) As Variant
    For Each R In RR
        LetCounter = LetCounter + 1
        If Left(R.Value, 1) = Letter Then
            Counter = Counter + 1
            If Counter = N Then Exit Function
        End If
    Next R
    LetCounter = ""
End Function
[/vba]

Автор - abtextime
Дата добавления - 01.07.2018 в 10:52
abtextime Дата: Воскресенье, 01.07.2018, 11:26 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 828
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Не сразу въехал, что надо топикстартеру,

вот просто формулы для листа ИТОГО

Код
=СТРОКА()-1


Код
=ЕСЛИОШИБКА(ИНДЕКС(Т1[Фамилия И.О.];$B2);"")


Код
=ЕСЛИОШИБКА(ЕСЛИ(ИНДЕКС(Т1[Дата рождения];$B2)=0;"";ИНДЕКС(Т1[Дата рождения];$B2));"")


Код
=ЕСЛИОШИБКА(ИНДЕКС(Т1[Отец];$B2);"")


Код
=ЕСЛИОШИБКА(ИНДЕКС(Т1[Мать];$B2);"")


Код
=ЕСЛИОШИБКА(ИНДЕКС(Т1[Адрес];$B2);"")
К сообщению приложен файл: 20180701-1-.xlsm(66.7 Kb)


Сообщение отредактировал abtextime - Воскресенье, 01.07.2018, 11:26
 
Ответить
СообщениеНе сразу въехал, что надо топикстартеру,

вот просто формулы для листа ИТОГО

Код
=СТРОКА()-1


Код
=ЕСЛИОШИБКА(ИНДЕКС(Т1[Фамилия И.О.];$B2);"")


Код
=ЕСЛИОШИБКА(ЕСЛИ(ИНДЕКС(Т1[Дата рождения];$B2)=0;"";ИНДЕКС(Т1[Дата рождения];$B2));"")


Код
=ЕСЛИОШИБКА(ИНДЕКС(Т1[Отец];$B2);"")


Код
=ЕСЛИОШИБКА(ИНДЕКС(Т1[Мать];$B2);"")


Код
=ЕСЛИОШИБКА(ИНДЕКС(Т1[Адрес];$B2);"")

Автор - abtextime
Дата добавления - 01.07.2018 в 11:26
DrMini Дата: Воскресенье, 01.07.2018, 14:08 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 319
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010, 2013
Прошу прощения за долгий ответ на Ваш abtextime, ответ. К родителям ходил в огороде помочь.
Все формулы работают кроме ячейки B2 на листе Итого. В колонке № п/п цифры должны появляться только когда на листе Посетители появится запись соответствующая этой строке. Я малость подправил Вашу формулу
Код
=СТРОКА()-1

на
Код
=ЕСЛИОШИБКА(ИНДЕКС(Т1[№ п./п.];$A2);"")

И всё заработало. Но в ячейке B2 формула не работает. Идёт циклическая ссылка на ячейку A2
Помогите исправить. В крайнем случае можно колонку "Кол-во на листе" лист Итого (A1:A2) вообще убрать.
надеюсь описал проблему понятно.
К сообщению приложен файл: _20180701-1-.xlsm(64.3 Kb)


Сообщение отредактировал DrMini - Воскресенье, 01.07.2018, 14:09
 
Ответить
СообщениеПрошу прощения за долгий ответ на Ваш abtextime, ответ. К родителям ходил в огороде помочь.
Все формулы работают кроме ячейки B2 на листе Итого. В колонке № п/п цифры должны появляться только когда на листе Посетители появится запись соответствующая этой строке. Я малость подправил Вашу формулу
Код
=СТРОКА()-1

на
Код
=ЕСЛИОШИБКА(ИНДЕКС(Т1[№ п./п.];$A2);"")

И всё заработало. Но в ячейке B2 формула не работает. Идёт циклическая ссылка на ячейку A2
Помогите исправить. В крайнем случае можно колонку "Кол-во на листе" лист Итого (A1:A2) вообще убрать.
надеюсь описал проблему понятно.

Автор - DrMini
Дата добавления - 01.07.2018 в 14:08
abtextime Дата: Воскресенье, 01.07.2018, 14:29 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 828
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Пусть так будет в столбце B

Код
=ЕСЛИОШИБКА(Т1[@[№ п./п.]];"")
К сообщению приложен файл: 9282653.xlsm(68.7 Kb)
 
Ответить
СообщениеПусть так будет в столбце B

Код
=ЕСЛИОШИБКА(Т1[@[№ п./п.]];"")

Автор - abtextime
Дата добавления - 01.07.2018 в 14:29
DrMini Дата: Воскресенье, 01.07.2018, 15:20 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 319
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010, 2013

Пусть так будет в столбце B

Пускай так и будет.
Спасибо всё отлично.


Сообщение отредактировал DrMini - Воскресенье, 01.07.2018, 15:20
 
Ответить
Сообщение

Пусть так будет в столбце B

Пускай так и будет.
Спасибо всё отлично.

Автор - DrMini
Дата добавления - 01.07.2018 в 15:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автодобавление строк при заполнении таблицы на другом листе (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!