Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения/данных по дате и количеству и массива данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения/данных по дате и количеству и массива данных (Формулы/Formulas)
Поиск значения/данных по дате и количеству и массива данных
agroster Дата: Суббота, 07.07.2018, 17:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Подскажите как составить формулу, у самого не получается. Уже сил нет.
К сообщению приложен файл: 0189694.xlsx(10.8 Kb)
 
Ответить
СообщениеПодскажите как составить формулу, у самого не получается. Уже сил нет.

Автор - agroster
Дата добавления - 07.07.2018 в 17:58
Pelena Дата: Суббота, 07.07.2018, 18:39 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13026
Репутация: 2877 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ИНДЕКС($E$3:$E$19;ПОИСКПОЗ(A3;ИНДЕКС($F$3:$L$19;0;ПОИСКПОЗ($A$2;$F$2:$L$2;0));0))
К сообщению приложен файл: 9939103.xlsx(11.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ИНДЕКС($E$3:$E$19;ПОИСКПОЗ(A3;ИНДЕКС($F$3:$L$19;0;ПОИСКПОЗ($A$2;$F$2:$L$2;0));0))

Автор - Pelena
Дата добавления - 07.07.2018 в 18:39
Светлый Дата: Суббота, 07.07.2018, 19:09 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 614
Репутация: 165 ±
Замечаний: 0% ±

Excel 2010
И Вам, здравствуйте!
Формула массива (Ctrl+Shift+Enter)
Код
=ИНДЕКС(E:E;МАКС((A$2=F$2:L$2)*(A3=F$3:L$19)*СТРОКА($3:$19)))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 07.07.2018, 19:10
 
Ответить
СообщениеИ Вам, здравствуйте!
Формула массива (Ctrl+Shift+Enter)
Код
=ИНДЕКС(E:E;МАКС((A$2=F$2:L$2)*(A3=F$3:L$19)*СТРОКА($3:$19)))

Автор - Светлый
Дата добавления - 07.07.2018 в 19:09
_Boroda_ Дата: Суббота, 07.07.2018, 20:29 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12972
Репутация: 5335 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ПРОСМОТР(;-1/(A3=ИНДЕКС(F$3:L$19;;A$2-F$2+1));E$3:E$19)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ПРОСМОТР(;-1/(A3=ИНДЕКС(F$3:L$19;;A$2-F$2+1));E$3:E$19)

Автор - _Boroda_
Дата добавления - 07.07.2018 в 20:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения/данных по дате и количеству и массива данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!