Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как заполнить пустые ячейки данные из другого столбца? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как заполнить пустые ячейки данные из другого столбца? (Формулы/Formulas)
Как заполнить пустые ячейки данные из другого столбца?
AdwordsDirect Дата: Понедельник, 09.07.2018, 14:40 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 143
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день, уважаемые знатоки, у меня вопрос, есть столбец А с пропущенными (пустыми ячейками), и столбец В с данными которыми надо заполнить эти пустые ячейки, только чтобы данные из В брались строго по порядку и циклично, и желательно чтобы не важно было формуле (скрипту) какое количество (число) данных в столбце В, благодарен за помощь! Есть ли возможность указать сколько должна формула заполнить пустых ячеек, в смысле чтоб она не бесконечно это делало, а с указанием: "На 279 закончить".
За оперативность буду 3 дня подряд заходить и подымать рейтинг плюсами :)
К сообщению приложен файл: 7261835.xlsx(10.2 Kb)


Сообщение отредактировал AdwordsDirect - Понедельник, 09.07.2018, 14:42
 
Ответить
СообщениеДобрый день, уважаемые знатоки, у меня вопрос, есть столбец А с пропущенными (пустыми ячейками), и столбец В с данными которыми надо заполнить эти пустые ячейки, только чтобы данные из В брались строго по порядку и циклично, и желательно чтобы не важно было формуле (скрипту) какое количество (число) данных в столбце В, благодарен за помощь! Есть ли возможность указать сколько должна формула заполнить пустых ячеек, в смысле чтоб она не бесконечно это делало, а с указанием: "На 279 закончить".
За оперативность буду 3 дня подряд заходить и подымать рейтинг плюсами :)

Автор - AdwordsDirect
Дата добавления - 09.07.2018 в 14:40
_Boroda_ Дата: Понедельник, 09.07.2018, 14:58 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12686
Репутация: 5200 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Цитата AdwordsDirect, 09.07.2018 в 14:40, в сообщении № 1 ()
За оперативность буду 3 дня подряд заходить и подымать рейтинг плюсами
Попытка подкупа должностного лица при исполнении? :D

Так нужно?
Код
=ЕСЛИ(A1="";ИНДЕКС(B:B;ОСТАТ(СЧЁТЕСЛИ(A$1:A1;"")-1;СЧЁТЗ(B:B))+1);A1)

С условием по строкам так
Код
=ЕСЛИ(СТРОКА()>279;"";ЕСЛИ(A1="";ИНДЕКС(B:B;ОСТАТ(СЧЁТЕСЛИ(A$1:A1;"")-1;СЧЁТЗ(B:B))+1);A1))
но зачем? на сколько нужно строк, на столько формулу и протягивайте

[p.s.]Возможно я не понял вопрос
К сообщению приложен файл: 7261835_1.xlsx(11.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Цитата AdwordsDirect, 09.07.2018 в 14:40, в сообщении № 1 ()
За оперативность буду 3 дня подряд заходить и подымать рейтинг плюсами
Попытка подкупа должностного лица при исполнении? :D

Так нужно?
Код
=ЕСЛИ(A1="";ИНДЕКС(B:B;ОСТАТ(СЧЁТЕСЛИ(A$1:A1;"")-1;СЧЁТЗ(B:B))+1);A1)

С условием по строкам так
Код
=ЕСЛИ(СТРОКА()>279;"";ЕСЛИ(A1="";ИНДЕКС(B:B;ОСТАТ(СЧЁТЕСЛИ(A$1:A1;"")-1;СЧЁТЗ(B:B))+1);A1))
но зачем? на сколько нужно строк, на столько формулу и протягивайте

[p.s.]Возможно я не понял вопрос

Автор - _Boroda_
Дата добавления - 09.07.2018 в 14:58
AdwordsDirect Дата: Понедельник, 09.07.2018, 15:06 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 143
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Просто космос, благодарю!!!
 
Ответить
СообщениеПросто космос, благодарю!!!

Автор - AdwordsDirect
Дата добавления - 09.07.2018 в 15:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как заполнить пустые ячейки данные из другого столбца? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!