Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое округление - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое округление (Формулы/Formulas)
Автоматическое округление
LamaLii Дата: Вторник, 10.07.2018, 06:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Как в ячейку вписать формулу, чтоб она автоматически округляла значение до двух значащих цифр? Причём количество знаков после запятой может быть любым, для одних расчётов это три знака, для других - пять и более. То есть нужно именно значащие цифры, а не разряды.
 
Ответить
СообщениеДобрый день!
Как в ячейку вписать формулу, чтоб она автоматически округляла значение до двух значащих цифр? Причём количество знаков после запятой может быть любым, для одних расчётов это три знака, для других - пять и более. То есть нужно именно значащие цифры, а не разряды.

Автор - LamaLii
Дата добавления - 10.07.2018 в 06:50
Pelena Дата: Вторник, 10.07.2018, 07:12 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13223
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Файл с примером помог бы в понимании проблемы. Что есть значащие цифры?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Файл с примером помог бы в понимании проблемы. Что есть значащие цифры?

Автор - Pelena
Дата добавления - 10.07.2018 в 07:12
pabchek Дата: Вторник, 10.07.2018, 09:37 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 899
Репутация: 215 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Да простят модераторы, что отвечаю без файла. Размялся перед работой, потом времени не будет.
Если правильно понял, предлагаю свой, не изящный, вариант:
Код
=ЗНАК(A1)*ОКРУГЛТ(ABS(A1)*10^9;10^(ЦЕЛОЕ(LOG10(ABS(A1)))+8))/10^9

Или вот получше немного (файл перезалил)
Код
=ЗНАК(A1)*ОКРУГЛТ(ABS(A1);10^(ЦЕЛОЕ(LOG10(ABS(A1)))-1))
К сообщению приложен файл: 3566719.xlsb(7.8 Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 10.07.2018, 09:52
 
Ответить
СообщениеЗдравствуйте!
Да простят модераторы, что отвечаю без файла. Размялся перед работой, потом времени не будет.
Если правильно понял, предлагаю свой, не изящный, вариант:
Код
=ЗНАК(A1)*ОКРУГЛТ(ABS(A1)*10^9;10^(ЦЕЛОЕ(LOG10(ABS(A1)))+8))/10^9

Или вот получше немного (файл перезалил)
Код
=ЗНАК(A1)*ОКРУГЛТ(ABS(A1);10^(ЦЕЛОЕ(LOG10(ABS(A1)))-1))

Автор - pabchek
Дата добавления - 10.07.2018 в 09:37
sboy Дата: Вторник, 10.07.2018, 10:08 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2192
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Или вот получше немного

Код
=ОКРУГЛ(A1;1-ЦЕЛОЕ(LOG10(ABS(A1))))
 
Ответить
Сообщение
Или вот получше немного

Код
=ОКРУГЛ(A1;1-ЦЕЛОЕ(LOG10(ABS(A1))))

Автор - sboy
Дата добавления - 10.07.2018 в 10:08
pabchek Дата: Вторник, 10.07.2018, 10:58 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 899
Репутация: 215 ±
Замечаний: 0% ±

Excel 2007
[offtop] sboy, Сергей, зачОт :up:
А я, похоже, преждевременно решил, что проснулся ))[/offtop]


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
Сообщение[offtop] sboy, Сергей, зачОт :up:
А я, похоже, преждевременно решил, что проснулся ))[/offtop]

Автор - pabchek
Дата добавления - 10.07.2018 в 10:58
LamaLii Дата: Понедельник, 17.09.2018, 18:01 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер!
Большое спасибо!
Я наконец совладала с формулой)) Но вот только есть число получается "0,000090" в конце ноля нет (ячейка М11). Это никак не переделать?
И можно ли как-то завязать столбец О, чтоб в нём так же было округление до того количества разрядов, что и в столбце М?
К сообщению приложен файл: 8158113.rar(79.4 Kb)
 
Ответить
СообщениеДобрый вечер!
Большое спасибо!
Я наконец совладала с формулой)) Но вот только есть число получается "0,000090" в конце ноля нет (ячейка М11). Это никак не переделать?
И можно ли как-то завязать столбец О, чтоб в нём так же было округление до того количества разрядов, что и в столбце М?

Автор - LamaLii
Дата добавления - 17.09.2018 в 18:01
bmv98rus Дата: Понедельник, 17.09.2018, 20:21 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1395
Репутация: 235 ±
Замечаний: 0% ±

Excel 2013/2016
Если правильно понял,
вариант 1
Код
=ROUND(0,01*L6*M6;LEN(TEXT(M6;"Основной"))-2)

и вариант 2
Код
=ROUND(0,01*L6*M6;1-INT(LOG10(ABS((H6*I6*K6)/J6))))


Сообщение отредактировал bmv98rus - Понедельник, 17.09.2018, 20:28
 
Ответить
СообщениеЕсли правильно понял,
вариант 1
Код
=ROUND(0,01*L6*M6;LEN(TEXT(M6;"Основной"))-2)

и вариант 2
Код
=ROUND(0,01*L6*M6;1-INT(LOG10(ABS((H6*I6*K6)/J6))))

Автор - bmv98rus
Дата добавления - 17.09.2018 в 20:21
LamaLii Дата: Суббота, 29.09.2018, 08:20 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Если правильно понял,
вариант 1

=ОКРУГЛ(0;01*L6*M6;ДЛСТР(ТЕКСТ(M6;"Основной"))-2)

и вариант 2

=ОКРУГЛ(0;01*L6*M6;1-ЦЕЛОЕ(LOG10(ABS((H6*I6*K6)/J6))))

это в какой столбец подставлять? Для столбца М или О?
 
Ответить
Сообщение
Если правильно понял,
вариант 1

=ОКРУГЛ(0;01*L6*M6;ДЛСТР(ТЕКСТ(M6;"Основной"))-2)

и вариант 2

=ОКРУГЛ(0;01*L6*M6;1-ЦЕЛОЕ(LOG10(ABS((H6*I6*K6)/J6))))

это в какой столбец подставлять? Для столбца М или О?

Автор - LamaLii
Дата добавления - 29.09.2018 в 08:20
Pelena Дата: Суббота, 29.09.2018, 08:50 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 13223
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
LamaLii, не надо цитировать пост целиком, это нарушение Правил форума. Исправьте


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеLamaLii, не надо цитировать пост целиком, это нарушение Правил форума. Исправьте

Автор - Pelena
Дата добавления - 29.09.2018 в 08:50
LamaLii Дата: Пятница, 19.10.2018, 16:13 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, простите, не могу найти, как отредактировать :unsure:
 
Ответить
СообщениеPelena, простите, не могу найти, как отредактировать :unsure:

Автор - LamaLii
Дата добавления - 19.10.2018 в 16:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое округление (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!