Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск совпадения слова в ячейке с ячейками другого листа - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск совпадения слова в ячейке с ячейками другого листа (Формулы/Formulas)
Поиск совпадения слова в ячейке с ячейками другого листа
Nikita-kr Дата: Вторник, 10.07.2018, 10:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Помогите решить задачу. Есть файл с двумя листами. На листе "балконы" есть ячейки в которых помимо прочего написано название города, на листе "города" указаны те, которые могут встречаться в тексте конкретной ячейки на листе "балконы". Нужно чтобы на листе "балконы" в ячейке B2 была формула проверяющая наличие в ячейке А2 наличие слова из столбца А:А листа "города" и выводила какой-то признак "да/нет" или что-то другое (чтобы потом можно было отфильтровать)
Файл с примером прилагаю
Благодарю за ответ
К сообщению приложен файл: ____2003.xls(100.0 Kb)
 
Ответить
СообщениеДобрый день!
Помогите решить задачу. Есть файл с двумя листами. На листе "балконы" есть ячейки в которых помимо прочего написано название города, на листе "города" указаны те, которые могут встречаться в тексте конкретной ячейки на листе "балконы". Нужно чтобы на листе "балконы" в ячейке B2 была формула проверяющая наличие в ячейке А2 наличие слова из столбца А:А листа "города" и выводила какой-то признак "да/нет" или что-то другое (чтобы потом можно было отфильтровать)
Файл с примером прилагаю
Благодарю за ответ

Автор - Nikita-kr
Дата добавления - 10.07.2018 в 10:44
sboy Дата: Вторник, 10.07.2018, 10:55 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2192
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Добрый день
формула массива
Код
=СУММ(--ЕЧИСЛО(ПОИСК(Города!$A$1:$A$1141;A2)))

и формат ячеек \Да;;Нет
К сообщению приложен файл: _2003.xlsx(28.2 Kb)
 
Ответить
СообщениеДобрый день
формула массива
Код
=СУММ(--ЕЧИСЛО(ПОИСК(Города!$A$1:$A$1141;A2)))

и формат ячеек \Да;;Нет

Автор - sboy
Дата добавления - 10.07.2018 в 10:55
Nikita-kr Дата: Вторник, 10.07.2018, 11:10 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
sboy, спасибо огромное! respect
 
Ответить
Сообщениеsboy, спасибо огромное! respect

Автор - Nikita-kr
Дата добавления - 10.07.2018 в 11:10
_Boroda_ Дата: Вторник, 10.07.2018, 11:11 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Похоже, но чуть иначе - есть города Бор и Боровичи
Код
=СЧЁТ(ПОИСК(" "&Города!$A$1:$A$1141&" ";" "&A2&" "))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПохоже, но чуть иначе - есть города Бор и Боровичи
Код
=СЧЁТ(ПОИСК(" "&Города!$A$1:$A$1141&" ";" "&A2&" "))

Автор - _Boroda_
Дата добавления - 10.07.2018 в 11:11
sboy Дата: Вторник, 10.07.2018, 11:17 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2192
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
есть города Бор и Боровичи

Важное замечание, упустил составные слова
 
Ответить
Сообщение
есть города Бор и Боровичи

Важное замечание, упустил составные слова

Автор - sboy
Дата добавления - 10.07.2018 в 11:17
Nikita-kr Дата: Вторник, 10.07.2018, 11:58 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Что-то пошло не так, при расягивании формулы пишет "да" не там где надо
В файле добавил снизу, пометил желтым
К сообщению приложен файл: _2003-1-.xlsx(29.7 Kb)
 
Ответить
СообщениеЧто-то пошло не так, при расягивании формулы пишет "да" не там где надо
В файле добавил снизу, пометил желтым

Автор - Nikita-kr
Дата добавления - 10.07.2018 в 11:58
sboy Дата: Вторник, 10.07.2018, 12:10 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2192
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Используйте формулу от _Boroda_,
прикрутил в файл
К сообщению приложен файл: 5741508.xlsx(28.8 Kb)
 
Ответить
СообщениеИспользуйте формулу от _Boroda_,
прикрутил в файл

Автор - sboy
Дата добавления - 10.07.2018 в 12:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск совпадения слова в ячейке с ячейками другого листа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!