Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск в диапазоне и подстановка данных в ячейку. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в диапазоне и подстановка данных в ячейку. (Формулы/Formulas)
Поиск в диапазоне и подстановка данных в ячейку.
parovoznik Дата: Среда, 11.07.2018, 07:36 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 13 ±
Замечаний: 0% ±

Excel 2007
Доброе утро.
Нужно подсчитать компенсацию на перевозку в порожнем состоянии путем поиска расстояния в таблице.
Например . Тарифное расстояние от станции к станции -500км. с учетом коэффициента 0.55:Доп.данные в порожнем состоянии.,=500*0,55=275км и теперь нужно найти в таблице соответствующий диапазон и СТАВКУ подставить в формулу в ячейку Е9.
В прилагаемом примере описано.
К сообщению приложен файл: 0528922.xlsx(12.0 Kb)
 
Ответить
СообщениеДоброе утро.
Нужно подсчитать компенсацию на перевозку в порожнем состоянии путем поиска расстояния в таблице.
Например . Тарифное расстояние от станции к станции -500км. с учетом коэффициента 0.55:Доп.данные в порожнем состоянии.,=500*0,55=275км и теперь нужно найти в таблице соответствующий диапазон и СТАВКУ подставить в формулу в ячейку Е9.
В прилагаемом примере описано.

Автор - parovoznik
Дата добавления - 11.07.2018 в 07:36
Pelena Дата: Среда, 11.07.2018, 08:13 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12830
Репутация: 2827 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Формула массива
Код
=ИНДЕКС(B4:B55;ПОИСКПОЗ(E3*E4;--ЛЕВСИМВ(A4:A55;ПОИСК("-";A4:A55)-1)))*4*E5

А если первый столбец разделить на два (см. Лист2), то можно обойтись простым ВПР
К сообщению приложен файл: 6053705.xlsx(15.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=ИНДЕКС(B4:B55;ПОИСКПОЗ(E3*E4;--ЛЕВСИМВ(A4:A55;ПОИСК("-";A4:A55)-1)))*4*E5

А если первый столбец разделить на два (см. Лист2), то можно обойтись простым ВПР

Автор - Pelena
Дата добавления - 11.07.2018 в 08:13
_Boroda_ Дата: Среда, 11.07.2018, 09:28 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12658
Репутация: 5191 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=ВПР(E3*E4;--ЛЕВБ(A4:B55;ПОИСК("-";A4:B55&"-")-1);2)*4*E5

Обычная формула
Код
=ПРОСМОТР(E3*E4;ОТБР(ПОДСТАВИТЬ(A4:A55;"-";","));B4:B55)*4*E5
К сообщению приложен файл: 0528922_1.xlsx(12.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=ВПР(E3*E4;--ЛЕВБ(A4:B55;ПОИСК("-";A4:B55&"-")-1);2)*4*E5

Обычная формула
Код
=ПРОСМОТР(E3*E4;ОТБР(ПОДСТАВИТЬ(A4:A55;"-";","));B4:B55)*4*E5

Автор - _Boroda_
Дата добавления - 11.07.2018 в 09:28
parovoznik Дата: Среда, 11.07.2018, 13:15 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 13 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, Pelena благодарю за ответы. hands
 
Ответить
Сообщение_Boroda_, Pelena благодарю за ответы. hands

Автор - parovoznik
Дата добавления - 11.07.2018 в 13:15
parovoznik Дата: Среда, 11.07.2018, 19:19 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 13 ±
Замечаний: 0% ±

Excel 2007
В процессе работы возникла еще одна проблема.
Нужно найти в диапазоне результат в зависимости от расстояния и перевозимого груза. Формулу написал,но что то не работает. :(
К сообщению приложен файл: 4771889.xlsm(22.1 Kb)
 
Ответить
СообщениеВ процессе работы возникла еще одна проблема.
Нужно найти в диапазоне результат в зависимости от расстояния и перевозимого груза. Формулу написал,но что то не работает. :(

Автор - parovoznik
Дата добавления - 11.07.2018 в 19:19
Pelena Дата: Среда, 11.07.2018, 19:29 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12830
Репутация: 2827 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Код
=ИНДЕКС($H$4:$J$48;ПОИСКПОЗ(A3;$F$4:$F$48);ПОИСКПОЗ(B3;$H$3:$J$3;0))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ИНДЕКС($H$4:$J$48;ПОИСКПОЗ(A3;$F$4:$F$48);ПОИСКПОЗ(B3;$H$3:$J$3;0))

Автор - Pelena
Дата добавления - 11.07.2018 в 19:29
parovoznik Дата: Среда, 11.07.2018, 19:33 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 13 ±
Замечаний: 0% ±

Excel 2007
Pelena, Вы как всегда на Высоте!!!Пять баллов. hands
 
Ответить
СообщениеPelena, Вы как всегда на Высоте!!!Пять баллов. hands

Автор - parovoznik
Дата добавления - 11.07.2018 в 19:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в диапазоне и подстановка данных в ячейку. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!