Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка и перенос автоматически в нужную ячейку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка и перенос автоматически в нужную ячейку (Формулы/Formulas)
Сортировка и перенос автоматически в нужную ячейку
makriag Дата: Среда, 11.07.2018, 10:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!
Подскажите пожалуйста, вроде простой вопрос, а решить не могу.
Есть 2 столбца в первом числа от 1 до 10, а во втором например 5, 7, 2. И нужно цифры во втором столбце разнести(отсортировать) так чтобы они встали напротив 5,7,2 из первого столбца. Как это сделать? Простая сортировка только делает от меньшего к большему, а здесь нужно чтобы программа переносила цифры по нужным ячейкам
К сообщению приложен файл: _1.xlsx(8.0 Kb)


Сообщение отредактировал makriag - Среда, 11.07.2018, 10:44
 
Ответить
СообщениеЗдравствуйте!
Подскажите пожалуйста, вроде простой вопрос, а решить не могу.
Есть 2 столбца в первом числа от 1 до 10, а во втором например 5, 7, 2. И нужно цифры во втором столбце разнести(отсортировать) так чтобы они встали напротив 5,7,2 из первого столбца. Как это сделать? Простая сортировка только делает от меньшего к большему, а здесь нужно чтобы программа переносила цифры по нужным ячейкам

Автор - makriag
Дата добавления - 11.07.2018 в 10:26
AlexM Дата: Среда, 11.07.2018, 10:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3778
Репутация: 952 ±
Замечаний: 0% ±

Excel 2003
По правилам форума нужен файл пример



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПо правилам форума нужен файл пример

Автор - AlexM
Дата добавления - 11.07.2018 в 10:35
AlexM Дата: Среда, 11.07.2018, 10:51 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3778
Репутация: 952 ±
Замечаний: 0% ±

Excel 2003
В С1 вставить формулу
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(A1=B$1:B$3);B$1:B$3);"")
протянуть вниз
Или так
Код
=ЕСЛИОШИБКА(ВПР(A1;B$1:B$3;1;);"")
Код
=ЕСЛИ(ЕНД(ВПР(A1;B$1:B$3;;));"";A1)
или формула массива
Код
=ЕСЛИ(ИЛИ(A1=B$1:B$3);A1;"")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 11.07.2018, 11:59
 
Ответить
СообщениеВ С1 вставить формулу
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(A1=B$1:B$3);B$1:B$3);"")
протянуть вниз
Или так
Код
=ЕСЛИОШИБКА(ВПР(A1;B$1:B$3;1;);"")
Код
=ЕСЛИ(ЕНД(ВПР(A1;B$1:B$3;;));"";A1)
или формула массива
Код
=ЕСЛИ(ИЛИ(A1=B$1:B$3);A1;"")

Автор - AlexM
Дата добавления - 11.07.2018 в 10:51
pabchek Дата: Среда, 11.07.2018, 11:38 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 899
Репутация: 215 ±
Замечаний: 0% ±

Excel 2007
До кучи, формула массива:
Код
=СУММ((A1=B$1:B$3)*A1)

Код
=(СУММ(--(A1=B$1:B$3))=1)*A1

Код
=МАКС((B$1:B$3=A1)*A1)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Среда, 11.07.2018, 11:51
 
Ответить
СообщениеДо кучи, формула массива:
Код
=СУММ((A1=B$1:B$3)*A1)

Код
=(СУММ(--(A1=B$1:B$3))=1)*A1

Код
=МАКС((B$1:B$3=A1)*A1)

Автор - pabchek
Дата добавления - 11.07.2018 в 11:38
makriag Дата: Среда, 11.07.2018, 13:10 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Огромнейшее спасибо!
Вы мне очень помогли!
Отличный форум.
 
Ответить
СообщениеОгромнейшее спасибо!
Вы мне очень помогли!
Отличный форум.

Автор - makriag
Дата добавления - 11.07.2018 в 13:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка и перенос автоматически в нужную ячейку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!