Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт количества значений в диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт количества значений в диапазоне (Формулы/Formulas)
Подсчёт количества значений в диапазоне
IvanIvanovv Дата: Среда, 25.07.2018, 10:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ((СУММПРОИЗВ(--(((Лист1!$E$2:$E$3000)=E6)*И(ГОД(Лист1!$B$2:$B$3000)=2017))))=0;"";(СУММПРОИЗВ(--(((Лист1!$E$2:$E$3000)=E6)*И(ГОД(Лист1!$B$2:$B$3000)=2017)))))

формула должна считать сколько раз встречается значение из Е6 на листе1 и одновременно чтоб напротив стоял 2017 год, но условия почемуто не выполняется
формула на листах 2017 и 2018 красные ячейки
К сообщению приложен файл: 6238093.xlsx(43.2 Kb)


Сообщение отредактировал IvanIvanovv - Среда, 25.07.2018, 10:23
 
Ответить
Сообщение
Код
=ЕСЛИ((СУММПРОИЗВ(--(((Лист1!$E$2:$E$3000)=E6)*И(ГОД(Лист1!$B$2:$B$3000)=2017))))=0;"";(СУММПРОИЗВ(--(((Лист1!$E$2:$E$3000)=E6)*И(ГОД(Лист1!$B$2:$B$3000)=2017)))))

формула должна считать сколько раз встречается значение из Е6 на листе1 и одновременно чтоб напротив стоял 2017 год, но условия почемуто не выполняется
формула на листах 2017 и 2018 красные ячейки

Автор - IvanIvanovv
Дата добавления - 25.07.2018 в 10:13
Nic70y Дата: Среда, 25.07.2018, 10:19 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4934
Репутация: 1069 ±
Замечаний: 0% ±

Excel 2013
формулы нужно в тЭги сувать,
это красивее и тогда она переводиться.
1)
Код
Лист1!$E$2:$E$3000
в этом диапазоне ни чего нет
2) *И -- не к чему


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Среда, 25.07.2018, 10:22
 
Ответить
Сообщениеформулы нужно в тЭги сувать,
это красивее и тогда она переводиться.
1)
Код
Лист1!$E$2:$E$3000
в этом диапазоне ни чего нет
2) *И -- не к чему

Автор - Nic70y
Дата добавления - 25.07.2018 в 10:19
IvanIvanovv Дата: Среда, 25.07.2018, 10:25 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прошу прощения, прикрепил старую версию файла, вот новая, значения берутся из поля F, но опять же на листе 2017 всё считает, а 2018 почему-то - нет, хотя в формуле просто меняется год сравнения
К сообщению приложен файл: 4002951.xlsx(43.3 Kb)
 
Ответить
СообщениеПрошу прощения, прикрепил старую версию файла, вот новая, значения берутся из поля F, но опять же на листе 2017 всё считает, а 2018 почему-то - нет, хотя в формуле просто меняется год сравнения

Автор - IvanIvanovv
Дата добавления - 25.07.2018 в 10:25
_Boroda_ Дата: Среда, 25.07.2018, 10:30 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13661
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ((Лист1!$E$2:$E$3000=E6)*(ГОД(Лист1!$B$2:$B$3000)=2017))

И формат ячеек
0;;
Для удобства можно писать где-то на листе год и давать ссылку на эту ячейку
Имя листа так можно
Код
=ПРАВБ(ЯЧЕЙКА("имяфайла";AK1);4)

Итого формула для любого года получается
Код
=СУММПРОИЗВ((Лист1!$E$2:$E$3000=E6)*(ГОД(Лист1!$B$2:$B$3000)=--ПРАВБ(ЯЧЕЙКА("имяфайла";AK1);4)))

Для любого языка
Код
=СУММПРОИЗВ((Лист1!$F$2:$F$3000=E6)*(ГОД(Лист1!$B$2:$B$3000)=--ПРАВБ(ЯЧЕЙКА("filename";AK1);4)))


* Добавлено
Писал по старому файлу.
Во вложении новый
К сообщению приложен файл: 4002951_1.xlsx(40.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ((Лист1!$E$2:$E$3000=E6)*(ГОД(Лист1!$B$2:$B$3000)=2017))

И формат ячеек
0;;
Для удобства можно писать где-то на листе год и давать ссылку на эту ячейку
Имя листа так можно
Код
=ПРАВБ(ЯЧЕЙКА("имяфайла";AK1);4)

Итого формула для любого года получается
Код
=СУММПРОИЗВ((Лист1!$E$2:$E$3000=E6)*(ГОД(Лист1!$B$2:$B$3000)=--ПРАВБ(ЯЧЕЙКА("имяфайла";AK1);4)))

Для любого языка
Код
=СУММПРОИЗВ((Лист1!$F$2:$F$3000=E6)*(ГОД(Лист1!$B$2:$B$3000)=--ПРАВБ(ЯЧЕЙКА("filename";AK1);4)))


* Добавлено
Писал по старому файлу.
Во вложении новый

Автор - _Boroda_
Дата добавления - 25.07.2018 в 10:30
IvanIvanovv Дата: Среда, 25.07.2018, 10:32 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
2) *И -- не к чему

убрал но подсчёт почему-то не верный, проверял с помощью фильтра на ЛИСТ1 по одному из значений, и результат формулы не верный, с -- и И он верный, но опять же на без них за 2018 год почему-то считает
 
Ответить
Сообщение
2) *И -- не к чему

убрал но подсчёт почему-то не верный, проверял с помощью фильтра на ЛИСТ1 по одному из значений, и результат формулы не верный, с -- и И он верный, но опять же на без них за 2018 год почему-то считает

Автор - IvanIvanovv
Дата добавления - 25.07.2018 в 10:32
sboy Дата: Среда, 25.07.2018, 10:34 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2225
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
Еще вариант
2017
Код
=СЧЁТЕСЛИМН(Лист1!$F$2:$F$206;E6;Лист1!$B$2:$B$206;"<01/01/2018")

2018
Код
=СЧЁТЕСЛИМН(Лист1!$F$2:$F$206;E6;Лист1!$B$2:$B$206;">=01/01/2018")
К сообщению приложен файл: 4504321.xlsx(43.8 Kb)
 
Ответить
СообщениеЕще вариант
2017
Код
=СЧЁТЕСЛИМН(Лист1!$F$2:$F$206;E6;Лист1!$B$2:$B$206;"<01/01/2018")

2018
Код
=СЧЁТЕСЛИМН(Лист1!$F$2:$F$206;E6;Лист1!$B$2:$B$206;">=01/01/2018")

Автор - sboy
Дата добавления - 25.07.2018 в 10:34
Nic70y Дата: Среда, 25.07.2018, 10:39 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4934
Репутация: 1069 ±
Замечаний: 0% ±

Excel 2013
Ваша формула, без лишнего
Код
=ЕСЛИ(СУММПРОИЗВ((Лист1!$F$2:$F$3000=E6)*(ГОД(Лист1!$B$2:$B$3000)=2017))=0;"";СУММПРОИЗВ((Лист1!$F$2:$F$3000=E6)*(ГОД(Лист1!$B$2:$B$3000)=2017)))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеВаша формула, без лишнего
Код
=ЕСЛИ(СУММПРОИЗВ((Лист1!$F$2:$F$3000=E6)*(ГОД(Лист1!$B$2:$B$3000)=2017))=0;"";СУММПРОИЗВ((Лист1!$F$2:$F$3000=E6)*(ГОД(Лист1!$B$2:$B$3000)=2017)))

Автор - Nic70y
Дата добавления - 25.07.2018 в 10:39
IvanIvanovv Дата: Среда, 25.07.2018, 11:00 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ваша формула, без лишнего

вроди всё заработало СПАСИБО БОЛЬШОЕ hands booze
 
Ответить
Сообщение
Ваша формула, без лишнего

вроди всё заработало СПАСИБО БОЛЬШОЕ hands booze

Автор - IvanIvanovv
Дата добавления - 25.07.2018 в 11:00
IvanIvanovv Дата: Среда, 25.07.2018, 11:02 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
И формат ячеек
0;;
Для удобства можно писать где-то на листе год и давать ссылку на эту ячейку
Имя листа так можно

=ПРАВБ(ЯЧЕЙКА("имяфайла";AK1);4)

спасибо за вариант, но я пока не знаком с функциями ПРАВБ и ЯЧЕЙКА :shy:
 
Ответить
Сообщение
И формат ячеек
0;;
Для удобства можно писать где-то на листе год и давать ссылку на эту ячейку
Имя листа так можно

=ПРАВБ(ЯЧЕЙКА("имяфайла";AK1);4)

спасибо за вариант, но я пока не знаком с функциями ПРАВБ и ЯЧЕЙКА :shy:

Автор - IvanIvanovv
Дата добавления - 25.07.2018 в 11:02
DAVID1990 Дата: Воскресенье, 16.09.2018, 22:15 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер!
Подскажите, как мне в строке С19 получить следующее значение: Нужно в диапазоне С6-С16 выбрать значения, которые больше либо равны 0,010, но меньше 0,020 и СУММУ ИХ КОЛИЧЕСТВА поделить на общее число значений в диапазоне , тем самым получить % отклонений от общего числа значений.
К сообщению приложен файл: 9763271.xls(40.5 Kb)
 
Ответить
СообщениеДобрый вечер!
Подскажите, как мне в строке С19 получить следующее значение: Нужно в диапазоне С6-С16 выбрать значения, которые больше либо равны 0,010, но меньше 0,020 и СУММУ ИХ КОЛИЧЕСТВА поделить на общее число значений в диапазоне , тем самым получить % отклонений от общего числа значений.

Автор - DAVID1990
Дата добавления - 16.09.2018 в 22:15
Pelena Дата: Воскресенье, 16.09.2018, 22:17 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 13298
Репутация: 2927 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
DAVID1990, прочитайте Правила форума и создайте свою тему. Эта тема закрыта


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеDAVID1990, прочитайте Правила форума и создайте свою тему. Эта тема закрыта

Автор - Pelena
Дата добавления - 16.09.2018 в 22:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт количества значений в диапазоне (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!