Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Очистка ячеек при работе с дублями в таблицах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Очистка ячеек при работе с дублями в таблицах (Формулы/Formulas)
Очистка ячеек при работе с дублями в таблицах
ovkkk Дата: Понедельник, 30.07.2018, 13:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет! Имеется таблица с 500 000 записями. Колонки телефон и email содержат много дублей. При использовании функции "удаление дублей" Эксель удаляет полностью строку, что искажает итоговые данные в таблице. Как не удалять строку полностью, а просто очистить ячейки с дублями при этом оставить один из дублей.

Заранее спасибо за ответ.
К сообщению приложен файл: 3969644.xlsx(11.8 Kb)


Сообщение отредактировал ovkkk - Понедельник, 30.07.2018, 14:29
 
Ответить
СообщениеВсем привет! Имеется таблица с 500 000 записями. Колонки телефон и email содержат много дублей. При использовании функции "удаление дублей" Эксель удаляет полностью строку, что искажает итоговые данные в таблице. Как не удалять строку полностью, а просто очистить ячейки с дублями при этом оставить один из дублей.

Заранее спасибо за ответ.

Автор - ovkkk
Дата добавления - 30.07.2018 в 13:51
_Boroda_ Дата: Понедельник, 30.07.2018, 15:34 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13196
Репутация: 5425 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Сортируете таблицу ФИО-Дата-тел-мейл
В ячейке F3 пишете формулу
Код
=СУММПРОИЗВ(--(B3:D3=B2:D2))=3

Сортируете столбец F по ИСТИНА и удаляете в видимых строках ненужное (тел, мейл и, возможно, фамилию)
К сообщению приложен файл: 3969644_1.xlsx(12.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСортируете таблицу ФИО-Дата-тел-мейл
В ячейке F3 пишете формулу
Код
=СУММПРОИЗВ(--(B3:D3=B2:D2))=3

Сортируете столбец F по ИСТИНА и удаляете в видимых строках ненужное (тел, мейл и, возможно, фамилию)

Автор - _Boroda_
Дата добавления - 30.07.2018 в 15:34
ovkkk Дата: Вторник, 31.07.2018, 09:07 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
Не то! к сожалению
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
Не то! к сожалению

Автор - ovkkk
Дата добавления - 31.07.2018 в 09:07
_Boroda_ Дата: Вторник, 31.07.2018, 09:13 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13196
Репутация: 5425 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не то!

Ну простите, что не угодил, я больше так не буду
Может, Вы даже осчастливите нас более развернутым ответом?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Не то!

Ну простите, что не угодил, я больше так не буду
Может, Вы даже осчастливите нас более развернутым ответом?

Автор - _Boroda_
Дата добавления - 31.07.2018 в 09:13
ovkkk Дата: Вторник, 31.07.2018, 16:35 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Постараюсь описать более подробно!=)
Есть таблица, в ней ячейки с ФИО, телефон, емайл. В этих ячейках куча дублей. Если пользоваться функцией "удаление дублей" то удалится вся строка полностью. Хотелось бы найти решение, которое позволит очистить (не удалить) строки с дублями и оставить исходное значение


Сообщение отредактировал ovkkk - Вторник, 31.07.2018, 16:41
 
Ответить
СообщениеПостараюсь описать более подробно!=)
Есть таблица, в ней ячейки с ФИО, телефон, емайл. В этих ячейках куча дублей. Если пользоваться функцией "удаление дублей" то удалится вся строка полностью. Хотелось бы найти решение, которое позволит очистить (не удалить) строки с дублями и оставить исходное значение

Автор - ovkkk
Дата добавления - 31.07.2018 в 16:35
_Boroda_ Дата: Вторник, 31.07.2018, 18:20 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13196
Репутация: 5425 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А я Вам что написал? Вы попробовали хотя бы? Или увидели слово "Удаляете" и всё? Удалять не строки нужно, а просто на Делит нажать


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА я Вам что написал? Вы попробовали хотя бы? Или увидели слово "Удаляете" и всё? Удалять не строки нужно, а просто на Делит нажать

Автор - _Boroda_
Дата добавления - 31.07.2018 в 18:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Очистка ячеек при работе с дублями в таблицах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!