Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать сколько названий удовлетворяют условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сколько названий удовлетворяют условию (Формулы/Formulas)
Посчитать сколько названий удовлетворяют условию
awaddwaawddw Дата: Понедельник, 30.07.2018, 23:18 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 165
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Будьте любезны:

Имеются названия с числами, необходимо посчитать количество названий которые будут удовлетворять условию: левое число больше правого.

Приложил эксель файл.
К сообщению приложен файл: 6321156.xlsx(13.0 Kb)
 
Ответить
СообщениеБудьте любезны:

Имеются названия с числами, необходимо посчитать количество названий которые будут удовлетворять условию: левое число больше правого.

Приложил эксель файл.

Автор - awaddwaawddw
Дата добавления - 30.07.2018 в 23:18
krosav4ig Дата: Понедельник, 30.07.2018, 23:46 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1658
Репутация: 690 ±
Замечаний: 0% ±

Excel 2007,2010,2013
и вам здрасте
Код
=СУММПРОИЗВ((ПРАВБ('2'!$A1:$S1;ДЛСТР(B$1))=B$1)*('2'!$D1:$V1>'2'!$E1:$W1))
К сообщению приложен файл: 8522087.xlsx(13.2 Kb)


(_)Õvõ(_)
 
Ответить
Сообщениеи вам здрасте
Код
=СУММПРОИЗВ((ПРАВБ('2'!$A1:$S1;ДЛСТР(B$1))=B$1)*('2'!$D1:$V1>'2'!$E1:$W1))

Автор - krosav4ig
Дата добавления - 30.07.2018 в 23:46
pabchek Дата: Вторник, 31.07.2018, 10:39 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 899
Репутация: 215 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Наверное, длинна строки не очень корректный вариант если условие будет иметь одинаковое количество символов.
Немного модифицировал для такого случая:
Код
=СУММПРОИЗВ((ПРАВБ('2'!A1:S1;4)="один")*('2'!D1:V1>'2'!E1:W1))


Да, мне подсказали, я был неправ - недопонял. Свой вариант оставлю, как рабочий, но менее универсальный)))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 31.07.2018, 11:35
 
Ответить
СообщениеЗдравствуйте!
Наверное, длинна строки не очень корректный вариант если условие будет иметь одинаковое количество символов.
Немного модифицировал для такого случая:
Код
=СУММПРОИЗВ((ПРАВБ('2'!A1:S1;4)="один")*('2'!D1:V1>'2'!E1:W1))


Да, мне подсказали, я был неправ - недопонял. Свой вариант оставлю, как рабочий, но менее универсальный)))

Автор - pabchek
Дата добавления - 31.07.2018 в 10:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сколько названий удовлетворяют условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!