Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Избежать повторяющихся фрагментов в формуле ЕСЛИ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Избежать повторяющихся фрагментов в формуле ЕСЛИ (Формулы/Formulas)
Избежать повторяющихся фрагментов в формуле ЕСЛИ
Anis625 Дата: Среда, 01.08.2018, 23:03 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 147
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер, уважаемые коллеги!

Не кидайте, пожалуйста, помидорами если это плюшевый вопрос. И все же давно с ним мучаюсь и вот решил спросить гуру Excel.
Если честно сделал несколько попыток найти ответ в интернете, увы даже не знаю как описать проблему. Поэтому пример выложил во вложении.

Наверняка решение простое.
К сообщению приложен файл: Primer.xlsx(8.8 Kb)


Сообщение отредактировал Pelena - Четверг, 02.08.2018, 09:35
 
Ответить
СообщениеДобрый вечер, уважаемые коллеги!

Не кидайте, пожалуйста, помидорами если это плюшевый вопрос. И все же давно с ним мучаюсь и вот решил спросить гуру Excel.
Если честно сделал несколько попыток найти ответ в интернете, увы даже не знаю как описать проблему. Поэтому пример выложил во вложении.

Наверняка решение простое.

Автор - Anis625
Дата добавления - 01.08.2018 в 23:03
Светлый Дата: Среда, 01.08.2018, 23:27 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 652
Репутация: 176 ±
Замечаний: 0% ±

Excel 2010
Добрый!
Вариант с другой функцией:
Код
=ЕСЛИ(ВПР(G9;B4:C6;2;)>=10;ВПР(G9;B4:C6;2;);"не берем")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый!
Вариант с другой функцией:
Код
=ЕСЛИ(ВПР(G9;B4:C6;2;)>=10;ВПР(G9;B4:C6;2;);"не берем")

Автор - Светлый
Дата добавления - 01.08.2018 в 23:27
Anis625 Дата: Среда, 01.08.2018, 23:30 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 147
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Светлый,
Дело не в оптимизации внутренней формулы (с этим проблем нет, пишу формулы).
Как можно заменить необходимость прописывания длинной формулы в условии (функции ЕСЛИ) и необходимость опять ее писать в случае выполнения условия.
Как функция ЕСЛИОШИБКА(проверка условия;то выдать), только для ЕСЛИ.
 
Ответить
СообщениеСветлый,
Дело не в оптимизации внутренней формулы (с этим проблем нет, пишу формулы).
Как можно заменить необходимость прописывания длинной формулы в условии (функции ЕСЛИ) и необходимость опять ее писать в случае выполнения условия.
Как функция ЕСЛИОШИБКА(проверка условия;то выдать), только для ЕСЛИ.

Автор - Anis625
Дата добавления - 01.08.2018 в 23:30
Светлый Дата: Среда, 01.08.2018, 23:40 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 652
Репутация: 176 ±
Замечаний: 0% ±

Excel 2010
С некоторыми допущениями:
Код
=СУММЕСЛИМН(C4:C6;B4:B6;G9;C4:C6;">=10")

и форматом 0;;не берё\м
А в ЕСЛИ придётся писать два раза.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеС некоторыми допущениями:
Код
=СУММЕСЛИМН(C4:C6;B4:B6;G9;C4:C6;">=10")

и форматом 0;;не берё\м
А в ЕСЛИ придётся писать два раза.

Автор - Светлый
Дата добавления - 01.08.2018 в 23:40
Anis625 Дата: Среда, 01.08.2018, 23:50 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 147
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Светлый,
В принципе вариант для данной задачки.
 
Ответить
СообщениеСветлый,
В принципе вариант для данной задачки.

Автор - Anis625
Дата добавления - 01.08.2018 в 23:50
Светлый Дата: Среда, 01.08.2018, 23:50 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 652
Репутация: 176 ±
Замечаний: 0% ±

Excel 2010
Можно подменить второй столбец условием ЕСЛИ и в нём сразу брать нужное значение:
Код
=ВПР(G9;ЕСЛИ({1;0};B4:B6;ЕСЛИ(C4:C6>=10;C4:C6;"не берем"));2;)

формула массива.
Доб.
Или так:
Код
=ИНДЕКС(ЕСЛИ(C4:C6>=10;C4:C6;"не берем");ПОИСКПОЗ(G9;B4:B6;))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 01.08.2018, 23:56
 
Ответить
СообщениеМожно подменить второй столбец условием ЕСЛИ и в нём сразу брать нужное значение:
Код
=ВПР(G9;ЕСЛИ({1;0};B4:B6;ЕСЛИ(C4:C6>=10;C4:C6;"не берем"));2;)

формула массива.
Доб.
Или так:
Код
=ИНДЕКС(ЕСЛИ(C4:C6>=10;C4:C6;"не берем");ПОИСКПОЗ(G9;B4:B6;))

Автор - Светлый
Дата добавления - 01.08.2018 в 23:50
Pelena Дата: Четверг, 02.08.2018, 09:33 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13119
Репутация: 2890 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
заменить необходимость прописывания длинной формулы

Можно присвоить повторяющемуся фрагменту имя, и уже его использовать в формуле
См. диспетчер имён Ctrl+F3
К сообщению приложен файл: Primer-3-.xlsx(9.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
заменить необходимость прописывания длинной формулы

Можно присвоить повторяющемуся фрагменту имя, и уже его использовать в формуле
См. диспетчер имён Ctrl+F3

Автор - Pelena
Дата добавления - 02.08.2018 в 09:33
pabchek Дата: Четверг, 02.08.2018, 11:54 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 899
Репутация: 215 ±
Замечаний: 0% ±

Excel 2007
Может так?
Код
=1/ЕСЛИОШИБКА(1/ИНДЕКС($C$4:$C$6;ПОИСКПОЗ(G9;B4:B6;0);1);"Не берем")


Нет, не в ту сторону думал(((
По ходу проскочил не очень ликвидный вариант с УФ:
Формула в ячейку обычная:
Код
=ИНДЕКС($C$4:$C$6;ПОИСКПОЗ(G9;B4:B6;0);1)

В УФ
Код
=$H$9<10
(вместо 10 можно ссылку на ячейку с условием)
И формат числа: "Не берем" (можно по полной "Не берем";"Не берем";"Не берем";"Не берем")
К сообщению приложен файл: 5887042.xlsx(8.8 Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Четверг, 02.08.2018, 12:57
 
Ответить
СообщениеМожет так?
Код
=1/ЕСЛИОШИБКА(1/ИНДЕКС($C$4:$C$6;ПОИСКПОЗ(G9;B4:B6;0);1);"Не берем")


Нет, не в ту сторону думал(((
По ходу проскочил не очень ликвидный вариант с УФ:
Формула в ячейку обычная:
Код
=ИНДЕКС($C$4:$C$6;ПОИСКПОЗ(G9;B4:B6;0);1)

В УФ
Код
=$H$9<10
(вместо 10 можно ссылку на ячейку с условием)
И формат числа: "Не берем" (можно по полной "Не берем";"Не берем";"Не берем";"Не берем")

Автор - pabchek
Дата добавления - 02.08.2018 в 11:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Избежать повторяющихся фрагментов в формуле ЕСЛИ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!