Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнение табеля рабочего времени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение табеля рабочего времени (Формулы/Formulas)
Автоматическое заполнение табеля рабочего времени
EvgenyAgeev Дата: Четверг, 02.08.2018, 15:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Всем привет.

Прошу помощи. Во вложении табель. Проблемы с вкладкой "Июль 2018". Она формируется из вкладки "Список бригады". Суть такая - во вкладке "Список бригады" проставляются галочки напротив тех сотрудников, которых нужно внести в табель. Дальше по условию я просто дублирую этот список людей во вкладку "Июль 2018" (потом этот столбец скроется). Для первого человека формула готова - она определяет первого сотрудника в столбце и выводит в ячейку, это то, что нужно.

Проблема с последующими людьми: нужно, чтобы формула определяла первого человека в ячейке С3, пробегалась по ячейкам столбца В, находила этого сотрудника, исключала, а сразу следующего сотрудника, видимого в ячейке (не обязательно следующей сразу за "исключенным" сотрудником) выводила в ячейку С14 и так далее вниз соответственно.

Вопрос задавал здесь, но там нет ответа.
К сообщению приложен файл: 7478110.png(117.3 Kb) · 2127639.xlsx(36.7 Kb)
 
Ответить
СообщениеВсем привет.

Прошу помощи. Во вложении табель. Проблемы с вкладкой "Июль 2018". Она формируется из вкладки "Список бригады". Суть такая - во вкладке "Список бригады" проставляются галочки напротив тех сотрудников, которых нужно внести в табель. Дальше по условию я просто дублирую этот список людей во вкладку "Июль 2018" (потом этот столбец скроется). Для первого человека формула готова - она определяет первого сотрудника в столбце и выводит в ячейку, это то, что нужно.

Проблема с последующими людьми: нужно, чтобы формула определяла первого человека в ячейке С3, пробегалась по ячейкам столбца В, находила этого сотрудника, исключала, а сразу следующего сотрудника, видимого в ячейке (не обязательно следующей сразу за "исключенным" сотрудником) выводила в ячейку С14 и так далее вниз соответственно.

Вопрос задавал здесь, но там нет ответа.

Автор - EvgenyAgeev
Дата добавления - 02.08.2018 в 15:45
krosav4ig Дата: Четверг, 02.08.2018, 17:24 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1623
Репутация: 679 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Добрый день
Попробуйте так
Код
=ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ($B$3:$B$882="";"";СТРОКА($B$3:$B$882));(СТРОКА()+8)/11))


[p.s.]формула массивная, вводится комбинацией клавиш Ctrl+Shift+Enter


(_)Õvõ(_)
 
Ответить
СообщениеДобрый день
Попробуйте так
Код
=ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ($B$3:$B$882="";"";СТРОКА($B$3:$B$882));(СТРОКА()+8)/11))


[p.s.]формула массивная, вводится комбинацией клавиш Ctrl+Shift+Enter

Автор - krosav4ig
Дата добавления - 02.08.2018 в 17:24
EvgenyAgeev Дата: Четверг, 02.08.2018, 18:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Добрый день
Попробуйте так

=ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ($B$3:$B$882="";"";СТРОКА($B$3:$B$882));(СТРОКА()+8)/11))


Оу, работает! hands Пока только не понимаю как. Спасибо огромное!
 
Ответить
Сообщение
Добрый день
Попробуйте так

=ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ($B$3:$B$882="";"";СТРОКА($B$3:$B$882));(СТРОКА()+8)/11))


Оу, работает! hands Пока только не понимаю как. Спасибо огромное!

Автор - EvgenyAgeev
Дата добавления - 02.08.2018 в 18:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение табеля рабочего времени (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!