Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР по нескольким критериям со смещением строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР по нескольким критериям со смещением строк (Формулы/Formulas)
ВПР по нескольким критериям со смещением строк
EvgenyAgeev Дата: Пятница, 03.08.2018, 15:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Всем привет.

Прошу вашей помощи. Суть проблемы: нужна формула, которая должна выступать аналогом ф-ии ВПР (или быть ф-й ВПР), но поиск и вывод конечного результата должен производиться по нескольким критериям (искомым значениям). При чем, одно из искомых значений смещено от других на несколько строк. Пример во вложении.
К сообщению приложен файл: 2521936.xls(44.0 Kb)
 
Ответить
СообщениеВсем привет.

Прошу вашей помощи. Суть проблемы: нужна формула, которая должна выступать аналогом ф-ии ВПР (или быть ф-й ВПР), но поиск и вывод конечного результата должен производиться по нескольким критериям (искомым значениям). При чем, одно из искомых значений смещено от других на несколько строк. Пример во вложении.

Автор - EvgenyAgeev
Дата добавления - 03.08.2018 в 15:01
sboy Дата: Пятница, 03.08.2018, 15:05 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2112
Репутация: 605 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Между фамилиями всегда одинаковое количество строк?
 
Ответить
СообщениеДобрый день.
Между фамилиями всегда одинаковое количество строк?

Автор - sboy
Дата добавления - 03.08.2018 в 15:05
EvgenyAgeev Дата: Пятница, 03.08.2018, 15:09 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Добрый день.
Между фамилиями всегда одинаковое количество строк?

Да, оно будет всегда сохраняться.
 
Ответить
Сообщение
Добрый день.
Между фамилиями всегда одинаковое количество строк?

Да, оно будет всегда сохраняться.

Автор - EvgenyAgeev
Дата добавления - 03.08.2018 в 15:09
sboy Дата: Пятница, 03.08.2018, 15:13 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2112
Репутация: 605 ±
Замечаний: 0% ±

Excel 2010
Вот такой вариант
Код
=ВПР(M$1;ИНДЕКС($C$1:$C$999;ПОИСКПОЗ($I2;$A$1:$A$999;)):ИНДЕКС($D$1:$D$999;ПОИСКПОЗ($I2;$A$1:$A$999;)+10);2;)
К сообщению приложен файл: 6167019.xls(44.0 Kb)


Сообщение отредактировал sboy - Пятница, 03.08.2018, 15:17
 
Ответить
СообщениеВот такой вариант
Код
=ВПР(M$1;ИНДЕКС($C$1:$C$999;ПОИСКПОЗ($I2;$A$1:$A$999;)):ИНДЕКС($D$1:$D$999;ПОИСКПОЗ($I2;$A$1:$A$999;)+10);2;)

Автор - sboy
Дата добавления - 03.08.2018 в 15:13
EvgenyAgeev Дата: Пятница, 03.08.2018, 15:47 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Вот такой вариант

=ВПР(M$1;ИНДЕКС($C$1:$C$999;ПОИСКПОЗ($I2;$A$1:$A$999;)):ИНДЕКС($D$1:$D$999;ПОИСКПОЗ($I2;$A$1:$A$999;)+10);2;)

Все отлично работает! hands Спасибо!
 
Ответить
Сообщение
Вот такой вариант

=ВПР(M$1;ИНДЕКС($C$1:$C$999;ПОИСКПОЗ($I2;$A$1:$A$999;)):ИНДЕКС($D$1:$D$999;ПОИСКПОЗ($I2;$A$1:$A$999;)+10);2;)

Все отлично работает! hands Спасибо!

Автор - EvgenyAgeev
Дата добавления - 03.08.2018 в 15:47
jakim Дата: Пятница, 03.08.2018, 18:15 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 844
Репутация: 223 ±
Замечаний: 0% ±

Excel 2010
Сперва уберите объединённые ячейки, а потом можно использовать комбиннацию ПОИСКПОЗ и ИНДЕКС.
В приложении объединение ячеек сохранено.

Код
=INDEX(D$3:D$24;MATCH(I2;A$3:A$24;0)+5)
К сообщению приложен файл: 6508485.xls(45.0 Kb)


Сообщение отредактировал jakim - Пятница, 03.08.2018, 18:16
 
Ответить
Сообщение
Сперва уберите объединённые ячейки, а потом можно использовать комбиннацию ПОИСКПОЗ и ИНДЕКС.
В приложении объединение ячеек сохранено.

Код
=INDEX(D$3:D$24;MATCH(I2;A$3:A$24;0)+5)

Автор - jakim
Дата добавления - 03.08.2018 в 18:15
EvgenyAgeev Дата: Воскресенье, 05.08.2018, 11:55 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Сперва уберите объединённые ячейки, а потом можно использовать комбиннацию ПОИСКПОЗ и ИНДЕКС.
В приложении объединение ячеек сохранено.

=ИНДЕКС(D$3:D$24;ПОИСКПОЗ(I2;A$3:A$24;0)+5)


Спасибо!
 
Ответить
Сообщение
Сперва уберите объединённые ячейки, а потом можно использовать комбиннацию ПОИСКПОЗ и ИНДЕКС.
В приложении объединение ячеек сохранено.

=ИНДЕКС(D$3:D$24;ПОИСКПОЗ(I2;A$3:A$24;0)+5)


Спасибо!

Автор - EvgenyAgeev
Дата добавления - 05.08.2018 в 11:55
jakim Дата: Воскресенье, 05.08.2018, 14:13 | Сообщение № 8
Группа: Друзья
Ранг: Ветеран
Сообщений: 844
Репутация: 223 ±
Замечаний: 0% ±

Excel 2010
В формулу можно добавить дополнительный поиск условиия ячейки М1 в столбце С.

Код
=INDEX(D$3:D$24;MATCH(I2;A$3:A$24;0)+MATCH(M$1;C$3:C$24;0)-1)
 
Ответить
Сообщение
В формулу можно добавить дополнительный поиск условиия ячейки М1 в столбце С.

Код
=INDEX(D$3:D$24;MATCH(I2;A$3:A$24;0)+MATCH(M$1;C$3:C$24;0)-1)

Автор - jakim
Дата добавления - 05.08.2018 в 14:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР по нескольким критериям со смещением строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!