Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчет значений в определенном временном диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет значений в определенном временном диапазоне (Формулы/Formulas)
подсчет значений в определенном временном диапазоне
denstyle Дата: Понедельник, 20.08.2018, 18:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте! Направьте на путь истинный. Есть таблица с данными по проведению ревизии ящиков в отделе, разбита по декадам (1-10; 11-20;21-31), ну и внесены данные в определенных временных периодах. Что требуется: снизу от основной таблицы есть отчетная таблица, выше нее выбираем временный период, а в таблице должно отобразиться сколько ревизий было проведено в этот временной период. Думал может как-нибудь через ВПР, но мешает именно запись декад, там хоть и можно изменить на даты, но количество столбцов в декаде должно быть неизменно (5).
К сообщению приложен файл: 8760337.xls(58.5 Kb)


С уважнием, Денис.
 
Ответить
СообщениеЗдравствуйте! Направьте на путь истинный. Есть таблица с данными по проведению ревизии ящиков в отделе, разбита по декадам (1-10; 11-20;21-31), ну и внесены данные в определенных временных периодах. Что требуется: снизу от основной таблицы есть отчетная таблица, выше нее выбираем временный период, а в таблице должно отобразиться сколько ревизий было проведено в этот временной период. Думал может как-нибудь через ВПР, но мешает именно запись декад, там хоть и можно изменить на даты, но количество столбцов в декаде должно быть неизменно (5).

Автор - denstyle
Дата добавления - 20.08.2018 в 18:22
Nic70y Дата: Понедельник, 20.08.2018, 19:11 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4795
Репутация: 1035 ±
Замечаний: 0% ±

Excel 2013
в декаде должно быть неизменно (5)
т.е 1 столбец на 2 дня,
если в F56:F57 даты будут "пропорциональны" этим столбцам (в примере так и есть) то можно сосчитать.
если будет 01.01.2018-09.01.2018 то уже проблематично.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 20.08.2018, 19:13
 
Ответить
Сообщение
в декаде должно быть неизменно (5)
т.е 1 столбец на 2 дня,
если в F56:F57 даты будут "пропорциональны" этим столбцам (в примере так и есть) то можно сосчитать.
если будет 01.01.2018-09.01.2018 то уже проблематично.

Автор - Nic70y
Дата добавления - 20.08.2018 в 19:11
denstyle Дата: Понедельник, 20.08.2018, 19:29 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, да, я вот о том же.. а если все-таки удастся развернуть полностью даты, т.е. каждый столбец будет дата (D3-01.01.18;C3-02.01.18 и т.д.), то как функцию правильно прописать?


С уважнием, Денис.
 
Ответить
СообщениеNic70y, да, я вот о том же.. а если все-таки удастся развернуть полностью даты, т.е. каждый столбец будет дата (D3-01.01.18;C3-02.01.18 и т.д.), то как функцию правильно прописать?

Автор - denstyle
Дата добавления - 20.08.2018 в 19:29
Nic70y Дата: Понедельник, 20.08.2018, 19:37 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4795
Репутация: 1035 ±
Замечаний: 0% ±

Excel 2013
то как функцию правильно
вариантом много,
например
Код
=СЧЁТЕСЛИ(ИНДЕКС($4:$53;;ПОИСКПОЗ($F$56;$3:$3)):ИНДЕКС($4:$53;;ПОИСКПОЗ($F$57;$3:$3));"Щ")


добавлено:
возникла такая мысль, если считать по законченным декадам, например даты с 1 по 11 - учитывать только с 1 по 10
то без проблем
К сообщению приложен файл: 0134997.xls(56.5 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 20.08.2018, 19:45
 
Ответить
Сообщение
то как функцию правильно
вариантом много,
например
Код
=СЧЁТЕСЛИ(ИНДЕКС($4:$53;;ПОИСКПОЗ($F$56;$3:$3)):ИНДЕКС($4:$53;;ПОИСКПОЗ($F$57;$3:$3));"Щ")


добавлено:
возникла такая мысль, если считать по законченным декадам, например даты с 1 по 11 - учитывать только с 1 по 10
то без проблем

Автор - Nic70y
Дата добавления - 20.08.2018 в 19:37
_Boroda_ Дата: Понедельник, 20.08.2018, 19:55 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12958
Репутация: 5330 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще например (если начало с 1-го числа года)
Код
=СЧЁТЕСЛИ(ИНДЕКС(4:4;$F56-$D3+4):ИНДЕКС(53:53;$F57-$D3+4);"Щ")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще например (если начало с 1-го числа года)
Код
=СЧЁТЕСЛИ(ИНДЕКС(4:4;$F56-$D3+4):ИНДЕКС(53:53;$F57-$D3+4);"Щ")

Автор - _Boroda_
Дата добавления - 20.08.2018 в 19:55
denstyle Дата: Понедельник, 20.08.2018, 20:09 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, спасибо))


С уважнием, Денис.
 
Ответить
СообщениеNic70y, спасибо))

Автор - denstyle
Дата добавления - 20.08.2018 в 20:09
denstyle Дата: Понедельник, 20.08.2018, 20:09 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо!


С уважнием, Денис.
 
Ответить
Сообщение_Boroda_, Спасибо!

Автор - denstyle
Дата добавления - 20.08.2018 в 20:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет значений в определенном временном диапазоне (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!