Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/помочь создать формулу с условием поиска по другому файлу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » помочь создать формулу с условием поиска по другому файлу (Формулы/Formulas)
помочь создать формулу с условием поиска по другому файлу
Shojgy Дата: Вторник, 28.08.2018, 01:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
доброй ночи, господа.

У меня имеется два табличных файла: первый - мой рабочий, в нем есть перечень артикулов продукции, на которую нужно проставить цены. второй файл - прайс-лист компании-производителя данной продукции типа пары столбцов "артикул" и " цена". В первом файле мне нужно создать формулу, которая бы обращалась к ячейке с артикулом продукции первого файла, искала соответствие по данному артикулу, и выдавала результатом цену этого артикула из файла прайса (файл №2)
К сообщению приложен файл: 7393186.xlsx(10.8 Kb) · 5947833.xlsx(10.1 Kb)


Сообщение отредактировал Shojgy - Вторник, 28.08.2018, 08:47
 
Ответить
Сообщениедоброй ночи, господа.

У меня имеется два табличных файла: первый - мой рабочий, в нем есть перечень артикулов продукции, на которую нужно проставить цены. второй файл - прайс-лист компании-производителя данной продукции типа пары столбцов "артикул" и " цена". В первом файле мне нужно создать формулу, которая бы обращалась к ячейке с артикулом продукции первого файла, искала соответствие по данному артикулу, и выдавала результатом цену этого артикула из файла прайса (файл №2)

Автор - Shojgy
Дата добавления - 28.08.2018 в 01:57
krosav4ig Дата: Вторник, 28.08.2018, 03:23 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1649
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Здраствуйте.
Читаем тут
Потом тут


(_)Õvõ(_)
 
Ответить
СообщениеЗдраствуйте.
Читаем тут
Потом тут

Автор - krosav4ig
Дата добавления - 28.08.2018 в 03:23
Shojgy Дата: Вторник, 28.08.2018, 08:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
krosav4ig, прошу прощения. файлы приложил.

7393186.xlsx - файл рабочий. в столбце "D" артикул, в столбец "H" надо вставить формулу, которая сравнит столбец "D" со столбцом "B" файла 5947833.xlsx и, в случае нахождения полного соответствия вставит данные из столбца "C" файла 5947833.xlsx.

второй вариант вопроса - похожий, только формула сравнит столбец "D" со столбцом "B" файла 5947833.xlsx и, в случае нахождения артикула полностью или, как часть большего числа символов, также вставит данные из столбца "C" файла 5947833.xlsx.

Правильно теперь я сформулировал вопрос?
 
Ответить
Сообщениеkrosav4ig, прошу прощения. файлы приложил.

7393186.xlsx - файл рабочий. в столбце "D" артикул, в столбец "H" надо вставить формулу, которая сравнит столбец "D" со столбцом "B" файла 5947833.xlsx и, в случае нахождения полного соответствия вставит данные из столбца "C" файла 5947833.xlsx.

второй вариант вопроса - похожий, только формула сравнит столбец "D" со столбцом "B" файла 5947833.xlsx и, в случае нахождения артикула полностью или, как часть большего числа символов, также вставит данные из столбца "C" файла 5947833.xlsx.

Правильно теперь я сформулировал вопрос?

Автор - Shojgy
Дата добавления - 28.08.2018 в 08:56
Pelena Дата: Вторник, 28.08.2018, 09:06 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13033
Репутация: 2877 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Для полного совпадения
Код
=ВПР(D2;[5947833.xlsx]Лист1!B$2:C$22;2;0)

Для частичного
Код
=ВПР("*"&D2&"*";[5947833.xlsx]Лист1!B$2:C$22;2;0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДля полного совпадения
Код
=ВПР(D2;[5947833.xlsx]Лист1!B$2:C$22;2;0)

Для частичного
Код
=ВПР("*"&D2&"*";[5947833.xlsx]Лист1!B$2:C$22;2;0)

Автор - Pelena
Дата добавления - 28.08.2018 в 09:06
Shojgy Дата: Вторник, 28.08.2018, 09:29 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
спасибо!
 
Ответить
Сообщениеспасибо!

Автор - Shojgy
Дата добавления - 28.08.2018 в 09:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » помочь создать формулу с условием поиска по другому файлу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!