Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка схем в зависимости от нумерации - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка схем в зависимости от нумерации (Формулы/Formulas)
Подстановка схем в зависимости от нумерации
Bill_Murray Дата: Четверг, 30.08.2018, 13:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток, Увожаемые форумчане!
Столкнулся со странной ситуацией, простым ВПР не могу решить.
Есть таблица с номерами схем и есть вторая с расшифровками. Каким образом можно сделать так, чтобы например вместо "8" заполнилась клетка "9.00-18.00" какую формулу можно применить?
К сообщению приложен файл: 2749929.xlsx(11.7 Kb)
 
Ответить
СообщениеДоброго времени суток, Увожаемые форумчане!
Столкнулся со странной ситуацией, простым ВПР не могу решить.
Есть таблица с номерами схем и есть вторая с расшифровками. Каким образом можно сделать так, чтобы например вместо "8" заполнилась клетка "9.00-18.00" какую формулу можно применить?

Автор - Bill_Murray
Дата добавления - 30.08.2018 в 13:50
Bill_Murray Дата: Четверг, 30.08.2018, 13:52 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Звучит наверное глупо или это просто, я конечно извиняюсь
 
Ответить
СообщениеЗвучит наверное глупо или это просто, я конечно извиняюсь

Автор - Bill_Murray
Дата добавления - 30.08.2018 в 13:52
Bill_Murray Дата: Четверг, 30.08.2018, 13:54 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Или поделитесь ссылкой на ресурс
 
Ответить
СообщениеИли поделитесь ссылкой на ресурс

Автор - Bill_Murray
Дата добавления - 30.08.2018 в 13:54
_Boroda_ Дата: Четверг, 30.08.2018, 14:02 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12958
Репутация: 5330 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Рядом можно написать
Код
=ЕСЛИОШИБКА(ВПР(A3;$L$2:$M$39;2;);A3)

Если нужно, то потом полученное можно скопировать и вставить значениями в диапазон А3:Е10
К сообщению приложен файл: 2749929_1.xlsx(14.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеРядом можно написать
Код
=ЕСЛИОШИБКА(ВПР(A3;$L$2:$M$39;2;);A3)

Если нужно, то потом полученное можно скопировать и вставить значениями в диапазон А3:Е10

Автор - _Boroda_
Дата добавления - 30.08.2018 в 14:02
Bill_Murray Дата: Четверг, 30.08.2018, 14:25 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, блин всё элементарно!) Спасибо)
И подскажите почему, если например А3 пустая, то формула принимает значение "0"?
 
Ответить
Сообщение_Boroda_, блин всё элементарно!) Спасибо)
И подскажите почему, если например А3 пустая, то формула принимает значение "0"?

Автор - Bill_Murray
Дата добавления - 30.08.2018 в 14:25
_Boroda_ Дата: Четверг, 30.08.2018, 14:34 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12958
Репутация: 5330 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Потому, что ВПР тогда дает ошибку, следовательно, смотрим на второй аргумент ЕСЛИОШИБКА, а там ссылка на А3. Ссылка на пустую ячейку дает ноль. Если нужно именно пустую ячейку, то напишите так
Код
=ЕСЛИОШИБКА(ВПР(A3;$L$2:$M$39;2;);A3)&""
К сообщению приложен файл: 2749929_2.xlsx(14.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПотому, что ВПР тогда дает ошибку, следовательно, смотрим на второй аргумент ЕСЛИОШИБКА, а там ссылка на А3. Ссылка на пустую ячейку дает ноль. Если нужно именно пустую ячейку, то напишите так
Код
=ЕСЛИОШИБКА(ВПР(A3;$L$2:$M$39;2;);A3)&""

Автор - _Boroda_
Дата добавления - 30.08.2018 в 14:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка схем в зависимости от нумерации (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!