Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма и счёт в диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма и счёт в диапазоне (Формулы/Formulas)
Сумма и счёт в диапазоне
zegor Дата: Пятница, 31.08.2018, 10:06 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 118
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Привет, excelworld. Пытаюсь получить что-то вроде =СУММЕСЛИ(A:A;"от B1*0,95 до B1*1,05") так же и СЧЁТЕСЛИ. Смысл в том что бы суммировать всё что попадает в диапазон +/- 5% от критерия, ну и посчитать какое количество слагаемых было вовлечено.
К сообщению приложен файл: 111.xlsx(8.7 Kb)
 
Ответить
СообщениеПривет, excelworld. Пытаюсь получить что-то вроде =СУММЕСЛИ(A:A;"от B1*0,95 до B1*1,05") так же и СЧЁТЕСЛИ. Смысл в том что бы суммировать всё что попадает в диапазон +/- 5% от критерия, ну и посчитать какое количество слагаемых было вовлечено.

Автор - zegor
Дата добавления - 31.08.2018 в 10:06
Светлый Дата: Пятница, 31.08.2018, 10:18 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 612
Репутация: 165 ±
Замечаний: 0% ±

Excel 2010
День добрый!
Код
=СУММЕСЛИМН(A:A;A:A;">="&B1*0,95;A:A;"<="&B1*1,05)

Код
=СЧЁТЕСЛИМН(A:A;">="&B1*0,95;A:A;"<="&B1*1,05)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДень добрый!
Код
=СУММЕСЛИМН(A:A;A:A;">="&B1*0,95;A:A;"<="&B1*1,05)

Код
=СЧЁТЕСЛИМН(A:A;">="&B1*0,95;A:A;"<="&B1*1,05)

Автор - Светлый
Дата добавления - 31.08.2018 в 10:18
zegor Дата: Пятница, 31.08.2018, 10:25 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 118
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Светлый, огромное спасибо.
 
Ответить
СообщениеСветлый, огромное спасибо.

Автор - zegor
Дата добавления - 31.08.2018 в 10:25
Che79 Дата: Пятница, 31.08.2018, 17:09 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1273
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Эх, совсем я Excel забывать стал...
Сумма
Код
СУММПРОИЗВ($A$1:ИНДЕКС($A:$A;СЧЁТ($A:$A))*(A1:ИНДЕКС($A:$A;СЧЁТ($A:$A))>=$B$1*0,95)*(A1:ИНДЕКС($A:$A;СЧЁТ($A:$A))<=$B$1*1,05))
Счёт
Код
=СУММПРОИЗВ(($A$1:ИНДЕКС($A:$A;СЧЁТ($A:$A))>0)*(A1:ИНДЕКС($A:$A;СЧЁТ($A:$A))>=$B$1*0,95)*($A$1:ИНДЕКС($A:$A;СЧЁТ($A:$A))<=$B$1*1,05))


Делай нормально и будет нормально!
 
Ответить
СообщениеЭх, совсем я Excel забывать стал...
Сумма
Код
СУММПРОИЗВ($A$1:ИНДЕКС($A:$A;СЧЁТ($A:$A))*(A1:ИНДЕКС($A:$A;СЧЁТ($A:$A))>=$B$1*0,95)*(A1:ИНДЕКС($A:$A;СЧЁТ($A:$A))<=$B$1*1,05))
Счёт
Код
=СУММПРОИЗВ(($A$1:ИНДЕКС($A:$A;СЧЁТ($A:$A))>0)*(A1:ИНДЕКС($A:$A;СЧЁТ($A:$A))>=$B$1*0,95)*($A$1:ИНДЕКС($A:$A;СЧЁТ($A:$A))<=$B$1*1,05))

Автор - Che79
Дата добавления - 31.08.2018 в 17:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма и счёт в диапазоне (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!