Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение пустых ячеек данными из соседних ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение пустых ячеек данными из соседних ячеек (Формулы/Formulas)
Заполнение пустых ячеек данными из соседних ячеек
Barbos_TN Дата: Понедельник, 03.09.2018, 16:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет :) !

Прошу помощи в написании не сложного алгоритма для заполнения пустых ячеек с номерами страниц.
Есть список авторов, но номер страницы есть не у всех.
Нужно все пустые ячейки, находящиеся выше, заполнить точно таким же номером.
В ручную очень долго - около 1000 авторов.
Во вложении файл с задачкой...
Помогите, пожалуйста.
К сообщению приложен файл: 7441474.xlsx(11.1 Kb)


Сообщение отредактировал Barbos_TN - Понедельник, 03.09.2018, 16:09
 
Ответить
СообщениеВсем привет :) !

Прошу помощи в написании не сложного алгоритма для заполнения пустых ячеек с номерами страниц.
Есть список авторов, но номер страницы есть не у всех.
Нужно все пустые ячейки, находящиеся выше, заполнить точно таким же номером.
В ручную очень долго - около 1000 авторов.
Во вложении файл с задачкой...
Помогите, пожалуйста.

Автор - Barbos_TN
Дата добавления - 03.09.2018 в 16:08
_Boroda_ Дата: Понедельник, 03.09.2018, 16:10 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13487
Репутация: 5522 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно в С2 написать формулу
Код
=ЕСЛИ(B2="";C3;B2)
протянуть ее до С24, затем, если нужно, скопировать и вставить Спецвставка-Значения в В2:В24

Или выделить В2:В24, нажать F5 - Выделить (или вкладка Главная - Найти и выделить - Выделить группу ячеек) - пустые ячейки - ОК, затем ничего больше не делая нажать = (равно), СтрелкуВниз, одновременно две клавиши - Контрл Ентер. И снова если нужно, то выделить В2:В24, скопировать и вставить в то же место значениями
К сообщению приложен файл: 5769118_1.xlsx(11.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно в С2 написать формулу
Код
=ЕСЛИ(B2="";C3;B2)
протянуть ее до С24, затем, если нужно, скопировать и вставить Спецвставка-Значения в В2:В24

Или выделить В2:В24, нажать F5 - Выделить (или вкладка Главная - Найти и выделить - Выделить группу ячеек) - пустые ячейки - ОК, затем ничего больше не делая нажать = (равно), СтрелкуВниз, одновременно две клавиши - Контрл Ентер. И снова если нужно, то выделить В2:В24, скопировать и вставить в то же место значениями

Автор - _Boroda_
Дата добавления - 03.09.2018 в 16:10
Barbos_TN Дата: Понедельник, 03.09.2018, 16:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Супер, спасибо!

Все так просто :)
А я часа 4 потерял в поиске решения...
 
Ответить
СообщениеСупер, спасибо!

Все так просто :)
А я часа 4 потерял в поиске решения...

Автор - Barbos_TN
Дата добавления - 03.09.2018 в 16:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение пустых ячеек данными из соседних ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!