Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма по фильтрам одного листа значения с другого листа - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по фильтрам одного листа значения с другого листа (Формулы/Formulas)
Сумма по фильтрам одного листа значения с другого листа
CrazyNice Дата: Вторник, 04.09.2018, 12:51 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 RUS
Добрый день!

Помогите, пожалуйста, с формулой.
Есть таблица на одном листе (территории в столбец, бренды в строку (как в шапку).
На территории может стоять фильтр.
На втором листе таблица с территориями, брендами и соответствующими значениями - все по столбцам.

Нужна формула на Лист1 по отфильтрованным территориям и бренду суммы значений с листа 2.

Знаю, что можно через суммпроизведение, промежуточные итоги и смещение, но что-то не растет кокос :-(

Заранее большое спасибо за помощь!
К сообщению приложен файл: _Excel.xlsx(9.1 Kb)
 
Ответить
СообщениеДобрый день!

Помогите, пожалуйста, с формулой.
Есть таблица на одном листе (территории в столбец, бренды в строку (как в шапку).
На территории может стоять фильтр.
На втором листе таблица с территориями, брендами и соответствующими значениями - все по столбцам.

Нужна формула на Лист1 по отфильтрованным территориям и бренду суммы значений с листа 2.

Знаю, что можно через суммпроизведение, промежуточные итоги и смещение, но что-то не растет кокос :-(

Заранее большое спасибо за помощь!

Автор - CrazyNice
Дата добавления - 04.09.2018 в 12:51
_Boroda_ Дата: Вторник, 04.09.2018, 13:04 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12984
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Сделайте как пример какой-нибудь фильтр в файле и вручную занесите нужные значения в таб.1. И файл положите сюда. А то не совсем ясно что Вы хотите


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСделайте как пример какой-нибудь фильтр в файле и вручную занесите нужные значения в таб.1. И файл положите сюда. А то не совсем ясно что Вы хотите

Автор - _Boroda_
Дата добавления - 04.09.2018 в 13:04
buka77 Дата: Вторник, 04.09.2018, 13:16 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 6 ±
Замечаний: 0% ±

Excel 2010
По какому критерию определяется количество повторений названия территорий на Листе 1? Разве там не должно быть по одному названию?
Не это ли нужно? (см. пример)
К сообщению приложен файл: 6015973.xlsx(9.7 Kb)
 
Ответить
СообщениеПо какому критерию определяется количество повторений названия территорий на Листе 1? Разве там не должно быть по одному названию?
Не это ли нужно? (см. пример)

Автор - buka77
Дата добавления - 04.09.2018 в 13:16
CrazyNice Дата: Вторник, 04.09.2018, 13:29 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 RUS
Перезалила пример
К сообщению приложен файл: 0471788.xlsx(11.0 Kb)
 
Ответить
СообщениеПерезалила пример

Автор - CrazyNice
Дата добавления - 04.09.2018 в 13:29
CrazyNice Дата: Вторник, 04.09.2018, 13:30 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 RUS
По какому критерию определяется количество повторений названия территорий на Листе 1?


Там в настоящем отчете есть рядом столбец с более мелким делением территорий, поэтому, когда ставишь фильтр, может быть несколько строк с одной и той же территорией.
 
Ответить
Сообщение
По какому критерию определяется количество повторений названия территорий на Листе 1?


Там в настоящем отчете есть рядом столбец с более мелким делением территорий, поэтому, когда ставишь фильтр, может быть несколько строк с одной и той же территорией.

Автор - CrazyNice
Дата добавления - 04.09.2018 в 13:30
_Boroda_ Дата: Вторник, 04.09.2018, 13:44 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12984
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММ(ЕЧИСЛО(ПОИСКПОЗ(Лист2!$A2:$A32;ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ($B3;СТРОКА($B4:$B15)-3;));$B4:$B15);))*(Лист2!$B2:$B32=C3)*Лист2!$C2:$C32)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 0471788_1.xlsx(11.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММ(ЕЧИСЛО(ПОИСКПОЗ(Лист2!$A2:$A32;ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ($B3;СТРОКА($B4:$B15)-3;));$B4:$B15);))*(Лист2!$B2:$B32=C3)*Лист2!$C2:$C32)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 04.09.2018 в 13:44
CrazyNice Дата: Вторник, 04.09.2018, 14:58 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 RUS
Так нужно?

Да! :D hands hands hands
Спасибо огромное!
 
Ответить
Сообщение
Так нужно?

Да! :D hands hands hands
Спасибо огромное!

Автор - CrazyNice
Дата добавления - 04.09.2018 в 14:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по фильтрам одного листа значения с другого листа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!