Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММЕСЛИМН , если в одной из ячеек есть oшибка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММЕСЛИМН , если в одной из ячеек есть oшибка (Формулы/Formulas)
СУММЕСЛИМН , если в одной из ячеек есть oшибка
bobrenja Дата: Среда, 05.09.2018, 15:56 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Как правильно написать формулу для функции СУММЕСЛИМН , если в одной из ячеек есть ошибка?
Поставлял несколько вариантов, не получилось ((

Код
=СУММЕСЛИМН(ЕСЛИ(ЕЧИСЛО(C3:C6);C3:C6;0);D3:D6;A1)
К сообщению приложен файл: ESUM.xlsx(9.0 Kb)


Сообщение отредактировал bobrenja - Среда, 05.09.2018, 15:58
 
Ответить
СообщениеКак правильно написать формулу для функции СУММЕСЛИМН , если в одной из ячеек есть ошибка?
Поставлял несколько вариантов, не получилось ((

Код
=СУММЕСЛИМН(ЕСЛИ(ЕЧИСЛО(C3:C6);C3:C6;0);D3:D6;A1)

Автор - bobrenja
Дата добавления - 05.09.2018 в 15:56
_Boroda_ Дата: Среда, 05.09.2018, 16:01 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12984
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИМН(C3:C6;D3:D6;A1;C3:C6;">-"&9^99)


Код
=СУММ((D3:D6=A1)*ЕСЛИОШИБКА(C3:C6;))

Код
=СУММ(ЕСЛИОШИБКА(C3:C6*(D3:D6=A1);))

Последние две - формулы массива. Вводится одновременным нажатием Ctrl+Shift+Enter


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИМН(C3:C6;D3:D6;A1;C3:C6;">-"&9^99)


Код
=СУММ((D3:D6=A1)*ЕСЛИОШИБКА(C3:C6;))

Код
=СУММ(ЕСЛИОШИБКА(C3:C6*(D3:D6=A1);))

Последние две - формулы массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 05.09.2018 в 16:01
bobrenja Дата: Среда, 05.09.2018, 16:02 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Работает. Что значит ">-"&9^9?
 
Ответить
СообщениеРаботает. Что значит ">-"&9^9?

Автор - bobrenja
Дата добавления - 05.09.2018 в 16:02
_Boroda_ Дата: Среда, 05.09.2018, 16:06 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12984
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
">-"&9^9 - больше минус 9 в степени 99

9^99 - очень большое отрицательное число, примерно 2,9*10^94
-29 512 665 430 652 800 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000
Вместо нулей там какие-то цифры


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение">-"&9^9 - больше минус 9 в степени 99

9^99 - очень большое отрицательное число, примерно 2,9*10^94
-29 512 665 430 652 800 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000
Вместо нулей там какие-то цифры

Автор - _Boroda_
Дата добавления - 05.09.2018 в 16:06
bobrenja Дата: Среда, 05.09.2018, 16:08 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
_Boroda_, ноль дает формула

Код
=СУММ((D3:D6=A1)*ЕСЛИОШИБКА(C3:C6;))
 
Ответить
Сообщение_Boroda_, ноль дает формула

Код
=СУММ((D3:D6=A1)*ЕСЛИОШИБКА(C3:C6;))

Автор - bobrenja
Дата добавления - 05.09.2018 в 16:08
_Boroda_ Дата: Среда, 05.09.2018, 16:09 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12984
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вводится одновременным нажатием Ctrl+Shift+Enter


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 05.09.2018 в 16:09
bobrenja Дата: Среда, 05.09.2018, 16:11 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
ссори в массив не вложил
 
Ответить
Сообщениессори в массив не вложил

Автор - bobrenja
Дата добавления - 05.09.2018 в 16:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММЕСЛИМН , если в одной из ячеек есть oшибка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!