Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Второе или n-е вхождение по 2м условиям. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Второе или n-е вхождение по 2м условиям. (Формулы/Formulas)
Второе или n-е вхождение по 2м условиям.
bobrenja Дата: Среда, 05.09.2018, 21:08 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Все не могу решить вариант.
Вроде и решения есть, но не могу применить.
В файле все.
К сообщению приложен файл: search.xlsx(10.8 Kb)


Сообщение отредактировал bobrenja - Среда, 05.09.2018, 21:09
 
Ответить
СообщениеВсе не могу решить вариант.
Вроде и решения есть, но не могу применить.
В файле все.

Автор - bobrenja
Дата добавления - 05.09.2018 в 21:08
_Boroda_ Дата: Среда, 05.09.2018, 21:20 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13487
Репутация: 5522 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(D:D;НАИМЕНЬШИЙ(ЕСЛИ(B4:B14&C4:C14=G4&F4;СТРОКА(B4:B14));2))

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Все это можно засунуть вовнутрь ЕСЛИОШИБКА
К сообщению приложен файл: search_1.xlsx(10.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(D:D;НАИМЕНЬШИЙ(ЕСЛИ(B4:B14&C4:C14=G4&F4;СТРОКА(B4:B14));2))

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Все это можно засунуть вовнутрь ЕСЛИОШИБКА

Автор - _Boroda_
Дата добавления - 05.09.2018 в 21:20
bobrenja Дата: Среда, 05.09.2018, 21:20 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Решил проблему с допом, но нужно без доп.столбца. (
 
Ответить
СообщениеРешил проблему с допом, но нужно без доп.столбца. (

Автор - bobrenja
Дата добавления - 05.09.2018 в 21:20
bobrenja Дата: Среда, 05.09.2018, 21:21 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 108
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
ага. оно )))
 
Ответить
Сообщениеага. оно )))

Автор - bobrenja
Дата добавления - 05.09.2018 в 21:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Второе или n-е вхождение по 2м условиям. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!