Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Показатель по значению последней даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Показатель по значению последней даты (Формулы/Formulas)
Показатель по значению последней даты
stoniq Дата: Пятница, 07.09.2018, 11:48 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Всем добрый день!
Прошу помочь с задачкой. В колонки А и B каждый день добавляются данные, примерно по 5 добавлений в день. Соответственно добавляется дата и сумма. В таблицу правее необходимо вытягивать самый последний показательно по конкретной дате. Например если 01.09.2018 было добавлено значение 100, значит его необходимо вытянуть в таблицу, через некоторое время ниже добавилась строчка 01.09.2018 со значением 200, значит в таблице должно быть уже 200. Пример прикрепил.
К сообщению приложен файл: 1930013.xlsx(9.5 Kb)
 
Ответить
СообщениеВсем добрый день!
Прошу помочь с задачкой. В колонки А и B каждый день добавляются данные, примерно по 5 добавлений в день. Соответственно добавляется дата и сумма. В таблицу правее необходимо вытягивать самый последний показательно по конкретной дате. Например если 01.09.2018 было добавлено значение 100, значит его необходимо вытянуть в таблицу, через некоторое время ниже добавилась строчка 01.09.2018 со значением 200, значит в таблице должно быть уже 200. Пример прикрепил.

Автор - stoniq
Дата добавления - 07.09.2018 в 11:48
_Boroda_ Дата: Пятница, 07.09.2018, 11:52 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12984
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС($B:$B;СЧЁТЕСЛИ($A:$A;"<="&D1))

С проверкой дат можно так
Код
=ЕСЛИ(СЧЁТЕСЛИ($A:$A;D1);ИНДЕКС($B:$B;СЧЁТЕСЛИ($A:$A;"<="&D1));"")
К сообщению приложен файл: 1930013_1.xlsx(10.0 Kb) · 1930013_2.xlsx(10.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС($B:$B;СЧЁТЕСЛИ($A:$A;"<="&D1))

С проверкой дат можно так
Код
=ЕСЛИ(СЧЁТЕСЛИ($A:$A;D1);ИНДЕКС($B:$B;СЧЁТЕСЛИ($A:$A;"<="&D1));"")

Автор - _Boroda_
Дата добавления - 07.09.2018 в 11:52
stoniq Дата: Пятница, 07.09.2018, 12:15 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, второй вариант вообще супер, спасибо!
 
Ответить
Сообщение_Boroda_, второй вариант вообще супер, спасибо!

Автор - stoniq
Дата добавления - 07.09.2018 в 12:15
stoniq Дата: Суббота, 08.09.2018, 13:17 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Ребят, а в случае, если после даты добавляется предыдущая дата (такое иногда бывает)? Формула уже не срабатывает (пример выделил зелёным).
К сообщению приложен файл: 0531776.xlsx(10.1 Kb)


Сообщение отредактировал stoniq - Суббота, 08.09.2018, 13:18
 
Ответить
СообщениеРебят, а в случае, если после даты добавляется предыдущая дата (такое иногда бывает)? Формула уже не срабатывает (пример выделил зелёным).

Автор - stoniq
Дата добавления - 08.09.2018 в 13:17
_Boroda_ Дата: Суббота, 08.09.2018, 13:24 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12984
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда так
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(D1=$A1:$A999);$B1:$B999);"")
К сообщению приложен файл: 0531776_1.xlsx(10.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда так
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(D1=$A1:$A999);$B1:$B999);"")

Автор - _Boroda_
Дата добавления - 08.09.2018 в 13:24
stoniq Дата: Суббота, 08.09.2018, 13:45 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, отлично работает, очень странно, что отказывается в гугл таблицах работать, впервые такое
 
Ответить
Сообщение_Boroda_, отлично работает, очень странно, что отказывается в гугл таблицах работать, впервые такое

Автор - stoniq
Дата добавления - 08.09.2018 в 13:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Показатель по значению последней даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!