Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти наибольшую дату в списке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти наибольшую дату в списке (Формулы/Formulas)
Найти наибольшую дату в списке
l-lisa Дата: Вторник, 09.10.2018, 15:57 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 162
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Добрый день, у меня есть два столбца, в первом-ID, а во втором находятся даты, подскажите пожалуйста,как можно найти для каждого ID наибольшую дату
К сообщению приложен файл: 5088375.xlsx(8.6 Kb)
 
Ответить
СообщениеДобрый день, у меня есть два столбца, в первом-ID, а во втором находятся даты, подскажите пожалуйста,как можно найти для каждого ID наибольшую дату

Автор - l-lisa
Дата добавления - 09.10.2018 в 15:57
_Boroda_ Дата: Вторник, 09.10.2018, 16:22 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13189
Репутация: 5424 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Даты точно всегда по возрастанию?
Тогда так
Код
=ЕСЛИ(ЕЧИСЛО(B2)*(A2<>A3);C2;"")

Если нет, то так
Код
=ЕСЛИ((МАКС(ИНДЕКС((A$2:A$99=A2)*Ч(+B$2:B$99);))=B2)*(A$2:A$99=A2);B2;"")

Примерчик бы побольше не помешал
И сколько строк в реальном файле7?
К сообщению приложен файл: 5088375_1.xlsx(9.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДаты точно всегда по возрастанию?
Тогда так
Код
=ЕСЛИ(ЕЧИСЛО(B2)*(A2<>A3);C2;"")

Если нет, то так
Код
=ЕСЛИ((МАКС(ИНДЕКС((A$2:A$99=A2)*Ч(+B$2:B$99);))=B2)*(A$2:A$99=A2);B2;"")

Примерчик бы побольше не помешал
И сколько строк в реальном файле7?

Автор - _Boroda_
Дата добавления - 09.10.2018 в 16:22
TimSha Дата: Вторник, 09.10.2018, 16:37 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 591
Репутация: 91 ±
Замечаний: 0% ±

Excel 2013 Pro +
как можно найти для каждого ID наибольшую дату

Сводной таблицей. Как вариант.


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
как можно найти для каждого ID наибольшую дату

Сводной таблицей. Как вариант.

Автор - TimSha
Дата добавления - 09.10.2018 в 16:37
l-lisa Дата: Вторник, 09.10.2018, 17:15 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 162
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Спасибо за помощь! _Boroda_, hands
 
Ответить
СообщениеСпасибо за помощь! _Boroda_, hands

Автор - l-lisa
Дата добавления - 09.10.2018 в 17:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти наибольшую дату в списке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!