Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/fx для "текст содержит" и присвоение других значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » fx для "текст содержит" и присвоение других значений (Формулы/Formulas)
fx для "текст содержит" и присвоение других значений
abolshoy Дата: Четверг, 11.10.2018, 19:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
собственно что-то у меня приступ тупизма:

есть столбец с текстом, нужно сравнить ячейку с 2мя вариантами текста
если есть в ячейке слово "синее" то в соседнюю ячейку записать значение из другой ячейки, а если есть слово "желтая", то соответственно значение из другой ячейки

спасибо
К сообщению приложен файл: 9489552.xlsx(8.9 Kb)
 
Ответить
Сообщениесобственно что-то у меня приступ тупизма:

есть столбец с текстом, нужно сравнить ячейку с 2мя вариантами текста
если есть в ячейке слово "синее" то в соседнюю ячейку записать значение из другой ячейки, а если есть слово "желтая", то соответственно значение из другой ячейки

спасибо

Автор - abolshoy
Дата добавления - 11.10.2018 в 19:58
Nic70y Дата: Четверг, 11.10.2018, 20:01 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4891
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("синее";E7));$K$2;ЕСЛИ(ЕЧИСЛО(ПОИСК("желтая";E7));$L$2;""))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("синее";E7));$K$2;ЕСЛИ(ЕЧИСЛО(ПОИСК("желтая";E7));$L$2;""))

Автор - Nic70y
Дата добавления - 11.10.2018 в 20:01
abolshoy Дата: Четверг, 11.10.2018, 20:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
благодарю

и далее опять стопарнулся

если в столбце D значение 100, нужно выбрать значение из столбца G то, которое содержит букву "C" в столбце С
К сообщению приложен файл: 8028599.xlsx(9.7 Kb)
 
Ответить
Сообщениеблагодарю

и далее опять стопарнулся

если в столбце D значение 100, нужно выбрать значение из столбца G то, которое содержит букву "C" в столбце С

Автор - abolshoy
Дата добавления - 11.10.2018 в 20:56
Nic70y Дата: Четверг, 11.10.2018, 21:01 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4891
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
а если не 100?
а если не "C"?
что тогда?
нарисуйте в примере, что должно получиться в каждой строке


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеа если не 100?
а если не "C"?
что тогда?
нарисуйте в примере, что должно получиться в каждой строке

Автор - Nic70y
Дата добавления - 11.10.2018 в 21:01
abolshoy Дата: Четверг, 11.10.2018, 21:08 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
попытался изобразить
К сообщению приложен файл: 9174224.xlsx(10.2 Kb)


Сообщение отредактировал abolshoy - Четверг, 11.10.2018, 21:10
 
Ответить
Сообщениепопытался изобразить

Автор - abolshoy
Дата добавления - 11.10.2018 в 21:08
Karataev Дата: Четверг, 11.10.2018, 21:13 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1261
Репутация: 487 ±
Замечаний: 0% ±

Excel
для "L18":
Код
=ВПР(B18;$C$4:$G$11;5;0)
К сообщению приложен файл: 9174224_kar.xlsx(10.4 Kb)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
Сообщениедля "L18":
Код
=ВПР(B18;$C$4:$G$11;5;0)

Автор - Karataev
Дата добавления - 11.10.2018 в 21:13
abolshoy Дата: Четверг, 11.10.2018, 21:38 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
огромное человеческое Мерси
 
Ответить
Сообщениеогромное человеческое Мерси

Автор - abolshoy
Дата добавления - 11.10.2018 в 21:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » fx для "текст содержит" и присвоение других значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!