Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Необходимо просуммировать часы по проектам из таймшитов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Необходимо просуммировать часы по проектам из таймшитов (Формулы/Formulas)
Необходимо просуммировать часы по проектам из таймшитов
troitca Дата: Среда, 17.10.2018, 17:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Уважаемые знатоки, просьба помочь по следующему вопросу:

Есть ежемесячные таймшиты, в которых сотрудники заполняют ежедневное количество часов по каждому коду проекта. Для примера в файле апрельский и майский таймшиты (вкладки Апрель и Май). На вкладке Base таймшиты вставлены сверху вниз и слева в столбце просто протянут месяц ручками. Возможно, для решения задачи лучше сразу их транспонировать, собирая базу (правда фамилии сверху будут, но они пока не нужны).

Количество и состав сотрудников меняется от месяца к месяцу. Каждый сотрудник может работать на любом проекте и на разных проектах в течение месяца.
Необходимо собрать в одной таблице часы попроектно и помесячно (пока хотя бы не по сотрудникам), пример таблички на вкладке Base. Просьба помочь. Такое ощущение, что нужно как-то просуммировать все index match кода проекта и месяца, но не пойму, как это сделать, так как совпадение кода и месяца может встречаться не один раз, а много раз, в разных колонках и в разных столбцах.

Также немного оффтоп к обработке массива: просьба рассказать, как убрать все пустые столбцы. Пробовала выделить всю таблицу, Find&Select-Go to special-Blanks-Delete columns. Выделяет все пустые ячейки, но удаляет не только пустые колонки, но и почти все непустые тоже...

Просьба помочь формулами, а не макросами.
Заранее большое спасибо.
К сообщению приложен файл: ______.xls(99.0 Kb)


Сообщение отредактировал troitca - Среда, 17.10.2018, 18:02
 
Ответить
СообщениеУважаемые знатоки, просьба помочь по следующему вопросу:

Есть ежемесячные таймшиты, в которых сотрудники заполняют ежедневное количество часов по каждому коду проекта. Для примера в файле апрельский и майский таймшиты (вкладки Апрель и Май). На вкладке Base таймшиты вставлены сверху вниз и слева в столбце просто протянут месяц ручками. Возможно, для решения задачи лучше сразу их транспонировать, собирая базу (правда фамилии сверху будут, но они пока не нужны).

Количество и состав сотрудников меняется от месяца к месяцу. Каждый сотрудник может работать на любом проекте и на разных проектах в течение месяца.
Необходимо собрать в одной таблице часы попроектно и помесячно (пока хотя бы не по сотрудникам), пример таблички на вкладке Base. Просьба помочь. Такое ощущение, что нужно как-то просуммировать все index match кода проекта и месяца, но не пойму, как это сделать, так как совпадение кода и месяца может встречаться не один раз, а много раз, в разных колонках и в разных столбцах.

Также немного оффтоп к обработке массива: просьба рассказать, как убрать все пустые столбцы. Пробовала выделить всю таблицу, Find&Select-Go to special-Blanks-Delete columns. Выделяет все пустые ячейки, но удаляет не только пустые колонки, но и почти все непустые тоже...

Просьба помочь формулами, а не макросами.
Заранее большое спасибо.

Автор - troitca
Дата добавления - 17.10.2018 в 17:49
Pelena Дата: Среда, 17.10.2018, 18:11 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13225
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
часы попроектно и помесячно

формула массива
Код
=СУММ(($D$4:$EG$20=$A28)*ЕСЛИ(ЕЧИСЛО($D$5:$EG$21);$D$5:$EG$21;0)*($A$4:$A$20=B$27))
К сообщению приложен файл: _1_.xlsx(53.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
часы попроектно и помесячно

формула массива
Код
=СУММ(($D$4:$EG$20=$A28)*ЕСЛИ(ЕЧИСЛО($D$5:$EG$21);$D$5:$EG$21;0)*($A$4:$A$20=B$27))

Автор - Pelena
Дата добавления - 17.10.2018 в 18:11
troitca Дата: Среда, 17.10.2018, 18:28 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
формула массива

=СУММ(($D$4:$EG$20=$A28)*ЕСЛИ(ЕЧИСЛО($D$5:$EG$21);$D$5:$EG$21;0)*($A$4:$A$20=B$27))


спасибо большое! попробую на всю базу затянуть и отпишусь по результатам!)))
 
Ответить
Сообщение
формула массива

=СУММ(($D$4:$EG$20=$A28)*ЕСЛИ(ЕЧИСЛО($D$5:$EG$21);$D$5:$EG$21;0)*($A$4:$A$20=B$27))


спасибо большое! попробую на всю базу затянуть и отпишусь по результатам!)))

Автор - troitca
Дата добавления - 17.10.2018 в 18:28
Светлый Дата: Четверг, 18.10.2018, 05:54 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 707
Репутация: 187 ±
Замечаний: 0% ±

Excel 2010
формула массива

Немного сокращу формулу Елены. Сам недавно узнал этот трюк:
Код
=СУММ(($D$4:$EG$20=$A28)*Ч(+$D$5:$EG$21)*($A$4:$A$20=B$27))


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
формула массива

Немного сокращу формулу Елены. Сам недавно узнал этот трюк:
Код
=СУММ(($D$4:$EG$20=$A28)*Ч(+$D$5:$EG$21)*($A$4:$A$20=B$27))

Автор - Светлый
Дата добавления - 18.10.2018 в 05:54
_Boroda_ Дата: Четверг, 18.10.2018, 07:47 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну тогда уж и я массивность уберу
Код
=СУММПРОИЗВ(($D$4:$EG$20=$A28)*($A$4:$A$20=B$27);$D$5:$EG$21)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНу тогда уж и я массивность уберу
Код
=СУММПРОИЗВ(($D$4:$EG$20=$A28)*($A$4:$A$20=B$27);$D$5:$EG$21)

Автор - _Boroda_
Дата добавления - 18.10.2018 в 07:47
troitca Дата: Четверг, 18.10.2018, 09:21 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата Светлый, 18.10.2018 в 05:54, в сообщении № 4 ()
Немного сокращу формулу Елены. Сам недавно узнал этот трюк:

=СУММ(($D$4:$EG$20=$A28)*Ч(+$D$5:$EG$21)*($A$4:$A$20=B$27))


Ув. Светлый, а не могли бы вы файлик прикрепить, получаю #value! у себя..
Спасибо


Сообщение отредактировал troitca - Четверг, 18.10.2018, 09:45
 
Ответить
Сообщение
Цитата Светлый, 18.10.2018 в 05:54, в сообщении № 4 ()
Немного сокращу формулу Елены. Сам недавно узнал этот трюк:

=СУММ(($D$4:$EG$20=$A28)*Ч(+$D$5:$EG$21)*($A$4:$A$20=B$27))


Ув. Светлый, а не могли бы вы файлик прикрепить, получаю #value! у себя..
Спасибо

Автор - troitca
Дата добавления - 18.10.2018 в 09:21
troitca Дата: Четверг, 18.10.2018, 09:27 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ну тогда уж и я массивность уберу
=СУММПРОИЗВ(($D$4:$EG$20=$A28)*($A$4:$A$20=B$27);$D$5:$EG$21)


Ув. _Boroda_
Пытаюсь научиться активно пользоваться sumproduct, но что-то никак у меня синтаксис в голове не уложится, или может после декрета еще совсем не варит голова :'(

Подскажите, пожалуйста, если не нужно помесячно считать, а нужно просто просуммировать часы по каждому проекту, почему не будет работать формула
Код
=SUMPRODUCT(($D$4:$EG$20=$A28)*$D$5:$EG$21)

Когда $D$4:$EG$20=$A28 находит код проекта, присваивает значение 1 и перемножает на следующую ячейку внизу среди $D$5:$EG$21. Разве не так?

Спасибо...


Сообщение отредактировал troitca - Четверг, 18.10.2018, 09:48
 
Ответить
Сообщение
Ну тогда уж и я массивность уберу
=СУММПРОИЗВ(($D$4:$EG$20=$A28)*($A$4:$A$20=B$27);$D$5:$EG$21)


Ув. _Boroda_
Пытаюсь научиться активно пользоваться sumproduct, но что-то никак у меня синтаксис в голове не уложится, или может после декрета еще совсем не варит голова :'(

Подскажите, пожалуйста, если не нужно помесячно считать, а нужно просто просуммировать часы по каждому проекту, почему не будет работать формула
Код
=SUMPRODUCT(($D$4:$EG$20=$A28)*$D$5:$EG$21)

Когда $D$4:$EG$20=$A28 находит код проекта, присваивает значение 1 и перемножает на следующую ячейку внизу среди $D$5:$EG$21. Разве не так?

Спасибо...

Автор - troitca
Дата добавления - 18.10.2018 в 09:27
Pelena Дата: Четверг, 18.10.2018, 09:44 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 13225
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
troitca, формулы надо оформлять тегами с помощью кнопки fx в режиме правки поста. Исправьте.

По теме: в диапазоне $D$5:$EG$21 не только числа, а перемножение на текст даёт ошибку. Именно поэтому у меня в формуле стоит проверка ЕЧИСЛО() и у Светлого тоже в виде Ч(+...
А формулу Александра можно так записать
Код
=СУММПРОИЗВ(--($D$4:$EG$20=$A28);$D$5:$EG$21)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеtroitca, формулы надо оформлять тегами с помощью кнопки fx в режиме правки поста. Исправьте.

По теме: в диапазоне $D$5:$EG$21 не только числа, а перемножение на текст даёт ошибку. Именно поэтому у меня в формуле стоит проверка ЕЧИСЛО() и у Светлого тоже в виде Ч(+...
А формулу Александра можно так записать
Код
=СУММПРОИЗВ(--($D$4:$EG$20=$A28);$D$5:$EG$21)

Автор - Pelena
Дата добавления - 18.10.2018 в 09:44
troitca Дата: Четверг, 18.10.2018, 09:51 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
По теме: в диапазоне $D$5:$EG$21 не только числа, а перемножение на текст даёт ошибку. Именно поэтому у меня в формуле стоит проверка ЕЧИСЛО() и у Светлого тоже в виде Ч(+...


А у Бороды нет проверки на число, но формула работает. Поэтому пытаюсь разобраться в синтаксисе.
 
Ответить
Сообщение
По теме: в диапазоне $D$5:$EG$21 не только числа, а перемножение на текст даёт ошибку. Именно поэтому у меня в формуле стоит проверка ЕЧИСЛО() и у Светлого тоже в виде Ч(+...


А у Бороды нет проверки на число, но формула работает. Поэтому пытаюсь разобраться в синтаксисе.

Автор - troitca
Дата добавления - 18.10.2018 в 09:51
Pelena Дата: Четверг, 18.10.2018, 09:53 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 13225
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Ответила выше


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеОтветила выше

Автор - Pelena
Дата добавления - 18.10.2018 в 09:53
troitca Дата: Четверг, 18.10.2018, 09:59 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ответила выше

Спасибо, увидела. Соответственно и
Код
=SUMPRODUCT(($D$4:$EG$20=$A29)*1;$D$5:$EG$21)
тоже работает. Вроде более-менее проясняется :)

А про удаление кучи пустых столбцов не подскажете мне еще? Или может в какую тему отправите другую?) Спасибо заранее.
 
Ответить
Сообщение
Ответила выше

Спасибо, увидела. Соответственно и
Код
=SUMPRODUCT(($D$4:$EG$20=$A29)*1;$D$5:$EG$21)
тоже работает. Вроде более-менее проясняется :)

А про удаление кучи пустых столбцов не подскажете мне еще? Или может в какую тему отправите другую?) Спасибо заранее.

Автор - troitca
Дата добавления - 18.10.2018 в 09:59
Pelena Дата: Четверг, 18.10.2018, 10:01 | Сообщение № 12
Группа: Админы
Ранг: Местный житель
Сообщений: 13225
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
про удаление кучи пустых столбцов
создайте новую тему


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
про удаление кучи пустых столбцов
создайте новую тему

Автор - Pelena
Дата добавления - 18.10.2018 в 10:01
_Boroda_ Дата: Четверг, 18.10.2018, 10:05 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А у Бороды нет проверки на число

Дело в том, что если делать конструкцию типа ааа*ввв, то и ааа, и ввв должны быть числовыми, чтобы умножение нормально прошло.
А если мы внутри СУММПРОИЗВ пишем В РАЗНЫХ аргументах массивы с текстом СУММПРОИЗВ(ааа;ввв), то он (текст) игнорируется. Почитайте справку СУММПРОИЗВ, там про это написано


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
А у Бороды нет проверки на число

Дело в том, что если делать конструкцию типа ааа*ввв, то и ааа, и ввв должны быть числовыми, чтобы умножение нормально прошло.
А если мы внутри СУММПРОИЗВ пишем В РАЗНЫХ аргументах массивы с текстом СУММПРОИЗВ(ааа;ввв), то он (текст) игнорируется. Почитайте справку СУММПРОИЗВ, там про это написано

Автор - _Boroda_
Дата добавления - 18.10.2018 в 10:05
troitca Дата: Четверг, 18.10.2018, 10:57 | Сообщение № 14
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Хорошо, спасибо)
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
 
Ответить
СообщениеХорошо, спасибо)
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Автор - troitca
Дата добавления - 18.10.2018 в 10:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Необходимо просуммировать часы по проектам из таймшитов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!