Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразовать "текст" в "время" - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразовать "текст" в "время" (Формулы/Formulas)
Преобразовать "текст" в "время"
potapov14 Дата: Четверг, 18.10.2018, 12:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.

Есть таблица с колонкой времени в формате:
1m 59s

Суть в том, что может в колонке написано быть просто 59s (без 1m)

Как легко можно такое преобразовать в 01:59 ?
К сообщению приложен файл: time.xlsx(8.2 Kb)
 
Ответить
СообщениеДобрый день.

Есть таблица с колонкой времени в формате:
1m 59s

Суть в том, что может в колонке написано быть просто 59s (без 1m)

Как легко можно такое преобразовать в 01:59 ?

Автор - potapov14
Дата добавления - 18.10.2018 в 12:56
_Boroda_ Дата: Четверг, 18.10.2018, 13:38 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=--(ЕСЛИ(ДЛСТР(A2)>3;"0:";"0:0:")&ПОДСТАВИТЬ(ЛЕВБ(A2;ДЛСТР(A2)-1);"m";":"))

С учетом того, что часов нет и 00 секунд пишется
К сообщению приложен файл: time_1.xlsx(8.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=--(ЕСЛИ(ДЛСТР(A2)>3;"0:";"0:0:")&ПОДСТАВИТЬ(ЛЕВБ(A2;ДЛСТР(A2)-1);"m";":"))

С учетом того, что часов нет и 00 секунд пишется

Автор - _Boroda_
Дата добавления - 18.10.2018 в 13:38
potapov14 Дата: Четверг, 18.10.2018, 13:51 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, но в случае, когда в колонке написано просто 1m, то результат считает это как за секунду.
 
Ответить
СообщениеСпасибо, но в случае, когда в колонке написано просто 1m, то результат считает это как за секунду.

Автор - potapov14
Дата добавления - 18.10.2018 в 13:51
Nic70y Дата: Четверг, 18.10.2018, 14:07 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4891
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
Код
=--ПОДСТАВИТЬ(ПОДСТАВИТЬ(ЕСЛИ(ЕЧИСЛО(ПОИСК("m";A2));"";"0m")&A2;"m";":");"s";)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=--ПОДСТАВИТЬ(ПОДСТАВИТЬ(ЕСЛИ(ЕЧИСЛО(ПОИСК("m";A2));"";"0m")&A2;"m";":");"s";)

Автор - Nic70y
Дата добавления - 18.10.2018 в 14:07
_Boroda_ Дата: Четверг, 18.10.2018, 14:25 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
в случае, когда в колонке написано просто 1m
У Вас ни в примере, ни в описании ничего про это не говорится, поэтому я и предположил
С учетом того, что часов нет и 00 секунд пишется

тогда так
Код
=--(ЕСЛИ(СЧЁТ(ПОИСК("m";A2));"0:";"0:0:")&ПОДСТАВИТЬ(ЛЕВБ(A2;ДЛСТР(A2)-1);"m";":"))

И Вам действительно нужно минуты-секунды писать в формате часы-минуты?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
в случае, когда в колонке написано просто 1m
У Вас ни в примере, ни в описании ничего про это не говорится, поэтому я и предположил
С учетом того, что часов нет и 00 секунд пишется

тогда так
Код
=--(ЕСЛИ(СЧЁТ(ПОИСК("m";A2));"0:";"0:0:")&ПОДСТАВИТЬ(ЛЕВБ(A2;ДЛСТР(A2)-1);"m";":"))

И Вам действительно нужно минуты-секунды писать в формате часы-минуты?

Автор - _Boroda_
Дата добавления - 18.10.2018 в 14:25
potapov14 Дата: Четверг, 18.10.2018, 16:10 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо всем за помощь! Вы мне очень помогли!!!
 
Ответить
СообщениеСпасибо всем за помощь! Вы мне очень помогли!!!

Автор - potapov14
Дата добавления - 18.10.2018 в 16:10
krosav4ig Дата: Четверг, 18.10.2018, 16:37 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1698
Репутация: 699 ±
Замечаний: 0% ±

Excel 2007,2010,2013
еще вариант, массивная формула
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(0&A4;ПОИСК({"h";"m";"s"};0&A4)-2;2)/24/60^{0;1;2};))


(_)Õvõ(_)
 
Ответить
Сообщениееще вариант, массивная формула
Код
=СУММ(ЕСЛИОШИБКА(ПСТР(0&A4;ПОИСК({"h";"m";"s"};0&A4)-2;2)/24/60^{0;1;2};))

Автор - krosav4ig
Дата добавления - 18.10.2018 в 16:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразовать "текст" в "время" (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!