Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет числа единиц - по месяцам - в таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет числа единиц - по месяцам - в таблице (Формулы/Formulas)
Подсчет числа единиц - по месяцам - в таблице
cerber412 Дата: Четверг, 18.10.2018, 16:43 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер. Подскажите такую вещь.

В столбцах D,E,F - находятся данные по дате.
А в столбце I - находятся нули и единицы.

Как преобразовать этот массив данных - в таблицу, которая приведена в диапазоне P11:Q25 ?
(В общем там задача в том, чтобы подсчитать сумму единиц - в конкретном месяце, а затем подсчитать сумму единиц для других месяцев. Подсчитать с учетом года)
К сообщению приложен файл: 1187844.xls(40.5 Kb)
 
Ответить
СообщениеДобрый вечер. Подскажите такую вещь.

В столбцах D,E,F - находятся данные по дате.
А в столбце I - находятся нули и единицы.

Как преобразовать этот массив данных - в таблицу, которая приведена в диапазоне P11:Q25 ?
(В общем там задача в том, чтобы подсчитать сумму единиц - в конкретном месяце, а затем подсчитать сумму единиц для других месяцев. Подсчитать с учетом года)

Автор - cerber412
Дата добавления - 18.10.2018 в 16:43
lebensvoll Дата: Четверг, 18.10.2018, 17:00 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 830
Репутация: 15 ±
Замечаний: 0% ±

Excel 2010
cerber412, ПОПРОБУЙТЕ В ЯЧЕЙКУ Q11 (ПРОСУММИРОВАТЬ ЧТОБ ЗНАЧЕНИЯ ЗА 2017 МАЙ ПРОПИСАТЬ ФОРМУЛУ)
Код
=СУММПРОИЗВ(I14:I49*(СЦЕПИТЬ(F14:F49;" ";E14:E49)=P11))


Кто бы ты ни был, мир в твоих руках
 
Ответить
Сообщениеcerber412, ПОПРОБУЙТЕ В ЯЧЕЙКУ Q11 (ПРОСУММИРОВАТЬ ЧТОБ ЗНАЧЕНИЯ ЗА 2017 МАЙ ПРОПИСАТЬ ФОРМУЛУ)
Код
=СУММПРОИЗВ(I14:I49*(СЦЕПИТЬ(F14:F49;" ";E14:E49)=P11))

Автор - lebensvoll
Дата добавления - 18.10.2018 в 17:00
cerber412 Дата: Четверг, 18.10.2018, 17:05 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
lebensvoll, в вашей формуле - идет ссылка на ячейку P11.
Но эта ячейка - изначально пустая.

Откуда формула узнает, что там должно быть написано "2017 май" ?


Сообщение отредактировал cerber412 - Четверг, 18.10.2018, 17:06
 
Ответить
Сообщениеlebensvoll, в вашей формуле - идет ссылка на ячейку P11.
Но эта ячейка - изначально пустая.

Откуда формула узнает, что там должно быть написано "2017 май" ?

Автор - cerber412
Дата добавления - 18.10.2018 в 17:05
sboy Дата: Четверг, 18.10.2018, 17:08 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2198
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Удалить пустые, дать названия столбцам и стройте сводную с диаграммой
К сообщению приложен файл: 1187844.xlsx(20.3 Kb)
 
Ответить
СообщениеДобрый день.
Удалить пустые, дать названия столбцам и стройте сводную с диаграммой

Автор - sboy
Дата добавления - 18.10.2018 в 17:08
cerber412 Дата: Четверг, 18.10.2018, 17:09 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
sboy, нет - решение со сводной диаграммой не подходит.

Я спрашивал именно про формулу для диапазона P11:Q25
 
Ответить
Сообщениеsboy, нет - решение со сводной диаграммой не подходит.

Я спрашивал именно про формулу для диапазона P11:Q25

Автор - cerber412
Дата добавления - 18.10.2018 в 17:09
lebensvoll Дата: Четверг, 18.10.2018, 17:17 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 830
Репутация: 15 ±
Замечаний: 0% ±

Excel 2010
cerber412, НУ ВО ПЕРВЫХ
Я лишь работал с тем что было в вашем файле и в данной ячейке P11 у вас написано 2017 май
а в P12 2017 август и т.д.
Что дали то и получите.
Ну и во вторых
формула просуммирует те значения которые вы укажете в ячейке P11 НО. лишь только так как вы указали в своем файле 2017 май; 2018 март и т.д
Ставьте конкретнее задачи
К сообщению приложен файл: 4779832.xlsx(14.6 Kb)


Кто бы ты ни был, мир в твоих руках

Сообщение отредактировал lebensvoll - Четверг, 18.10.2018, 17:20
 
Ответить
Сообщениеcerber412, НУ ВО ПЕРВЫХ
Я лишь работал с тем что было в вашем файле и в данной ячейке P11 у вас написано 2017 май
а в P12 2017 август и т.д.
Что дали то и получите.
Ну и во вторых
формула просуммирует те значения которые вы укажете в ячейке P11 НО. лишь только так как вы указали в своем файле 2017 май; 2018 март и т.д
Ставьте конкретнее задачи

Автор - lebensvoll
Дата добавления - 18.10.2018 в 17:17
sboy Дата: Четверг, 18.10.2018, 17:21 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2198
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Цитата
именно про формулу

а, так вам шашечки :)
держите
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$14:$F$49&" "&$E$14:$E$49;АГРЕГАТ(15;6;(СТРОКА($E$14:$E$49)-13)/(ПОИСКПОЗ($F$14:$F$49&$E$14:$E$49;$F$14:$F$49&$E$14:$E$49;)=(СТРОКА($E$14:$E$49)-13));СТРОКА(A1)));"")

Код
=СУММПРОИЗВ(($F$14:$F$49&" "&$E$14:$E$49=N34)*$G$14:$G$49)
К сообщению приложен файл: 3924882.xls(34.0 Kb)


Сообщение отредактировал sboy - Четверг, 18.10.2018, 17:22
 
Ответить
Сообщение
Цитата
именно про формулу

а, так вам шашечки :)
держите
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$14:$F$49&" "&$E$14:$E$49;АГРЕГАТ(15;6;(СТРОКА($E$14:$E$49)-13)/(ПОИСКПОЗ($F$14:$F$49&$E$14:$E$49;$F$14:$F$49&$E$14:$E$49;)=(СТРОКА($E$14:$E$49)-13));СТРОКА(A1)));"")

Код
=СУММПРОИЗВ(($F$14:$F$49&" "&$E$14:$E$49=N34)*$G$14:$G$49)

Автор - sboy
Дата добавления - 18.10.2018 в 17:21
cerber412 Дата: Четверг, 18.10.2018, 17:25 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
и в данной ячейке P11 у вас написано 2017 май


А напротив данной ячейки P11 - в моем файле - написано число "2"
По вашей логике - можно сказать, что и так все хорошо, поскольку в диапазоне "P11:Q25" - уже и так стоят данные.
Я их туда поставил для примера, чтобы было понятно - каким должен получится итог.

Вопрос звучал так:
Как преобразовать этот массив данных (столбцы D,E,F, I) - в таблицу, которая приведена в диапазоне P11:Q25 ?
 
Ответить
Сообщение
и в данной ячейке P11 у вас написано 2017 май


А напротив данной ячейки P11 - в моем файле - написано число "2"
По вашей логике - можно сказать, что и так все хорошо, поскольку в диапазоне "P11:Q25" - уже и так стоят данные.
Я их туда поставил для примера, чтобы было понятно - каким должен получится итог.

Вопрос звучал так:
Как преобразовать этот массив данных (столбцы D,E,F, I) - в таблицу, которая приведена в диапазоне P11:Q25 ?

Автор - cerber412
Дата добавления - 18.10.2018 в 17:25
cerber412 Дата: Четверг, 18.10.2018, 17:27 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
sboy, большое спасибо. Это именно то, что нужно.
 
Ответить
Сообщениеsboy, большое спасибо. Это именно то, что нужно.

Автор - cerber412
Дата добавления - 18.10.2018 в 17:27
lebensvoll Дата: Четверг, 18.10.2018, 17:41 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 830
Репутация: 15 ±
Замечаний: 0% ±

Excel 2010
cerber412, Ваш вопрос изначально звучал ТАК
Цитата
Подсчет числа единиц - по месяцам - в таблице

Далее уже вы как раз таки
Цитата
Как преобразовать этот массив данных (столбцы D,E,F, I) - в таблицу, которая приведена в диапазоне P11:Q25 ?

Но потом вновь
Цитата
(В общем там задача в том, чтобы подсчитать сумму единиц - в конкретном месяце, а затем подсчитать сумму единиц для других месяцев. Подсчитать с учетом года)

Как понял так и сделал.
Спасибо Вам за науку общения...


Кто бы ты ни был, мир в твоих руках
 
Ответить
Сообщениеcerber412, Ваш вопрос изначально звучал ТАК
Цитата
Подсчет числа единиц - по месяцам - в таблице

Далее уже вы как раз таки
Цитата
Как преобразовать этот массив данных (столбцы D,E,F, I) - в таблицу, которая приведена в диапазоне P11:Q25 ?

Но потом вновь
Цитата
(В общем там задача в том, чтобы подсчитать сумму единиц - в конкретном месяце, а затем подсчитать сумму единиц для других месяцев. Подсчитать с учетом года)

Как понял так и сделал.
Спасибо Вам за науку общения...

Автор - lebensvoll
Дата добавления - 18.10.2018 в 17:41
Nic70y Дата: Четверг, 18.10.2018, 21:17 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4891
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
еще вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(F$14:F$49&" "&E$14:E$49;МАКС(13-СТРОКА(P13);ЕСЛИ(F$14:F$49&" "&E$14:E$49=P10;СТРОКА(E$14:E$49)-12)));"")
Код
=СУММЕСЛИМН(I$14:I$49;$E$14:$E$49;ПСТР(P11;6;8);F$14:F$49;--ЛЕВБ(P11;4))
К сообщению приложен файл: 1482659.xls(37.0 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениееще вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(F$14:F$49&" "&E$14:E$49;МАКС(13-СТРОКА(P13);ЕСЛИ(F$14:F$49&" "&E$14:E$49=P10;СТРОКА(E$14:E$49)-12)));"")
Код
=СУММЕСЛИМН(I$14:I$49;$E$14:$E$49;ПСТР(P11;6;8);F$14:F$49;--ЛЕВБ(P11;4))

Автор - Nic70y
Дата добавления - 18.10.2018 в 21:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет числа единиц - по месяцам - в таблице (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!